aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-01-15 13:15:27 -0800
committerKhem Raj <raj.khem@gmail.com>2010-01-15 18:02:54 -0800
commiteec66cdff9d566c508778018938aad80b9563263 (patch)
tree4928c6ed4caa3cb1ee6b97a82db6d382507b28e1
parentb89042296b4ece9a867d4fe1d12194ee7cba9c38 (diff)
downloadopenembedded-eec66cdff9d566c508778018938aad80b9563263.tar.gz
cpio: Dont munge rmt during do_install on uclibc.
* cpio configure checks for sgtty.h in order to enable rmt to build as part of cpio package but this header is not available on uclibc so we have to adapt do_install accordingly. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/cpio/cpio_2.5.bb22
1 files changed, 14 insertions, 8 deletions
diff --git a/recipes/cpio/cpio_2.5.bb b/recipes/cpio/cpio_2.5.bb
index c21a59a44a..5c4ee632d7 100644
--- a/recipes/cpio/cpio_2.5.bb
+++ b/recipes/cpio/cpio_2.5.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "GNU cpio is a program to manage archives of files."
HOMEPAGE = "http://www.gnu.org/software/cpio/"
SECTION = "console"
LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
DEPENDS += " texinfo-native "
@@ -15,19 +15,25 @@ inherit autotools
do_install () {
autotools_do_install
install -d ${D}${base_bindir}/
- mv ${D}${bindir}/cpio ${D}${base_bindir}/cpio.${PN}
- mv ${D}${libexecdir}/rmt ${D}${libexecdir}/rmt.${PN}
+ mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio.${PN}"
+ case ${TARGET_OS} in
+ *-uclibc*) ;;
+ *) mv "${D}${libexecdir}/rmt" "${D}${libexecdir}/rmt.${PN}" ;;
+ esac
}
-
pkg_postinst_${PN} () {
update-alternatives --install ${base_bindir}/cpio cpio cpio.${PN} 100
- update-alternatives --install ${libexecdir}/rmt rmt rmt.${PN} 50
+ if [ -f ${libexecdir}/rmt.${PN} ]
+ then
+ update-alternatives --install ${libexecdir}/rmt rmt rmt.${PN} 50
+ fi
}
-
pkg_prerm_${PN} () {
update-alternatives --remove cpio cpio.${PN}
- update-alternatives --remove rmt rmt.${PN}
+ if [ -f ${libexecdir}/rmt.${PN} ]
+ then
+ update-alternatives --remove rmt rmt.${PN}
+ fi
}
-