aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-04-03 14:31:12 -0700
committerTom Rini <trini@embeddedalley.com>2009-04-06 14:33:02 -0700
commit439e60b246bcc741e883372f2340fc6ab7af93d3 (patch)
tree6c532ce57f0140cfbf896cab1abad2df77c0e37a
parent176aebf4b27991081071ef9df07dc5673fc17864 (diff)
downloadopenembedded-439e60b246bcc741e883372f2340fc6ab7af93d3.tar.gz
gcc-cross-sdk: Fix relocation of the toolchain and bump PR.
There's two parts to this. The first is to make relative, not absolute symlinks for 'cpp', etc. The second is that we need to configure without --with-gxx-include-dir and instead install the base C++ headers into the expected location. The path passed to --with-gxx-include-dir will not be relocated and is an absolute. Acked-by: Florian Boor <florian.boor@kernelconcepts.de> Acked-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tom Rini <trini@embeddedalley.com>
-rw-r--r--recipes/gcc/gcc-configure-sdk.inc3
-rw-r--r--recipes/gcc/gcc-cross-sdk_3.3.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_3.4.3.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_3.4.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.1.0.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.1.1.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.1.2.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.2.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.3.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.2.4.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.1.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.2.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_4.3.3.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_csl-arm-2007q3.bb2
-rw-r--r--recipes/gcc/gcc-package-sdk.inc3
15 files changed, 16 insertions, 16 deletions
diff --git a/recipes/gcc/gcc-configure-sdk.inc b/recipes/gcc/gcc-configure-sdk.inc
index 75080302ff..d04f6080ee 100644
--- a/recipes/gcc/gcc-configure-sdk.inc
+++ b/recipes/gcc/gcc-configure-sdk.inc
@@ -4,8 +4,7 @@ require gcc-configure-common.inc
USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}'
USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibcgnueabi", "no", "", d )}'
-EXTRA_OECONF_PATHS = "--with-gxx-include-dir=${prefix}/${TARGET_SYS}/${layout_includedir}/c++ \
- --with-sysroot=${prefix}/${TARGET_SYS} \
+EXTRA_OECONF_PATHS = "--with-sysroot=${prefix}/${TARGET_SYS} \
--with-build-time-tools=${CROSS_DIR}/${TARGET_SYS}/bin \
--with-build-sysroot=${STAGING_DIR_TARGET}"
diff --git a/recipes/gcc/gcc-cross-sdk_3.3.4.bb b/recipes/gcc/gcc-cross-sdk_3.3.4.bb
index f53c5d321a..ed9c18c557 100644
--- a/recipes/gcc/gcc-cross-sdk_3.3.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_3.3.4.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_3.4.3.bb b/recipes/gcc/gcc-cross-sdk_3.4.3.bb
index 48a7ecd645..0b1f6613bf 100644
--- a/recipes/gcc/gcc-cross-sdk_3.4.3.bb
+++ b/recipes/gcc/gcc-cross-sdk_3.4.3.bb
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_3.4.4.bb b/recipes/gcc/gcc-cross-sdk_3.4.4.bb
index f6dd0532e3..e3346590d5 100644
--- a/recipes/gcc/gcc-cross-sdk_3.4.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_3.4.4.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.1.0.bb b/recipes/gcc/gcc-cross-sdk_4.1.0.bb
index 5caec0b5a5..6b6097fb00 100644
--- a/recipes/gcc/gcc-cross-sdk_4.1.0.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.1.0.bb
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.1.1.bb b/recipes/gcc/gcc-cross-sdk_4.1.1.bb
index 461008d2d5..a6418f6404 100644
--- a/recipes/gcc/gcc-cross-sdk_4.1.1.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.1.1.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.1.2.bb b/recipes/gcc/gcc-cross-sdk_4.1.2.bb
index 55c9ceef70..7bc24806bb 100644
--- a/recipes/gcc/gcc-cross-sdk_4.1.2.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.1.2.bb
@@ -1,4 +1,4 @@
-PR = "r9"
+PR = "r10"
require gcc-${PV}.inc
require gcc-cross-sdk.inc
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.2.bb b/recipes/gcc/gcc-cross-sdk_4.2.2.bb
index 297bd8ece8..a326263c06 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.2.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.2.bb
@@ -1,4 +1,4 @@
-PR = "r7"
+PR = "r8"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.3.bb b/recipes/gcc/gcc-cross-sdk_4.2.3.bb
index ee4ce855af..297bd8ece8 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.3.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.3.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.2.4.bb b/recipes/gcc/gcc-cross-sdk_4.2.4.bb
index 3b66660d9b..0a3af9e469 100644
--- a/recipes/gcc/gcc-cross-sdk_4.2.4.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.2.4.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.1.bb b/recipes/gcc/gcc-cross-sdk_4.3.1.bb
index 13d395833e..876c65c369 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.1.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.1.bb
@@ -1,4 +1,4 @@
-PR = "r13"
+PR = "r14"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.2.bb b/recipes/gcc/gcc-cross-sdk_4.3.2.bb
index 8057608e0d..ee4ce855af 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.2.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.2.bb
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_4.3.3.bb b/recipes/gcc/gcc-cross-sdk_4.3.3.bb
index 29ee187785..7f3e1466ce 100644
--- a/recipes/gcc/gcc-cross-sdk_4.3.3.bb
+++ b/recipes/gcc/gcc-cross-sdk_4.3.3.bb
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
inherit sdk
diff --git a/recipes/gcc/gcc-cross-sdk_csl-arm-2007q3.bb b/recipes/gcc/gcc-cross-sdk_csl-arm-2007q3.bb
index 361b0c10aa..3352e41dcb 100644
--- a/recipes/gcc/gcc-cross-sdk_csl-arm-2007q3.bb
+++ b/recipes/gcc/gcc-cross-sdk_csl-arm-2007q3.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
inherit sdk
diff --git a/recipes/gcc/gcc-package-sdk.inc b/recipes/gcc/gcc-package-sdk.inc
index 0dc19c70b4..3d9cc0c53a 100644
--- a/recipes/gcc/gcc-package-sdk.inc
+++ b/recipes/gcc/gcc-package-sdk.inc
@@ -48,7 +48,8 @@ do_install () {
# Create the ${prefix}/${TARGET_SYS}/bin/* symlinks
install -d ${D}${prefix}/${TARGET_SYS}/bin/
for l in ${D}${bindir}/*; do
- ln -sf "${bindir}/`basename $l`" "${D}${prefix}/${TARGET_SYS}/bin/`basename $l | sed -e 's,${TARGET_PREFIX},,'`"
+ echo $l
+ ln -sf "../../${layout_base_bindir}/`basename $l`" "${D}${prefix}/${TARGET_SYS}/bin/`basename $l | sed -e 's,${TARGET_PREFIX},,'`"
done
ln -sf "${bindir}/${TARGET_PREFIX}gcc${EXEEXT}" "${D}${prefix}/${TARGET_SYS}/bin/cc${EXEEXT}"