aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-16 12:05:19 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-16 12:05:19 +0200
commita420e4d129b6b4a6de18b3195161195a630a38b8 (patch)
tree8c7b342dae1977976d33d8943555f040cdf0fcab
parentfa1039ef168f11906fdac1690f3462b39e057a66 (diff)
parent91432caba81577cccd57f0eff7b0541763c30a80 (diff)
downloadopenembedded-a420e4d129b6b4a6de18b3195161195a630a38b8.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rwxr-xr-xrecipes/fbprogress/fbprogress/fbprogress-init34
-rw-r--r--recipes/fbprogress/fbprogress_1.1.bb32
3 files changed, 67 insertions, 1 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index bd78008dd0..60d53abc71 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -111,7 +111,7 @@ SRCREV_pn-libowl ?= "277"
SRCREV_pn-libxcalibrate ?= "209d83af61ed38a002c8096377deac292b3e396c"
SRCREV_pn-libxosd ?= "627"
SRCREV_pn-linux-bfin ?= "3758"
-SRCREV_pn-linux-bug ?= "8996"
+SRCREV_pn-linux-bug ?= "9110"
SRCREV_pn-linux-hackndev-2.6 ?= "1308"
SRCREV_pn-linux-ixp4xx ?= "1089"
SRCREV_pn-linux-openmoko-2.6.24 ?= "fb42ce6724576fc173faf8abfb04aa2c36d213b7"
diff --git a/recipes/fbprogress/fbprogress/fbprogress-init b/recipes/fbprogress/fbprogress/fbprogress-init
new file mode 100755
index 0000000000..c1dd3787b1
--- /dev/null
+++ b/recipes/fbprogress/fbprogress/fbprogress-init
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+. /etc/init.d/functions
+
+case "$1" in
+ start)
+ # We don't want this script to block the rest of the boot process
+ if [ "$2" != "background" ]; then
+ $0 $1 background &
+ else
+ . /etc/profile
+
+ echo "Starting FBProgress"
+ fbprogress.sh &
+ fi
+ ;;
+
+ stop)
+ echo "Stopping FBProgress"
+ killproc fbprogress.sh
+ ;;
+
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+
+ *)
+ echo "usage: $0 { start | stop | restart }"
+ ;;
+esac
+
+exit 0
diff --git a/recipes/fbprogress/fbprogress_1.1.bb b/recipes/fbprogress/fbprogress_1.1.bb
new file mode 100644
index 0000000000..8d603b8a3e
--- /dev/null
+++ b/recipes/fbprogress/fbprogress_1.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Bug framebuffer progress indicator"
+AUTHOR = "Angel Roman"
+HOMEPAGE = "http://www.buglabs.net/"
+LICENSE = "GPL"
+DEPENDS = "freetype zlib virtual/kernel"
+SRCREV = "9118"
+PR = "r1"
+
+SRC_URI = "svn://svn.buglabs.net/bug/trunk;module=com.buglabs.bug.native.fbprogress;proto=svn \
+ file://fbprogress-init"
+
+S = "${WORKDIR}/com.buglabs.bug.native.fbprogress"
+
+inherit update-rc.d
+
+EXTRA_OEMAKE = "BUG_LINUX_SRC=${STAGING_KERNEL_DIR}"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/fbprogress
+ install -m 0644 ${S}/images/* ${D}/${sysconfdir}/fbprogress/
+ install -d ${D}${layout_bindir}
+ install -m 0755 fbprogress ${D}${layout_bindir}
+ install -m 0755 fbprogress.sh ${D}${layout_bindir}
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/fbprogress-init ${D}/${sysconfdir}/init.d/fbprogress
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "bug"
+
+INITSCRIPT_NAME = "fbprogress"
+INITSCRIPT_PARAMS = "start 01 S . stop 15 0 1 2 3 4 5 6 ."