aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Lapin <slapin@ossfans.org>2009-05-14 17:03:10 +0400
committerSergey Lapin <slapin@ossfans.org>2009-05-16 16:18:09 +0400
commitf7cda20ffc2bd30fbb7db898cbffc5d273bb9bb8 (patch)
tree7a7bea1ea9d52cf5908e6c75ada341e1f1e3d476
parenta420e4d129b6b4a6de18b3195161195a630a38b8 (diff)
downloadopenembedded-f7cda20ffc2bd30fbb7db898cbffc5d273bb9bb8.tar.gz
at91bootstrap: generalization of recipes
-rw-r--r--recipes/at91bootstrap/at91bootstrap.inc21
-rw-r--r--recipes/at91bootstrap/at91bootstrap_2.10.bb28
-rw-r--r--recipes/at91bootstrap/at91bootstrap_2.4.bb7
3 files changed, 25 insertions, 31 deletions
diff --git a/recipes/at91bootstrap/at91bootstrap.inc b/recipes/at91bootstrap/at91bootstrap.inc
new file mode 100644
index 0000000000..2160f64fbc
--- /dev/null
+++ b/recipes/at91bootstrap/at91bootstrap.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "at91bootstrap: loaded into internal SRAM by AT91 BootROM"
+SECTION = "bootloaders"
+
+SRC_URI = "ftp://www.at91.com/pub/buildroot/${PN}-${PV}.tar.bz2 \
+ file://defconfig \
+ "
+S = "${WORKDIR}/${PN}-${PV}"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} DESTDIR=${DEPLOY_DIR_IMAGE} REVISION=${PR}"
+
+do_compile () {
+ unset LDFLAGS
+ unset CFLAGS
+ unset CPPFLAGS
+
+ rm -Rf ${S}/binaries
+ cp ${S}/../defconfig ${S}/.config
+ oe_runmake AT91_CUSTOM_FLAGS="${AT91BOOTSTRAP_FLAGS}"
+ oe_runmake AT91_CUSTOM_FLAGS="${AT91BOOTSTRAP_FLAGS}" boot
+ oe_runmake AT91_CUSTOM_FLAGS="${AT91BOOTSTRAP_FLAGS}" install
+}
diff --git a/recipes/at91bootstrap/at91bootstrap_2.10.bb b/recipes/at91bootstrap/at91bootstrap_2.10.bb
index a652f1b155..a68d8ef581 100644
--- a/recipes/at91bootstrap/at91bootstrap_2.10.bb
+++ b/recipes/at91bootstrap/at91bootstrap_2.10.bb
@@ -1,26 +1,2 @@
-DESCRIPTION = "at91bootstrap: loaded into internal SRAM by AT91 BootROM"
-SECTION = "bootloaders"
-
-SRC_URI = "ftp://www.at91.com/pub/buildroot/${PN}-${PV}.tar.bz2 \
- file://defconfig \
- "
-
-AT91BOOTSTRAP_FLAGS ?= ""
-
-S = "${WORKDIR}/${PN}-${PV}"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} DESTDIR=${DEPLOY_DIR_IMAGE} REVISION=${PR}"
-
-do_compile () {
- unset LDFLAGS
- unset CFLAGS
- unset CPPFLAGS
-
- rm -Rf ${S}/binaries
- cp ${S}/../defconfig ${S}/.config
- oe_runmake AT91_CUSTOM_FLAGS="${AT91BOOTSTRAP_FLAGS}"
- oe_runmake AT91_CUSTOM_FLAGS="${AT91BOOTSTRAP_FLAGS}" boot
- oe_runmake AT91_CUSTOM_FLAGS="${AT91BOOTSTRAP_FLAGS}" install
-}
-
+PR = "r1"
+require at91bootstrap.inc
diff --git a/recipes/at91bootstrap/at91bootstrap_2.4.bb b/recipes/at91bootstrap/at91bootstrap_2.4.bb
index 69c7d6c19b..e2ba34ed57 100644
--- a/recipes/at91bootstrap/at91bootstrap_2.4.bb
+++ b/recipes/at91bootstrap/at91bootstrap_2.4.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "at91bootstrap"
+require at91bootstrap.inc
SRC_URI = "ftp://www.at91.com/pub/buildroot/${PN}-${PV}.tar.bz2 \
"
SRC_URI_append_afeb9260 = " file://0001-Generic-code-changes.patch;patch=1 \
@@ -6,8 +6,7 @@ SRC_URI_append_afeb9260 = " file://0001-Generic-code-changes.patch;patch=1 \
file://0003-AFEB9260-board-support.patch;patch=1 \
file://0004-AFEB9260-133-board-support.patch;patch=1"
-PR = "r4"
-SECTION = "bootloaders"
+PR = "r5"
AT91BOOTSTRAP_MACHINE ?= "${MACHINE}"
AT91BOOTSTRAP_FLAGS ?= ""
@@ -16,8 +15,6 @@ AT91BOOTSTRAP_MEMORY ?= "dataflash"
AT91BOOTSTRAP_IMAGE = "at91bootstrap-${MACHINE}-${AT91BOOTSTRAP_MEMORY}-${PV}-${PR}.bin"
AT91BOOTSTRAP_SYMLINK = "at91bootstrap.bin"
-S = "${WORKDIR}/${PN}-${PV}"
-
PACKAGE_ARCH = "${MACHINE_ARCH}"
EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} MEMORY=${AT91BOOTSTRAP_MEMORY}"