aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-17 19:40:10 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-17 19:40:10 +0000
commita7b30f8d32100cac63a79286a2e5a10aac744d1c (patch)
tree21a37451e3649da7f2b995e32624c2c0684adb66
parent19edb1d8e5c8f04943be2d4cfeb503ceab947682 (diff)
downloadopenembedded-a7b30f8d32100cac63a79286a2e5a10aac744d1c.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/06/17 21:38:22+02:00 utwente.nl!koen xaw_7.0.2.bb: add AUXDIR patch, fixes bug #6 2005/06/17 21:06:56+02:00 utwente.nl!koen maemo-image.bb: prefer some versions and providers 2005/06/17 20:57:55+02:00 utwente.nl!koen osso-core-config_200515.1.bb: tweak osso-core-config postinst, courtesy Florian Boor add dbus-0.23.1-osso, courtesy Florian Boor BKrev: 42b3271axW-O5s3qTWvT15Ugo3C0YQ
-rw-r--r--packages/dbus/dbus/0.23.1.diff0
-rw-r--r--packages/dbus/dbus/config.diff0
-rw-r--r--packages/dbus/dbus/dbus-monitor.patch0
-rw-r--r--packages/dbus/dbus/dbus-quiesce-startup-errors.patch0
-rw-r--r--packages/dbus/dbus/dbussend.patch0
-rw-r--r--packages/dbus/dbus/spawn-priority.diff0
-rw-r--r--packages/dbus/dbus/tools.diff0
-rw-r--r--packages/dbus/dbus_0.23.1-osso5.bb0
-rw-r--r--packages/maemo/osso-core-config_200515.1.bb41
-rw-r--r--packages/meta/maemo-image.bb34
-rw-r--r--packages/xaw/files/auxdir.patch0
-rw-r--r--packages/xaw/xaw_7.0.2.bb4
12 files changed, 78 insertions, 1 deletions
diff --git a/packages/dbus/dbus/0.23.1.diff b/packages/dbus/dbus/0.23.1.diff
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus/0.23.1.diff
diff --git a/packages/dbus/dbus/config.diff b/packages/dbus/dbus/config.diff
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus/config.diff
diff --git a/packages/dbus/dbus/dbus-monitor.patch b/packages/dbus/dbus/dbus-monitor.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus/dbus-monitor.patch
diff --git a/packages/dbus/dbus/dbus-quiesce-startup-errors.patch b/packages/dbus/dbus/dbus-quiesce-startup-errors.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus/dbus-quiesce-startup-errors.patch
diff --git a/packages/dbus/dbus/dbussend.patch b/packages/dbus/dbus/dbussend.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus/dbussend.patch
diff --git a/packages/dbus/dbus/spawn-priority.diff b/packages/dbus/dbus/spawn-priority.diff
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus/spawn-priority.diff
diff --git a/packages/dbus/dbus/tools.diff b/packages/dbus/dbus/tools.diff
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus/tools.diff
diff --git a/packages/dbus/dbus_0.23.1-osso5.bb b/packages/dbus/dbus_0.23.1-osso5.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dbus/dbus_0.23.1-osso5.bb
diff --git a/packages/maemo/osso-core-config_200515.1.bb b/packages/maemo/osso-core-config_200515.1.bb
index e69de29bb2..1010e91e8a 100644
--- a/packages/maemo/osso-core-config_200515.1.bb
+++ b/packages/maemo/osso-core-config_200515.1.bb
@@ -0,0 +1,41 @@
+LICENSE = "unknown"
+MAINTAINER= "Florian Boor <florian@kernelconcepts.de"
+PR = "r4"
+
+DEPENDS = "base-passwd osso-af-startup"
+RDEPENDS = "base-passwd osso-af-startup"
+
+SRC_URI = "http://stage.maemo.org:80/pool/maemo/ossw/source/o/${PN}/${PN}_${PV}.tar.gz"
+
+
+inherit autotools update-rc.d
+
+FILES_${PN} = "${sysconfdir}/osso-af-init ${sysconfdir}/init.d/"
+
+INITSCRIPT_NAME = "x-server.sh"
+INITSCRIPT_PARAMS = "defaults 21"
+
+
+do_install () {
+ install -d ${D}${sysconfdir}/osso-af-init
+ install -m 755 ${S}/x-server.defs ${D}/${sysconfdir}/osso-af-init/x-server.defs
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${S}/x-server.sh ${D}/${sysconfdir}/init.d/x-server.sh
+}
+
+pkg_postinst () {
+#!/bin/sh
+
+# can't do adduser stuff offline
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+MAEMOUSER=user
+MAEMOHOME=/home/user
+
+mkdir -p $MAEMOHOME/MyDocs || true
+chgrp "$MAEMOUSER" "$MAEMOHOME" 2>/dev/null || addgroup "$MAEMOUSER"
+adduser --system --home "$MAEMOHOME" --no-create-home --disabled-password --ingroup "$MAEMOUSER" "$MAEMOUSER" || chown -R "$MAEMOUSER"."$MAEMOUSER" "$MAEMOHOME" 2>/dev/null
+}
diff --git a/packages/meta/maemo-image.bb b/packages/meta/maemo-image.bb
index e69de29bb2..b9aad68edd 100644
--- a/packages/meta/maemo-image.bb
+++ b/packages/meta/maemo-image.bb
@@ -0,0 +1,34 @@
+#
+# Meta package for maemo based system image
+#
+
+FEED_URIS_append_openzaurus = " x11##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/x11 \
+ maemo##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/maemo"
+FEED_URIS_append_opensimpad = " x11##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/x11 \
+ maemo##http://openzaurus.org/official/unstable/${DISTRO_VERSION}/feed/maemo"
+FEED_URIS_append_familiar = " x11##http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed/x11"
+
+PR = "r1"
+
+export IMAGE_BASENAME = "maemo-image"
+
+GUI_MACHINE_CLASS ?= "none"
+
+MAEMO_EXTRA_DEPENDS = "scap"
+MAEMO_EXTRA_INSTALL = "osso-af-services osso-af-base-apps scap"
+
+#prefer some versions of the maemo stack
+PREFERRED_VERSION_gtk+="gtk+-2.6.4-1.osso7"
+PREFERRED_VERSION_dbus = "0.23.1-osso5"
+PREFERRED_PROVIDER_gconf = "gconf-osso"
+
+DEPENDS = "task-bootstrap \
+ meta-maemo \
+ ${MAEMO_EXTRA_DEPENDS}"
+
+export IPKG_INSTALL = "task-bootstrap maemo-task-base \
+ maemo-task-apps ${MAEMO_EXTRA_INSTALL} \
+ ${XSERVER}"
+
+inherit image_ipk
+LICENSE = MIT
diff --git a/packages/xaw/files/auxdir.patch b/packages/xaw/files/auxdir.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xaw/files/auxdir.patch
diff --git a/packages/xaw/xaw_7.0.2.bb b/packages/xaw/xaw_7.0.2.bb
index 47be126652..3515e0fac6 100644
--- a/packages/xaw/xaw_7.0.2.bb
+++ b/packages/xaw/xaw_7.0.2.bb
@@ -5,7 +5,9 @@ MAINTAINER = "Phil Blundell <pb@handhelds.org>"
DEPENDS = "xproto x11 xt xmu xpm"
DESCRIPTION = "X Athena Widgets library"
-SRC_URI = "${XLIBS_MIRROR}/libXaw-${PV}.tar.bz2"
+SRC_URI = "${XLIBS_MIRROR}/libXaw-${PV}.tar.bz2 \
+ file://auxdir.patch;patch=1"
+
S = "${WORKDIR}/libXaw-${PV}"
inherit autotools pkgconfig