aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-01-23 13:04:36 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-01-23 13:04:36 +0000
commit1ff63759466fe74afe78a9c25a5f0eddc9427f73 (patch)
treec2eb8394817a682e6883eaaed62d19ff3139017c
parent3eeb3cc8e42f90464cf5e7c87010fc016b6270af (diff)
downloadopenembedded-1ff63759466fe74afe78a9c25a5f0eddc9427f73.tar.gz
remove errornous references to libtool class. patch courtesy Marc Singer
BKrev: 41f3a0e4EiUIg4lpy9yKpp_SK0vy8Q
-rw-r--r--packages/directfb/directfb_0.9.20.bb40
-rw-r--r--packages/esound/esound-gpe_20020817.bb2
-rw-r--r--packages/gnome/gnome-keyring_0.2.1.bb21
-rw-r--r--packages/gnome/libbonobo_2.6.0.bb52
-rw-r--r--packages/gnome/libbonobo_2.6.2.bb57
-rw-r--r--packages/konqueror/konqueror-embedded_20030705.bb2
-rw-r--r--packages/nonworking/apache/apache_2.0.47.bb84
-rw-r--r--packages/nonworking/glib-1.2/glib-1.2_1.2.10.bb8
-rw-r--r--packages/nonworking/gtkmm/gtkmm_2.2.11.bb21
-rw-r--r--packages/nonworking/minisip/minisip_1.0a.bb13
-rw-r--r--packages/nonworking/ppp/ppp_2.4.1+cvs20040427.bb35
-rw-r--r--packages/nonworking/redland/redland_0.9.10.bb3
-rw-r--r--packages/nonworking/redland/redland_0.9.16.bb3
-rw-r--r--packages/nonworking/tetex/tetex_2.0.2.bb10
-rw-r--r--packages/ppp/ppp_2.4.1.bb2
15 files changed, 350 insertions, 3 deletions
diff --git a/packages/directfb/directfb_0.9.20.bb b/packages/directfb/directfb_0.9.20.bb
index e69de29bb2..78efa20027 100644
--- a/packages/directfb/directfb_0.9.20.bb
+++ b/packages/directfb/directfb_0.9.20.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "DirectFB is a thin library that provides developers \
+with hardware graphics acceleration, input device handling and \
+abstraction, an integrated windowing system with support for \
+translucent windows and multiple display layers on top of the \
+Linux framebuffer device."
+SECTION = "libs"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "jpeg libpng zlib"
+PR = "r1"
+
+SRC_URI = "http://www.directfb.org/download/DirectFB/DirectFB-${PV}.tar.gz"
+S = "${WORKDIR}/DirectFB-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-gfxdrivers=none --enable-libmpeg3=no --enable-freetype=no --enable-sdl=no"
+
+do_stage() {
+ oe_runmake -C src 'libdir=/lib' 'includedir=/include/directfb' \
+ 'oldincludedir=/include' 'datadir=/share' \
+ 'DESTDIR=${STAGING_LIBDIR}/..' \
+ 'INTERNALINCLUDEDIR=/include/directfb-internal' \
+ install-internalincludeHEADERS install-libLTLIBRARIES
+ oe_runmake -C include 'libdir=/lib' 'includedir=/include/directfb' \
+ 'oldincludedir=/include' 'datadir=/share' \
+ 'DESTDIR=${STAGING_LIBDIR}/..' \
+ 'INTERNALINCLUDEDIR=/include/directfb-internal' \
+ install-internalincludeHEADERS install-includeHEADERS
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_directfb_append = " ${libdir}/directfb-${PV}/systems/*.so \
+ ${libdir}/directfb-${PV}/inputdrivers/*.so \
+ ${libdir}/directfb-${PV}/interfaces/*/*.so \
+ ${datadir}/directfb-${PV}"
diff --git a/packages/esound/esound-gpe_20020817.bb b/packages/esound/esound-gpe_20020817.bb
index 0e912d78d6..4c7e80f7c6 100644
--- a/packages/esound/esound-gpe_20020817.bb
+++ b/packages/esound/esound-gpe_20020817.bb
@@ -11,7 +11,7 @@ SRC_URI = "${HANDHELDS_CVS};module=gpe/base/esound \
S = "${WORKDIR}/esound"
-inherit autotools libtool pkgconfig
+inherit autotools pkgconfig
EXTRA_OECONF = "--disable-alsa"
diff --git a/packages/gnome/gnome-keyring_0.2.1.bb b/packages/gnome/gnome-keyring_0.2.1.bb
index e69de29bb2..c40ba36cfb 100644
--- a/packages/gnome/gnome-keyring_0.2.1.bb
+++ b/packages/gnome/gnome-keyring_0.2.1.bb
@@ -0,0 +1,21 @@
+LICENSE = GPL
+SECTION = "x11/gnome"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${PN}/0.2/${PN}-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
+
+DEPENDS = ""
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+HEADERS = " \
+gnome-keyring.h \
+"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/gnome-keyring-1
+ for i in ${HEADERS}; do
+ install -m 0644 $i ${STAGING_INCDIR}/gnome-keyring-1/$i
+ done
+ oe_libinstall -so libgnome-keyring ${STAGING_LIBDIR}
+}
diff --git a/packages/gnome/libbonobo_2.6.0.bb b/packages/gnome/libbonobo_2.6.0.bb
index e69de29bb2..4f6dbfd332 100644
--- a/packages/gnome/libbonobo_2.6.0.bb
+++ b/packages/gnome/libbonobo_2.6.0.bb
@@ -0,0 +1,52 @@
+LICENSE = GPL
+SECTION = "x11/gnome"
+DESCRIPTION = "Bonobo CORBA interfaces library"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libbonobo/2.6/libbonobo-${PV}.tar.bz2 \
+ file://gtk-doc.m4 \
+ file://gtk-doc.make"
+DEPENDS = "glib-2.0 orbit2 intltool-native libxml2"
+ORBIT_IDL_SRC = "${STAGING_BINDIR}/orbit-idl-2"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ install -d m4
+ install ${WORKDIR}/gtk-doc.m4 m4/
+ install ${WORKDIR}/gtk-doc.make ./
+}
+
+ACTIVATION_HEADERS = "Bonobo_Unknown.h Bonobo_GenericFactory.h Bonobo_Activation_types.h \
+ bonobo-activation.h bonobo-activation-async.h bonobo-activation-activate.h \
+ bonobo-activation-init.h bonobo-activation-shlib.h bonobo-activation-register.h \
+ bonobo-activation-server-info.h bonobo-activation-version.h"
+
+BONOBO_HEADERS = "Bonobo.h bonobo-arg.h bonobo-context.h bonobo-event-source.h bonobo-exception.h \
+ bonobo-generic-factory.h bonobo-item-container.h bonobo-item-handler.h \
+ bonobo-listener.h bonobo-main.h bonobo-macros.h bonobo-moniker-extender.h \
+ bonobo-moniker-simple.h bonobo-moniker-util.h bonobo-moniker.h bonobo-object.h \
+ bonobo-foreign-object.h bonobo-persist-file.h bonobo-persist-stream.h \
+ bonobo-persist.h bonobo-persist-client.h bonobo-property-bag.h \
+ bonobo-property-bag-client.h bonobo-shlib-factory.h bonobo-storage.h \
+ bonobo-stream.h bonobo-stream-client.h bonobo-stream-memory.h \
+ bonobo-storage-memory.h bonobo-xobject.h bonobo-i18n.h bonobo-types.h \
+ bonobo-app-client.h bonobo-application.h"
+
+do_compile() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation
+ for i in ${ACTIVATION_HEADERS}; do install -m 0644 bonobo-activation/$i ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation/; done
+ install -d ${STAGING_INCDIR}/libbonobo-2.0/bonobo
+ for i in ${BONOBO_HEADERS}; do install -m 0644 bonobo/$i ${STAGING_INCDIR}/libbonobo-2.0/bonobo/; done
+ install -m 0644 libbonobo.h ${STAGING_INCDIR}/libbonobo-2.0/
+ install -d ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
+ install idl/*.idl ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
+ oe_libinstall -so -C bonobo libbonobo-2 ${STAGING_LIBDIR}
+ oe_libinstall -so -C bonobo-activation libbonobo-activation ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+}
diff --git a/packages/gnome/libbonobo_2.6.2.bb b/packages/gnome/libbonobo_2.6.2.bb
index e69de29bb2..dc0dc9d8cc 100644
--- a/packages/gnome/libbonobo_2.6.2.bb
+++ b/packages/gnome/libbonobo_2.6.2.bb
@@ -0,0 +1,57 @@
+LICENSE = GPL
+PR = "r1"
+SECTION = "x11/gnome/libs"
+DESCRIPTION = "Bonobo CORBA interfaces library"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libbonobo/2.6/libbonobo-${PV}.tar.bz2 \
+ file://gtk-doc.m4 \
+ file://gtk-doc.make"
+DEPENDS = "glib-2.0 orbit2 intltool-native libxml2"
+ORBIT_IDL_SRC = "${STAGING_BINDIR}/orbit-idl-2"
+
+FILES_${PN} += "${libdir}/orbit-2.0/*.so ${libdir}/bonobo/monikers/*.so"
+FILES_${PN}-dev += "${libdir}/orbit-2.0/* ${libdir}/bonobo/monikers/* \
+ ${libdir}/bonobo-2.0/samples"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ install -d m4
+ install ${WORKDIR}/gtk-doc.m4 m4/
+ install ${WORKDIR}/gtk-doc.make ./
+}
+
+ACTIVATION_HEADERS = "Bonobo_Unknown.h Bonobo_GenericFactory.h Bonobo_Activation_types.h \
+ bonobo-activation.h bonobo-activation-async.h bonobo-activation-activate.h \
+ bonobo-activation-init.h bonobo-activation-shlib.h bonobo-activation-register.h \
+ bonobo-activation-server-info.h bonobo-activation-version.h"
+
+BONOBO_HEADERS = "Bonobo.h bonobo-arg.h bonobo-context.h bonobo-event-source.h bonobo-exception.h \
+ bonobo-generic-factory.h bonobo-item-container.h bonobo-item-handler.h \
+ bonobo-listener.h bonobo-main.h bonobo-macros.h bonobo-moniker-extender.h \
+ bonobo-moniker-simple.h bonobo-moniker-util.h bonobo-moniker.h bonobo-object.h \
+ bonobo-foreign-object.h bonobo-persist-file.h bonobo-persist-stream.h \
+ bonobo-persist.h bonobo-persist-client.h bonobo-property-bag.h \
+ bonobo-property-bag-client.h bonobo-shlib-factory.h bonobo-storage.h \
+ bonobo-stream.h bonobo-stream-client.h bonobo-stream-memory.h \
+ bonobo-storage-memory.h bonobo-xobject.h bonobo-i18n.h bonobo-types.h \
+ bonobo-app-client.h bonobo-application.h"
+
+do_compile() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation
+ for i in ${ACTIVATION_HEADERS}; do install -m 0644 bonobo-activation/$i ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation/; done
+ install -d ${STAGING_INCDIR}/libbonobo-2.0/bonobo
+ for i in ${BONOBO_HEADERS}; do install -m 0644 bonobo/$i ${STAGING_INCDIR}/libbonobo-2.0/bonobo/; done
+ install -m 0644 libbonobo.h ${STAGING_INCDIR}/libbonobo-2.0/
+ install -d ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
+ install idl/*.idl ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
+ oe_libinstall -so -C bonobo libbonobo-2 ${STAGING_LIBDIR}
+ oe_libinstall -so -C bonobo-activation libbonobo-activation ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+}
diff --git a/packages/konqueror/konqueror-embedded_20030705.bb b/packages/konqueror/konqueror-embedded_20030705.bb
index 39fd29d3aa..551f0e2a59 100644
--- a/packages/konqueror/konqueror-embedded_20030705.bb
+++ b/packages/konqueror/konqueror-embedded_20030705.bb
@@ -14,7 +14,7 @@ SRC_URI = "http://devel-home.kde.org/~hausmann/snapshots/konqueror-embedded-snap
file://konq-embedrc "
S = "${WORKDIR}/konqueror-embedded-snapshot-${PV}"
-inherit autotools libtool
+inherit autotools
FILES_${PN} = "${palmtopdir}"
diff --git a/packages/nonworking/apache/apache_2.0.47.bb b/packages/nonworking/apache/apache_2.0.47.bb
index e69de29bb2..e8a7c390e5 100644
--- a/packages/nonworking/apache/apache_2.0.47.bb
+++ b/packages/nonworking/apache/apache_2.0.47.bb
@@ -0,0 +1,84 @@
+SECTION = net
+DEPENDS = expat openssl
+
+SRC_URI = http://ftp.epix.net/apache/httpd/httpd-${PV}.tar.gz \
+ file://${FILESDIR}/configure.patch;patch=1 \
+ file://${FILESDIR}/pcre-configure.patch;patch=1
+S = ${WORKDIR}/httpd-${PV}
+
+basesysconfdir := ${sysconfdir}
+sysconfdir = /etc/apache
+
+inherit autotools
+
+FILES_${PN}=${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
+ ${libdir}/*/ ${basesysconfdir} ${sharedstatedir} ${localstatedir} \
+ /bin /sbin /lib/*/ /lib/*.so* ${datadir}/${PN} ${datadir}/htdocs \
+ ${datadir}/icons ${datadir}/cgi-bin ${datadir}/error /var
+
+CFLAGS_append = " -DPATH_MAX=4096"
+CFLAGS_prepend = "-I${STAGING_INCDIR}/openssl "
+EXTRA_OECONF = "--enable-ssl --with-ssl=${STAGING_LIBDIR}/.. --enable-dav \
+ --enable-dav-fs --with-dbm=sdbm --with-berkeley-db=no \
+ --with-gdbm=no --with-ndbm=no"
+do_configure () {
+ (cd srclib/apr && ./buildconf)
+ (cd srclib/apr-util && ./buildconf)
+
+ cp srclib/apr/build/config.guess srclib/apr/build/config.sub \
+ srclib/apr/build/PrintPath srclib/apr/build/apr_common.m4 \
+ srclib/apr/build/find_apr.m4 $apu_src_dir/build/find_apu.m4 build
+
+ (cd srclib/pcre && autoconf)
+
+ aclocal -I build
+ autoheader
+ autoconf
+ oe_runconf
+}
+
+do_compile () {
+ touch srclib/apr-util/uri/gen_uri_delims.lo
+ ${BUILD_CC} srclib/apr-util/uri/gen_uri_delims.c -o srclib/apr-util/uri/gen_uri_delims
+ touch srclib/pcre/dftables.lo
+ ${BUILD_CC} -I/usr/include/pcre srclib/pcre/dftables.c -o srclib/pcre/dftables
+ cd server
+ ${BUILD_CC} -I${S}/srclib/apr/include -c gen_test_char.c && touch gen_test_char.lo
+ ${BUILD_CC} -I${S}/os/unix -I${S}/srclib/apr/include -I${S}/srclib/apr-util/include -I${S}/include -c util_debug.c && touch util_debug.lo
+ ${BUILD_CC} gen_test_char.o util_debug.o -o gen_test_char
+ /bin/sh ${S}/srclib/apr/libtool --silent --mode=compile ${CC} -DPATH_MAX=4096 -I${S}/srclib/apr/include -prefer-non-pic -static -c gen_test_char.c && touch gen_test_char.lo
+ /bin/sh ${S}/srclib/apr/libtool --silent --mode=compile ${CC} -DPATH_MAX=4096 -I${S}/os/unix -I${S}/srclib/apr/include -I${S}/srclib/apr-util/include -I${S}/include -prefer-non-pic -static -c util_debug.c && touch util_debug.lo
+ touch gen_test_char
+ cd ..
+ oe_runmake
+}
+
+do_install_append () {
+ set -x
+ install -d ${D}/${basesysconfdir}/init.d
+ cat ${FILESDIR}/init | \
+ sed -e 's,/usr/sbin/,${sbindir}/,g; \
+ s,/usr/bin/,${bindir}/,g; \
+ s,/usr/lib,${libdir}/,g; \
+ s,/etc/apache/,${sysconfdir}/,g; \
+ s,/etc/,${basesysconfdir}/,g; \
+ s,/usr/,${prefix}/,g;' > ${D}/${basesysconfdir}/init.d/httpd
+ chmod 755 ${D}/${basesysconfdir}/init.d/httpd
+ if test -e ${FILESDIR}/httpd.conf.${MACHINE}; then
+ install -m 0644 ${FILESDIR}/httpd.conf.${MACHINE} ${D}/${sysconfdir}/httpd.conf
+ fi
+}
+
+pkg_postinst () {
+ if test -n "$D"; then
+ D="-r $D"
+ fi
+ update-rc.d $D httpd defaults 91 20
+}
+
+pkg_prerm () {
+ if test -n "$D"; then
+ D="-r $D"
+ fi
+ update-rc.d $D httpd remove
+}
diff --git a/packages/nonworking/glib-1.2/glib-1.2_1.2.10.bb b/packages/nonworking/glib-1.2/glib-1.2_1.2.10.bb
index e69de29bb2..1d104a69b5 100644
--- a/packages/nonworking/glib-1.2/glib-1.2_1.2.10.bb
+++ b/packages/nonworking/glib-1.2/glib-1.2_1.2.10.bb
@@ -0,0 +1,8 @@
+SRC_URI = http://ftp.gnome.org/pub/gnome/sources/glib/1.2/glib-${PV}.tar.gz \
+ file://${FILESDIR}/configure.patch;patch=1
+
+inherit autotools
+
+do_configure_prepend () {
+ install -m 0644 ${FILESDIR}/glibconfig-sysdefs.h .
+}
diff --git a/packages/nonworking/gtkmm/gtkmm_2.2.11.bb b/packages/nonworking/gtkmm/gtkmm_2.2.11.bb
index e69de29bb2..181da3bcda 100644
--- a/packages/nonworking/gtkmm/gtkmm_2.2.11.bb
+++ b/packages/nonworking/gtkmm/gtkmm_2.2.11.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "C++ Bindings for Gtk+"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "gtk+ libsigc++"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.2/gtkmm-2.2.11.tar.bz2"
+
+inherit autotools
+
+do_stage() {
+ oe_soinstall shlib/libhistory.so.${PV} ${STAGING_LIBDIR}/
+ oe_soinstall shlib/libreadline.so.${PV} ${STAGING_LIBDIR}/
+
+ install -d ${STAGING_INCDIR}/readline
+ for f in readline.h chardefs.h keymaps.h history.h tilde.h rlstdc.h \
+ rlconf.h rltypedefs.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/readline/
+ done
+
+}
diff --git a/packages/nonworking/minisip/minisip_1.0a.bb b/packages/nonworking/minisip/minisip_1.0a.bb
index e69de29bb2..14ce425b0e 100644
--- a/packages/nonworking/minisip/minisip_1.0a.bb
+++ b/packages/nonworking/minisip/minisip_1.0a.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Minisip is a SIP User Agent"
+SECTION = "opie/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libmikey libopie1"
+
+SRC_URI = "http://minisip.org/source/minisip-0.1a.tar.gz"
+S = "${WORKDIR}/minisip-0.1"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-qte --enable-opie"
+
diff --git a/packages/nonworking/ppp/ppp_2.4.1+cvs20040427.bb b/packages/nonworking/ppp/ppp_2.4.1+cvs20040427.bb
index e69de29bb2..1f625613b9 100644
--- a/packages/nonworking/ppp/ppp_2.4.1+cvs20040427.bb
+++ b/packages/nonworking/ppp/ppp_2.4.1+cvs20040427.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
+
+DEPENDS = "libpcap-0.7.2 openssl"
+
+PACKAGES =+ "${PN}-plugins"
+
+FILES_${PN}-plugins = /usr/lib/pppd/*
+
+SRC_URI = "http://handhelds.org/~zecke/downloads/tmp/ppp-cvs-20040427.tar.gz \
+ file://008_pathnames.h.diff;patch=1 \
+ file://011_scripts_redialer.diff;patch=1 \
+ file://018_ip-up_option.diff;patch=1 \
+ file://057_pppoe-interface-change;patch=1 \
+ file://auth_hook_segfault;patch=1 \
+ file://cifdefroute.dif;patch=1 \
+ file://close_devfd;patch=1 \
+ file://fix_closed_fds;patch=1 \
+ file://no_crypt_hack;patch=1 \
+ file://ppp-2.3.11-oedod.dif;patch=1 \
+ file://ppp-2.4.2-stripMSdomain;patch=1 \
+ file://pppdump-no-deflate;patch=1 \
+ file://pppoe_discovery;patch=1 \
+ file://setevn_call_file;patch=1 \
+ file://syslog_local2;patch=1 \
+ file://use_openssl;patch=1 \
+ file://install_and_cc.patch;patch=1 \
+ file://mppe-signed.patch;patch=1 "
+
+S = "${WORKDIR}/ppp"
+
+inherit autotools
+
+EXTRA_OEMAKE = "STRIPPROG=arm-linux-strip"
+EXTRA_OECONF = --disable-strip
+
diff --git a/packages/nonworking/redland/redland_0.9.10.bb b/packages/nonworking/redland/redland_0.9.10.bb
index e69de29bb2..f29c465ea1 100644
--- a/packages/nonworking/redland/redland_0.9.10.bb
+++ b/packages/nonworking/redland/redland_0.9.10.bb
@@ -0,0 +1,3 @@
+SRC_URI = http://www.redland.opensource.ac.uk/dist/source/old/redland-${PV}.tar.gz
+
+inherit autotools
diff --git a/packages/nonworking/redland/redland_0.9.16.bb b/packages/nonworking/redland/redland_0.9.16.bb
index e69de29bb2..f29c465ea1 100644
--- a/packages/nonworking/redland/redland_0.9.16.bb
+++ b/packages/nonworking/redland/redland_0.9.16.bb
@@ -0,0 +1,3 @@
+SRC_URI = http://www.redland.opensource.ac.uk/dist/source/old/redland-${PV}.tar.gz
+
+inherit autotools
diff --git a/packages/nonworking/tetex/tetex_2.0.2.bb b/packages/nonworking/tetex/tetex_2.0.2.bb
index e69de29bb2..98e9edb35c 100644
--- a/packages/nonworking/tetex/tetex_2.0.2.bb
+++ b/packages/nonworking/tetex/tetex_2.0.2.bb
@@ -0,0 +1,10 @@
+SRC_URI = ftp://cam.ctan.org/tex-archive/systems/unix/teTeX/2.0/distrib/tetex-src-${PV}.tar.gz \
+ file://${FILESDIR}/configure.patch;patch=1
+S = ${WORKDIR}/tetex-src-${PV}
+
+inherit autotools
+
+do_configure () {
+ sh ./reautoconf
+ oe_runconf
+}
diff --git a/packages/ppp/ppp_2.4.1.bb b/packages/ppp/ppp_2.4.1.bb
index 44d99f588a..d9ba592f77 100644
--- a/packages/ppp/ppp_2.4.1.bb
+++ b/packages/ppp/ppp_2.4.1.bb
@@ -14,7 +14,7 @@ SRC_URI = "ftp://ftp.samba.org/pub/ppp/ppp-2.4.1.tar.gz \
file://ip-up \
file://ip-down"
-inherit autotools libtool
+inherit autotools
EXTRA_OEMAKE = "STRIPPROG=${STRIP}"
EXTRA_OECONF = --disable-strip