aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-03-21 23:26:41 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-03-21 23:26:41 +0000
commit507f5c47f31dc102d925959788af4ae8ddb5f6c9 (patch)
tree4ba3ccb6fcc4ab1dba6d51d35cffe4097298961b
parentdc9e3345fd087227731b17379aa46e1b8ee2d9b6 (diff)
parente737833493b9017bbfd3ab0dba6a2d26f85eebd8 (diff)
downloadopenembedded-507f5c47f31dc102d925959788af4ae8ddb5f6c9.tar.gz
merge of '17fe5a20eddea57fb860ffa0652cc78cda424804'
and '281a5681239793312291488e7b216ecbdfce9b33'
-rw-r--r--classes/efl.bbclass40
-rw-r--r--classes/efl_base.bbclass14
-rw-r--r--classes/efl_library.bbclass9
-rw-r--r--conf/distro/include/sane-srcdates.inc2
-rwxr-xr-xcontrib/python/generate-manifest-2.5.py7
-rw-r--r--packages/e17/e-wm/disable-e-cursor.patch277
-rw-r--r--packages/e17/e-wm_cvs.bb3
-rw-r--r--packages/efl1/ecore.inc2
-rw-r--r--packages/efl1/edb_cvs.bb2
-rw-r--r--packages/efl1/edbus_cvs.bb2
-rw-r--r--packages/efl1/edje_cvs.bb12
-rw-r--r--packages/efl1/eet_cvs.bb2
-rw-r--r--packages/efl1/eflpp_cvs.bb2
-rw-r--r--packages/efl1/efreet_cvs.bb2
-rw-r--r--packages/efl1/embryo_cvs.bb7
-rw-r--r--packages/efl1/emotion_cvs.bb2
-rw-r--r--packages/efl1/engrave_cvs.bb2
-rw-r--r--packages/efl1/enhance_cvs.bb2
-rw-r--r--packages/efl1/epdf_cvs.bb2
-rw-r--r--packages/efl1/epeg_cvs.bb2
-rw-r--r--packages/efl1/epsilon_cvs.bb2
-rw-r--r--packages/efl1/esmart_cvs.bb2
-rw-r--r--packages/efl1/etk-native_cvs.bb5
-rw-r--r--packages/efl1/etk_cvs.bb20
-rw-r--r--packages/efl1/evas.inc3
-rw-r--r--packages/efl1/evolve_cvs.bb2
-rw-r--r--packages/efl1/ewl_cvs.bb2
-rw-r--r--packages/efl1/exml_cvs.bb2
-rw-r--r--packages/efl1/imlib2_cvs.bb2
-rw-r--r--packages/python/python-2.5-manifest.inc29
-rw-r--r--packages/python/python-pysqlite2_2.4.0.bb17
31 files changed, 408 insertions, 71 deletions
diff --git a/classes/efl.bbclass b/classes/efl.bbclass
new file mode 100644
index 0000000000..eee28ddc75
--- /dev/null
+++ b/classes/efl.bbclass
@@ -0,0 +1,40 @@
+SECTION = "e/libs"
+HOMEPAGE = "http://www.enlightenment.org"
+LICENSE = "MIT BSD"
+SRCNAME = "${@bb.data.getVar('PN', d, 1).replace('-native', '')}"
+SRC_URI = "${E_CVS};module=e17/libs/${SRCNAME}"
+S = "${WORKDIR}/${SRCNAME}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev ${PN}-tests"
+
+FILES_${PN} = "${libdir}/*.so.*"
+
+FILES_${PN}-themes = "${datadir}/${PN}/themes \
+ ${datadir}/${PN}/data \
+ ${datadir}/${PN}/fonts \
+ ${datadir}/${PN}/pointers \
+ ${datadir}/${PN}/images \
+ ${datadir}/${PN}/users \
+ ${datadir}/${PN}/images \
+ ${datadir}/${PN}/styles"
+
+FILES_${PN}-dev += "${bindir}/${PN}-config \
+ ${libdir}/pkgconfig/* \
+ ${libdir}/lib*.la \
+ ${libdir}/lib*.a \
+ ${libdir}/*.so \
+ ${libdir}/${PN}/*.a \
+ ${libdir}/${PN}/*.la \
+ ${libdir}/${PN}/*/*.a \
+ ${libdir}/${PN}/*/*.la"
+
+FILES_${PN}-tests = "${bindir}/${PN} \
+ ${bindir}/*_* \
+ ${datadir}"
+
diff --git a/classes/efl_base.bbclass b/classes/efl_base.bbclass
deleted file mode 100644
index 023b2edf74..0000000000
--- a/classes/efl_base.bbclass
+++ /dev/null
@@ -1,14 +0,0 @@
-inherit autotools pkgconfig
-
-SECTION = "e/libs"
-HOMEPAGE = "http://www.enlightenment.org"
-SRCNAME = "${@bb.data.getVar('PN', d, 1).replace('-native', '')}"
-SRC_URI = "http://download.enlightenment.org/snapshots/2008-01-25/${SRCNAME}-${PV}.tar.gz"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-do_stage() {
- autotools_stage_all
-}
-
-PACKAGES = "${PN}-dbg ${PN} ${PN}-themes ${PN}-dev"
-FILES_${PN}-dev += "${bindir}/${PN}-config ${libdir}/pkgconfig/* ${libdir}/lib*.?a ${libdir}/lib*.a"
diff --git a/classes/efl_library.bbclass b/classes/efl_library.bbclass
deleted file mode 100644
index c2b6938e47..0000000000
--- a/classes/efl_library.bbclass
+++ /dev/null
@@ -1,9 +0,0 @@
-inherit efl_base
-
-SRC_URI = "${E_CVS};module=e17/libs/${SRCNAME}"
-S = "${WORKDIR}/${SRCNAME}"
-
-PACKAGES =+ "${PN}-tests"
-FILES_${PN}-tests = "${bindir}/${PN} ${bindir}/*_* ${datadir}"
-FILES_${PN}-dev += "${bindir}/*-config ${libdir}/${PN}/*.a ${libdir}/${PN}/*.la ${libdir}/${PN}/*/*.a ${libdir}/${PN}/*/*.la"
-FILES_${PN} = "${libdir}/*.so*"
diff --git a/conf/distro/include/sane-srcdates.inc b/conf/distro/include/sane-srcdates.inc
index ae83f51473..13498ac7bc 100644
--- a/conf/distro/include/sane-srcdates.inc
+++ b/conf/distro/include/sane-srcdates.inc
@@ -52,7 +52,7 @@ SRCDATE_gtkhtml2 ?= "20060323"
# Enlightenment Foundation Libraries
# Caution: This is not alphabetically, but (roughly) dependency-sorted.
# Please leave it like that.
-EFL_SRCDATE = "20080311"
+EFL_SRCDATE = "20080321"
SRCDATE_edb-native ?= "${EFL_SRCDATE}"
SRCDATE_edb ?= "${EFL_SRCDATE}"
SRCDATE_eet-native ?= "${EFL_SRCDATE}"
diff --git a/contrib/python/generate-manifest-2.5.py b/contrib/python/generate-manifest-2.5.py
index 94ae5ce4fd..69788f66af 100755
--- a/contrib/python/generate-manifest-2.5.py
+++ b/contrib/python/generate-manifest-2.5.py
@@ -294,8 +294,11 @@ if __name__ == "__main__":
m.addPackage( 0, "python-subprocess", "Python Subprocess Support", "python-core python-io python-re python-fcntl python-pickle",
"subprocess.*" )
- m.addPackage( 1, "python-sqlite3", "Python Sqlite3 Database Support", "python-core",
- "lib-dynload/_sqlite3.so sqlite3" ) # package
+ m.addPackage( 2, "python-sqlite3", "Python Sqlite3 Database Support", "python-core python-datetime python-lang python-crypt python-io python-threading python-zlib",
+ "lib-dynload/_sqlite3.so sqlite3/dbapi2.* sqlite3/__init__.*" )
+
+ m.addPackage( 0, "python-sqlite3-tests", "Python Sqlite3 Database Support Tests", "python-core python-sqlite3",
+ "sqlite3/test" )
m.addPackage( 0, "python-stringold", "Python String APIs [deprecated]", "python-core python-re",
"lib-dynload/strop.so string.*" )
diff --git a/packages/e17/e-wm/disable-e-cursor.patch b/packages/e17/e-wm/disable-e-cursor.patch
new file mode 100644
index 0000000000..51618434a5
--- /dev/null
+++ b/packages/e17/e-wm/disable-e-cursor.patch
@@ -0,0 +1,277 @@
+Index: e/src/bin/e_config.c
+===================================================================
+--- e.orig/src/bin/e_config.c
++++ e/src/bin/e_config.c
+@@ -461,6 +461,7 @@ e_config_init(void)
+ E_CONFIG_VAL(D, T, focus_last_focused_per_desktop, INT); /**/
+ E_CONFIG_VAL(D, T, focus_revert_on_hide_or_close, INT); /**/
+ E_CONFIG_VAL(D, T, pointer_slide, INT); /**/
++ E_CONFIG_VAL(D, T, show_cursor, INT); /**/
+ E_CONFIG_VAL(D, T, use_e_cursor, INT); /**/
+ E_CONFIG_VAL(D, T, cursor_size, INT); /**/
+ E_CONFIG_VAL(D, T, menu_autoscroll_margin, INT); /**/
+@@ -705,6 +706,7 @@ e_config_init(void)
+ e_config->focus_last_focused_per_desktop = 1;
+ e_config->focus_revert_on_hide_or_close = 1;
+ e_config->pointer_slide = 1;
++ e_config->show_cursor = 1;
+ e_config->use_e_cursor = 1;
+ e_config->cursor_size = 32;
+ e_config->menu_autoscroll_margin = 0;
+@@ -1570,6 +1572,7 @@ e_config_init(void)
+ E_CONFIG_LIMIT(e_config->focus_last_focused_per_desktop, 0, 1);
+ E_CONFIG_LIMIT(e_config->focus_revert_on_hide_or_close, 0, 1);
+ E_CONFIG_LIMIT(e_config->pointer_slide, 0, 1);
++ E_CONFIG_LIMIT(e_config->show_cursor, 0, 1);
+ E_CONFIG_LIMIT(e_config->use_e_cursor, 0, 1);
+ E_CONFIG_LIMIT(e_config->cursor_size, 0, 1024);
+ E_CONFIG_LIMIT(e_config->menu_autoscroll_margin, 0, 50);
+Index: e/src/modules/conf_mouse_cursor/e_int_config_cursor.c
+===================================================================
+--- e.orig/src/modules/conf_mouse_cursor/e_int_config_cursor.c
++++ e/src/modules/conf_mouse_cursor/e_int_config_cursor.c
+@@ -3,16 +3,25 @@
+ static void *_create_data(E_Config_Dialog *cfd);
+ static void _free_data(E_Config_Dialog *cfd, E_Config_Dialog_Data *cfdata);
+ static int _basic_apply_data(E_Config_Dialog *cfd, E_Config_Dialog_Data *cfdata);
++static void _basic_show_cursor_cb_change(void *data, Evas_Object *obj);
+ static Evas_Object *_basic_create_widgets(E_Config_Dialog *cfd, Evas *evas, E_Config_Dialog_Data *cfdata);
+ static int _advanced_apply_data(E_Config_Dialog *cfd, E_Config_Dialog_Data *cfdata);
++static void _advanced_show_cursor_cb_change(void *data, Evas_Object *obj);
+ static Evas_Object *_advanced_create_widgets(E_Config_Dialog *cfd, Evas *evas, E_Config_Dialog_Data *cfdata);
+
+ struct _E_Config_Dialog_Data
+ {
++ int show_cursor;
+ int use_e_cursor;
+
+ /* Advanced */
+ int cursor_size;
++
++ struct
++ {
++ Evas_Object *radio_use_e_cursor;
++ Evas_Object *slider_cursor_size;
++ } gui;
+ };
+
+ EAPI E_Config_Dialog *
+@@ -41,6 +50,7 @@ e_int_config_cursor(E_Container *con, co
+ static void
+ _fill_data(E_Config_Dialog_Data *cfdata)
+ {
++ cfdata->show_cursor = e_config->show_cursor;
+ cfdata->use_e_cursor = e_config->use_e_cursor;
+ cfdata->cursor_size = e_config->cursor_size;
+ }
+@@ -66,9 +76,11 @@ _basic_apply_data(E_Config_Dialog *cfd,
+ {
+ int changed = 0;
+
++ if (e_config->show_cursor != cfdata->show_cursor) changed = 1;
+ if (e_config->use_e_cursor != cfdata->use_e_cursor) changed = 1;
+
+ e_config->use_e_cursor = cfdata->use_e_cursor;
++ e_config->show_cursor = cfdata->show_cursor;
+ e_config_save_queue();
+
+ if (changed)
+@@ -79,6 +91,11 @@ _basic_apply_data(E_Config_Dialog *cfd,
+ {
+ E_Manager *man;
+ man = l->data;
++ if (man->pointer && !e_config->show_cursor)
++ {
++ e_pointer_hide(man->pointer);
++ continue;
++ }
+ if (man->pointer) e_object_del(E_OBJECT(man->pointer));
+ man->pointer = e_pointer_window_new(man->root, 1);
+ }
+@@ -86,6 +103,17 @@ _basic_apply_data(E_Config_Dialog *cfd,
+ return 1;
+ }
+
++static void
++_basic_show_cursor_cb_change(void *data, Evas_Object *obj)
++{
++ E_Config_Dialog_Data *cfdata;
++
++ cfdata = data;
++ if (!cfdata) return;
++
++ e_widget_disabled_set(cfdata->gui.radio_use_e_cursor, !cfdata->show_cursor);
++}
++
+ static Evas_Object *
+ _basic_create_widgets(E_Config_Dialog *cfd, Evas *evas, E_Config_Dialog_Data *cfdata)
+ {
+@@ -94,8 +122,14 @@ _basic_create_widgets(E_Config_Dialog *c
+
+ o = e_widget_list_add(evas, 0, 0);
+
++ ob = e_widget_check_add(evas, _("Show Cursor"), &(cfdata->show_cursor));
++ e_widget_on_change_hook_set(ob, _basic_show_cursor_cb_change, cfdata);
++ e_widget_list_object_append(o, ob, 1, 1, 0.5);
++
+ of = e_widget_framelist_add(evas, _("Cursor Settings"), 0);
+ rg = e_widget_radio_group_new(&cfdata->use_e_cursor);
++ cfdata->gui.radio_use_e_cursor = rg;
++
+ ob = e_widget_radio_add(evas, _("Use Enlightenment Cursor"), 1, rg);
+ e_widget_framelist_object_append(of, ob);
+ ob = e_widget_radio_add(evas, _("Use X Cursor"), 0, rg);
+@@ -111,9 +145,11 @@ _advanced_apply_data(E_Config_Dialog *cf
+ {
+ int changed = 0;
+
++ if (e_config->show_cursor != cfdata->show_cursor) changed = 1;
+ if (e_config->use_e_cursor != cfdata->use_e_cursor) changed = 1;
+ if (e_config->cursor_size != cfdata->cursor_size) changed = 1;
+-
++
++ e_config->show_cursor = cfdata->show_cursor;
+ e_config->use_e_cursor = cfdata->use_e_cursor;
+ if (cfdata->cursor_size <= 0) cfdata->cursor_size = 1;
+ e_config->cursor_size = cfdata->cursor_size;
+@@ -128,6 +164,11 @@ _advanced_apply_data(E_Config_Dialog *cf
+ {
+ E_Manager *man;
+ man = l->data;
++ if (man->pointer && !e_config->show_cursor)
++ {
++ e_pointer_hide(man->pointer);
++ continue;
++ }
+ if (man->pointer) e_object_del(E_OBJECT(man->pointer));
+ man->pointer = e_pointer_window_new(man->root, 1);
+ }
+@@ -135,6 +176,18 @@ _advanced_apply_data(E_Config_Dialog *cf
+ return 1;
+ }
+
++static void
++_advanced_show_cursor_cb_change(void *data, Evas_Object *obj)
++{
++ E_Config_Dialog_Data *cfdata;
++
++ cfdata = data;
++ if (!cfdata) return;
++
++ e_widget_disabled_set(cfdata->gui.radio_use_e_cursor, !cfdata->show_cursor);
++ e_widget_disabled_set(cfdata->gui.slider_cursor_size, !cfdata->show_cursor);
++}
++
+ static Evas_Object *
+ _advanced_create_widgets(E_Config_Dialog *cfd, Evas *evas, E_Config_Dialog_Data *cfdata)
+ {
+@@ -143,16 +196,27 @@ _advanced_create_widgets(E_Config_Dialog
+
+ o = e_widget_list_add(evas, 0, 0);
+
++ ob = e_widget_check_add(evas, _("Show Cursor"), &(cfdata->show_cursor));
++ e_widget_on_change_hook_set(ob, _advanced_show_cursor_cb_change, cfdata);
++ e_widget_list_object_append(o, ob, 1, 1, 0.5);
++
+ of = e_widget_framelist_add(evas, _("Cursor Settings"), 0);
+ rg = e_widget_radio_group_new(&cfdata->use_e_cursor);
++ cfdata->gui.radio_use_e_cursor = rg;
++
+ ob = e_widget_radio_add(evas, _("Use Enlightenment Cursor"), 1, rg);
+ e_widget_framelist_object_append(of, ob);
+ ob = e_widget_radio_add(evas, _("Use X Cursor"), 0, rg);
+ e_widget_framelist_object_append(of, ob);
+ ob = e_widget_label_add(evas, _("Cursor Size"));
+ e_widget_framelist_object_append(of, ob);
++
+ ob = e_widget_slider_add(evas, 1, 0, _("%1.0f pixels"), 8, 128, 4, 0, NULL, &(cfdata->cursor_size), 150);
++ cfdata->gui.slider_cursor_size = ob;
++
+ e_widget_framelist_object_append(of, ob);
++
+ e_widget_list_object_append(o, of, 1, 1, 0.5);
++
+ return o;
+ }
+Index: e/src/bin/e_pointer.c
+===================================================================
+--- e.orig/src/bin/e_pointer.c
++++ e/src/bin/e_pointer.c
+@@ -94,6 +94,8 @@ e_pointers_size_set(int size)
+ {
+ Evas_List *l;
+
++ if (!e_config->show_cursor) return;
++
+ for (l = _e_pointers; l; l = l->next)
+ {
+ E_Pointer *p;
+@@ -136,6 +138,13 @@ e_pointers_size_set(int size)
+ }
+
+ EAPI void
++e_pointer_hide(E_Pointer *p)
++{
++ if (p->win) ecore_x_window_cursor_set(p->win, 0);
++ if (p->evas) _e_pointer_canvas_del(p);
++}
++
++EAPI void
+ e_pointer_type_push(E_Pointer *p, void *obj, const char *type)
+ {
+ E_Pointer_Stack *stack;
+@@ -199,6 +208,7 @@ EAPI void
+ e_pointer_idler_before(void)
+ {
+ Evas_List *l;
++ if (!e_config->show_cursor) return;
+
+ for (l = _e_pointers; l; l = l->next)
+ {
+@@ -305,6 +315,8 @@ _e_pointer_cb_move(void *data, Evas *e _
+ E_Pointer *p;
+ Evas_Coord x, y;
+
++ if (!e_config->show_cursor) return;
++
+ p = data;
+ if (!p->e_cursor) return;
+ evas_object_geometry_get(p->hot_object, &x, &y, NULL, NULL);
+@@ -353,6 +365,13 @@ _e_pointer_type_set(E_Pointer *p, const
+ if (p->type) evas_stringshare_del(p->type);
+ p->type = evas_stringshare_add(type);
+
++ /* Do not set type if in "hidden mode" */
++ if (!e_config->show_cursor)
++ {
++ ecore_x_window_cursor_set(p->win, 0);
++ return 1;
++ }
++
+ if (p->e_cursor)
+ {
+ Evas_Object *o;
+Index: e/src/bin/e_config.h
+===================================================================
+--- e.orig/src/bin/e_config.h
++++ e/src/bin/e_config.h
+@@ -166,6 +166,7 @@ struct _E_Config
+ int focus_last_focused_per_desktop; // GUI
+ int focus_revert_on_hide_or_close; // GUI
+ int pointer_slide; // GUI
++ int show_cursor; // GUI
+ int use_e_cursor; // GUI
+ int cursor_size; // GUI
+ int menu_autoscroll_margin; // GUI
+Index: e/src/bin/e_pointer.h
+===================================================================
+--- e.orig/src/bin/e_pointer.h
++++ e/src/bin/e_pointer.h
+@@ -42,6 +42,7 @@ struct _E_Pointer
+ EAPI int e_pointer_init(void);
+ EAPI int e_pointer_shutdown(void);
+ EAPI E_Pointer *e_pointer_window_new(Ecore_X_Window win, int filled);
++EAPI void e_pointer_hide(E_Pointer *p);
+ EAPI void e_pointer_type_push(E_Pointer *p, void *obj, const char *type);
+ EAPI void e_pointer_type_pop(E_Pointer *p, void *obj, const char *type);
+ EAPI void e_pointers_size_set(int size);
diff --git a/packages/e17/e-wm_cvs.bb b/packages/e17/e-wm_cvs.bb
index c3a243a675..364e5539e1 100644
--- a/packages/e17/e-wm_cvs.bb
+++ b/packages/e17/e-wm_cvs.bb
@@ -2,11 +2,12 @@ DESCRIPTION = "The Enlightenment Window Mananger Version 17"
DEPENDS = "eet evas ecore edje efreet"
LICENSE = "MIT BSD"
PV = "0.16.999.042+cvs${SRCDATE}"
-PR = "r0"
+PR = "r1"
inherit e update-alternatives
SRC_URI = "${E_CVS};module=e17/apps/e \
+ file://disable-e-cursor.patch;patch=1 \
file://Xsession.d/98enlightenment \
file://applications.menu \
"
diff --git a/packages/efl1/ecore.inc b/packages/efl1/ecore.inc
index 6175c605c0..84c0b90c29 100644
--- a/packages/efl1/ecore.inc
+++ b/packages/efl1/ecore.inc
@@ -5,7 +5,7 @@ DEPENDS = "curl eet evas tslib"
# DEPENDS += "directfb libsdl-x11 openssl virtual/libiconv"
PV = "0.9.9.042+cvs${SRCDATE}"
-inherit efl_library
+inherit efl
SRC_URI += "file://fix-directfb-include.patch;patch=1"
diff --git a/packages/efl1/edb_cvs.bb b/packages/efl1/edb_cvs.bb
index 97dafb3931..8ad9c361a0 100644
--- a/packages/efl1/edb_cvs.bb
+++ b/packages/efl1/edb_cvs.bb
@@ -3,4 +3,4 @@ LICENSE = "MIT BSD"
DEPENDS = "zlib"
PV = "1.0.5.042+cvs${SRCDATE}"
-inherit efl_library
+inherit efl
diff --git a/packages/efl1/edbus_cvs.bb b/packages/efl1/edbus_cvs.bb
index feb940f4ec..0a4e04e558 100644
--- a/packages/efl1/edbus_cvs.bb
+++ b/packages/efl1/edbus_cvs.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT BSD"
PV = "0.1.0.042+cvs${SRCDATE}"
PR = "r3"
-inherit efl_library
+inherit efl
SRC_URI = "${E_CVS};module=e17/libs/e_dbus"
S = "${WORKDIR}/e_dbus"
diff --git a/packages/efl1/edje_cvs.bb b/packages/efl1/edje_cvs.bb
index e930fc4795..d0a1848c93 100644
--- a/packages/efl1/edje_cvs.bb
+++ b/packages/efl1/edje_cvs.bb
@@ -2,9 +2,13 @@ DESCRIPTION = "Edje is the Enlightenment graphical design & layout library"
DEPENDS = "eet evas ecore embryo edje-native"
LICENSE = "MIT BSD"
PV = "0.5.0.042+cvs${SRCDATE}"
-PR = "r0"
+PR = "r1"
-inherit efl_library
+inherit efl
-PACKAGES =+ "${PN}-tools"
-FILES_${PN}-tools = "${bindir}/edje_*"
+PACKAGES =+ "${PN}-utils"
+DEBIAN_NOAUTONAME_${PN}-utils = "1"
+FILES_${PN}-utils = "\
+ ${bindir}/edje_* \
+ ${datadir}/edje/include/edje.inc \
+"
diff --git a/packages/efl1/eet_cvs.bb b/packages/efl1/eet_cvs.bb
index 370b385bf8..c834cfa60a 100644
--- a/packages/efl1/eet_cvs.bb
+++ b/packages/efl1/eet_cvs.bb
@@ -4,4 +4,4 @@ LICENSE = "MIT BSD"
PV = "0.9.10.042+cvs${SRCDATE}"
PR = "r0"
-inherit efl_library
+inherit efl
diff --git a/packages/efl1/eflpp_cvs.bb b/packages/efl1/eflpp_cvs.bb
index ce01d89112..19db2ef41e 100644
--- a/packages/efl1/eflpp_cvs.bb
+++ b/packages/efl1/eflpp_cvs.bb
@@ -5,7 +5,7 @@ LICENSE = "LGPL"
DEPENDS = "evas ecore edje emotion esmart etk ewl libsigc++-2.0"
PV = "0.1.0+cvs${SRCDATE}"
-inherit efl_library
+inherit efl
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
diff --git a/packages/efl1/efreet_cvs.bb b/packages/efl1/efreet_cvs.bb
index a1a027fc8f..3087391312 100644
--- a/packages/efl1/efreet_cvs.bb
+++ b/packages/efl1/efreet_cvs.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT BSD"
PV = "0.0.3.042+cvs${SRCDATE}"
PR = "r0"
-inherit efl_library
+inherit efl
PACKAGES =+ "${PN}-mime"
FILES_${PN}-mime = "${libdir}/libefreet_mime.so.*"
diff --git a/packages/efl1/embryo_cvs.bb b/packages/efl1/embryo_cvs.bb
index 2f5ab176ce..6befb0c065 100644
--- a/packages/efl1/embryo_cvs.bb
+++ b/packages/efl1/embryo_cvs.bb
@@ -1,6 +1,9 @@
DESCRIPTION = "The Enlightenment C-like scripting language for Edje"
LICENSE = "MIT BSD"
PV = "0.9.1.042+cvs${SRCDATE}"
-PR = "r0"
+PR = "r1"
-inherit efl_library
+inherit efl
+
+# HACK alert: When compiling for VFP embryo emits bugs -- maybe gcc bug
+#FULL_OPTIMIZATION_arm =+ "-O0"
diff --git a/packages/efl1/emotion_cvs.bb b/packages/efl1/emotion_cvs.bb
index 7ee7c384d6..826f201779 100644
--- a/packages/efl1/emotion_cvs.bb
+++ b/packages/efl1/emotion_cvs.bb
@@ -5,7 +5,7 @@ DEPENDS = "eet evas ecore edje gstreamer gst-plugins-base"
PV = "0.1.0+cvs${SRCDATE}"
PR = "r1"
-inherit efl_library
+inherit efl
EXTRA_OECONF = "--disable-xine --enable-gstreamer"
diff --git a/packages/efl1/engrave_cvs.bb b/packages/efl1/engrave_cvs.bb
index 689e254fc1..ec39189410 100644
--- a/packages/efl1/engrave_cvs.bb
+++ b/packages/efl1/engrave_cvs.bb
@@ -4,4 +4,4 @@ LICENSE = "MIT"
DEPENDS = "evas ecore"
PV = "0.0.0+cvs${SRCDATE}"
-inherit efl_library
+inherit efl
diff --git a/packages/efl1/enhance_cvs.bb b/packages/efl1/enhance_cvs.bb
index 728beb61ec..8c73fbe1d8 100644
--- a/packages/efl1/enhance_cvs.bb
+++ b/packages/efl1/enhance_cvs.bb
@@ -3,4 +3,4 @@ LICENSE = "MIT"
DEPENDS = "exml"
PV = "0.0.0+cvs${SRCDATE}"
-inherit efl_library
+inherit efl
diff --git a/packages/efl1/epdf_cvs.bb b/packages/efl1/epdf_cvs.bb
index fa4f4282e1..e48c36606e 100644
--- a/packages/efl1/epdf_cvs.bb
+++ b/packages/efl1/epdf_cvs.bb
@@ -4,7 +4,7 @@ DEPENDS = "poppler evas ecore etk ewl"
PV = "0.1.0+cvs${SRCDATE}"
PR = "r0"
-inherit efl_library
+inherit efl
SRC_URI = "${E_CVS};module=e17/proto/${SRCNAME} \
file://fix-plugin-path-check.patch;HACK=1;patch=1"
diff --git a/packages/efl1/epeg_cvs.bb b/packages/efl1/epeg_cvs.bb
index 3991dd3d21..16d1c333a9 100644
--- a/packages/efl1/epeg_cvs.bb
+++ b/packages/efl1/epeg_cvs.bb
@@ -4,4 +4,4 @@ DEPENDS = "jpeg"
PV = "0.9.0+cvs${SRCDATE}"
PR = "r0"
-inherit efl_library
+inherit efl
diff --git a/packages/efl1/epsilon_cvs.bb b/packages/efl1/epsilon_cvs.bb
index 4674e1913c..0c12621d33 100644
--- a/packages/efl1/epsilon_cvs.bb
+++ b/packages/efl1/epsilon_cvs.bb
@@ -6,7 +6,7 @@ DEPENDS = "imlib2 epeg libpng evas ecore edje perl-native"
PV = "0.3.0.012+cvs${SRCDATE}"
PR = "r1"
-inherit efl_library
+inherit efl
SRC_URI += "file://fix_alignment_error.patch;patch=1"
diff --git a/packages/efl1/esmart_cvs.bb b/packages/efl1/esmart_cvs.bb
index fa35d60d30..6cdae5754d 100644
--- a/packages/efl1/esmart_cvs.bb
+++ b/packages/efl1/esmart_cvs.bb
@@ -3,7 +3,7 @@ LICENSE = "MIT BSD"
DEPENDS = "evas ecore edje imlib2 epsilon libtool"
PV = "0.9.0.042+cvs${SRCDATE}"
-inherit efl_library
+inherit efl
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
diff --git a/packages/efl1/etk-native_cvs.bb b/packages/efl1/etk-native_cvs.bb
index 6770be4ab3..eedb832141 100644
--- a/packages/efl1/etk-native_cvs.bb
+++ b/packages/efl1/etk-native_cvs.bb
@@ -3,8 +3,3 @@ inherit native
DEPENDS = "evas-native ecore-native edje-native"
SRC_URI += "file://no-tests.patch;patch=1"
-
-do_stage_append() {
- mv ${STAGING_DIR}/include/etk ${STAGING_INCDIR}
-}
-
diff --git a/packages/efl1/etk_cvs.bb b/packages/efl1/etk_cvs.bb
index 90df74e61c..a39129fc69 100644
--- a/packages/efl1/etk_cvs.bb
+++ b/packages/efl1/etk_cvs.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
PV = "0.1.0.042+cvs${SRCDATE}"
PR = "r0"
-inherit efl_library
+inherit efl
# TODO package engines seperatly (do_split_packages)
@@ -16,3 +16,21 @@ FILES_${PN}-dev += "${libdir}/etk/engines/*.a ${libdir}/etk/engines/*.la"
FILES_${PN}-dbg += "${libdir}/etk/engines/.debug/"
RRECOMMENDS_${PN} = "${PN}-engines"
+
+PACKAGES += "etk-engines-software-x11"
+FILES_${PN}-engines-software-x11 = "${libdir}/etk/engines/ecore_evas_software_x11.so"
+
+#PACKAGES =+ "etk-engines-gl-x11"
+#FILES_${PN}-engines-gl-x11 = "${libdir}/etk/engines/ecore_evas_gl_x11.so"
+
+PACKAGES =+ "etk-engines-evas"
+FILES_${PN}-engines-evas = "${libdir}/etk/engines/ecore_evas.so"
+
+PACKAGES =+ "etk-engines-fb"
+FILES_${PN}-engines-fb = "${libdir}/etk/engines/ecore_fb.so"
+
+PACKAGES =+ "etk-engines-x11"
+FILES_${PN}-engines-x11 = "${libdir}/etk/engines/ecore_evas_x11.so"
+
+PACKAGES =+ "etk-engines-software-x11-16"
+FILES_${PN}-engines-software-x11-16 = "${libdir}/etk/engines/ecore_evas_software_x11_16.so"
diff --git a/packages/efl1/evas.inc b/packages/efl1/evas.inc
index 77ec2db308..e4779d5b44 100644
--- a/packages/efl1/evas.inc
+++ b/packages/efl1/evas.inc
@@ -4,7 +4,7 @@ LICENSE = "MIT BSD"
DEPENDS = "eet freetype jpeg libpng virtual/libx11 libxext libxrender"
PV = "0.9.9.042+cvs${SRCDATE}"
-inherit efl_library
+inherit efl
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/evas"
EXTRA_OECONF = "<override me>"
@@ -26,7 +26,6 @@ do_install_append() {
FILES_${PN}-dev += "${libdir}/evas/modules/*/*/*/*.a ${libdir}/evas/modules/*/*/*/*.la"
FILES_${PN}-dbg += "${libdir}/evas/modules/*/*/*/.debug/"
-FILES_${PN} = "${libdir}/libevas*.so*"
PACKAGES_DYNAMIC = "libevas-engine-* libevas-loader-* libevas-saver-*"
diff --git a/packages/efl1/evolve_cvs.bb b/packages/efl1/evolve_cvs.bb
index 272d90002e..02706eb978 100644
--- a/packages/efl1/evolve_cvs.bb
+++ b/packages/efl1/evolve_cvs.bb
@@ -3,4 +3,4 @@ LICENSE = "MIT"
DEPENDS = "etk evolve-native"
PV = "0.0.0+cvs${SRCDATE}"
-inherit efl_library
+inherit efl
diff --git a/packages/efl1/ewl_cvs.bb b/packages/efl1/ewl_cvs.bb
index 15a777df67..eb00215891 100644
--- a/packages/efl1/ewl_cvs.bb
+++ b/packages/efl1/ewl_cvs.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT BSD"
PV = "0.5.2.042+cvs${SRCDATE}"
PR = "r0"
-inherit efl_library
+inherit efl
EXTRA_OECONF = "\
--enable-software-x11 \
diff --git a/packages/efl1/exml_cvs.bb b/packages/efl1/exml_cvs.bb
index b94af05833..d63fa056bb 100644
--- a/packages/efl1/exml_cvs.bb
+++ b/packages/efl1/exml_cvs.bb
@@ -3,5 +3,5 @@ LICENSE = "MIT"
DEPENDS = "libxml2 libxslt ecore"
PV = "0.1.1+cvs${SRCDATE}"
-inherit efl_library
+inherit efl
diff --git a/packages/efl1/imlib2_cvs.bb b/packages/efl1/imlib2_cvs.bb
index e17f3c04c1..c1d1f72791 100644
--- a/packages/efl1/imlib2_cvs.bb
+++ b/packages/efl1/imlib2_cvs.bb
@@ -5,7 +5,7 @@ DEPENDS = "freetype libpng jpeg virtual/libx11 libxext"
PV = "1.4.1.000+cvs${SRCDATE}"
PR = "r0"
-inherit efl_library
+inherit efl
SRC_URI += "file://remove-local-includes.patch;patch=1"
diff --git a/packages/python/python-2.5-manifest.inc b/packages/python/python-2.5-manifest.inc
index 9c4e68dfce..c098494d17 100644
--- a/packages/python/python-2.5-manifest.inc
+++ b/packages/python/python-2.5-manifest.inc
@@ -1,5 +1,5 @@
-#######################################################################################################################
-### AUTO-GENERATED by './contrib/python/generate-manifest-2.5.py' [(C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>] on Thu Mar 6 18:04:21 2008
+########################################################################################################################
+### AUTO-GENERATED by './generate-manifest-2.5.py' [(C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>] on Fri Mar 21 18:43:05 2008
###
### Visit THE Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
###
@@ -8,9 +8,9 @@
########################################################################################################################
-PROVIDES+="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
+PROVIDES+="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
-PACKAGES="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
+PACKAGES="python-profile python-threading python-distutils python-textutils python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-math python-hotshot python-unixadmin python-syslog python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
DESCRIPTION_python-profile="Python Basic Profiling Support"
PR_python-profile="ml0"
@@ -97,6 +97,11 @@ PR_python-image="ml0"
RDEPENDS_python-image="python-core"
FILES_python-image="${libdir}/python2.5/colorsys.* ${libdir}/python2.5/imghdr.* ${libdir}/python2.5/lib-dynload/imageop.so ${libdir}/python2.5/lib-dynload/rgbimg.so "
+DESCRIPTION_python-tests="Python Tests"
+PR_python-tests="ml0"
+RDEPENDS_python-tests="python-core"
+FILES_python-tests="${libdir}/python2.5/test "
+
DESCRIPTION_python-core-dbg="Python core module debug information"
PR_python-core-dbg="ml0"
RDEPENDS_python-core-dbg="python-core"
@@ -213,14 +218,14 @@ RDEPENDS_python-mime="python-core python-io"
FILES_python-mime="${libdir}/python2.5/mimetools.* ${libdir}/python2.5/uu.* ${libdir}/python2.5/quopri.* ${libdir}/python2.5/rfc822.* "
DESCRIPTION_python-sqlite3="Python Sqlite3 Database Support"
-PR_python-sqlite3="ml1"
-RDEPENDS_python-sqlite3="python-core"
-FILES_python-sqlite3="${libdir}/python2.5/lib-dynload/_sqlite3.so ${libdir}/python2.5/sqlite3 "
-
-DESCRIPTION_python-tests="Python Tests"
-PR_python-tests="ml0"
-RDEPENDS_python-tests="python-core"
-FILES_python-tests="${libdir}/python2.5/test "
+PR_python-sqlite3="ml2"
+RDEPENDS_python-sqlite3="python-core python-datetime python-lang python-crypt python-io python-threading python-zlib"
+FILES_python-sqlite3="${libdir}/python2.5/lib-dynload/_sqlite3.so ${libdir}/python2.5/sqlite3/dbapi2.* ${libdir}/python2.5/sqlite3/__init__.* "
+
+DESCRIPTION_python-sqlite3-tests="Python Sqlite3 Database Support Tests"
+PR_python-sqlite3-tests="ml0"
+RDEPENDS_python-sqlite3-tests="python-core python-sqlite3"
+FILES_python-sqlite3-tests="${libdir}/python2.5/sqlite3/test "
DESCRIPTION_python-unittest="Python Unit Testing Framework"
PR_python-unittest="ml0"
diff --git a/packages/python/python-pysqlite2_2.4.0.bb b/packages/python/python-pysqlite2_2.4.0.bb
index 751122e10e..50adcba006 100644
--- a/packages/python/python-pysqlite2_2.4.0.bb
+++ b/packages/python/python-pysqlite2_2.4.0.bb
@@ -4,9 +4,10 @@ PRIORITY = "optional"
LICENSE = "BSD"
DEPENDS = "sqlite3"
SRCNAME = "pysqlite"
+PR = "ml1"
SRC_URI = "http://initd.org/pub/software/pysqlite/releases/2.4/${PV}/${SRCNAME}-${PV}.tar.gz \
- file://fix-setup.patch;patch=1"
+ file://fix-setup.patch;patch=1"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
@@ -15,3 +16,17 @@ do_install_append() {
install -d ${D}${datadir}/doc/
mv ${D}${datadir}/pysqlite2-doc ${D}${datadir}/doc/${PN}
}
+
+RDEPENDS = "\
+ python-datetime \
+ python-lang \
+ python-crypt \
+ python-io \
+ python-threading \
+ python-unittest \
+ python-zlib \
+"
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/pysqlite2/test"
+RDEPENDS_${PN}-tests = "${PN}"