aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2005-07-06 20:51:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-06 20:51:46 +0000
commita0dfd9af4c15763fc59b623259af6f6f851e9483 (patch)
tree37cb4b9bf47ac3d20aba52e8b024f2d4a87b0024
parent4c4111af549167c102374d5f7b0daf0eb5d8b07f (diff)
downloadopenembedded-a0dfd9af4c15763fc59b623259af6f6f851e9483.tar.gz
Clean up (begin):
Use ${palmtopdir} instead of hardcoding /opt/QtPalmtop. This eases to switch the default opie location once we want it (/usr, /opt/Qtopia /home/sweat/home)
-rw-r--r--classes/opie_i18n.bbclass12
-rw-r--r--packages/nonworking/freenote/freenote_1.6.1.bb10
-rw-r--r--packages/nonworking/qualendar/qualendar_0.8.0.bb10
3 files changed, 16 insertions, 16 deletions
diff --git a/classes/opie_i18n.bbclass b/classes/opie_i18n.bbclass
index 7ceae83124..cb3d07de75 100644
--- a/classes/opie_i18n.bbclass
+++ b/classes/opie_i18n.bbclass
@@ -9,7 +9,7 @@
#
I18N_STATS = "1"
-SRC_URI += "cvs://anoncvs:anoncvs@cvs.handhelds.org/cvs;module=opie/i18n"
+SRC_URI += "${HANDHELDS_CVS};module=opie/i18n"
DEPENDS += "opie-i18n"
die () {
@@ -122,14 +122,14 @@ do_build_opie_i18n () {
# If we don't adjust FILES to exclude the i18n directory, we will end up with
# _lots_ of empty i18n/$lang directories in the original .ipk.
- if (echo "${FILES}" | egrep "/opt/QtPalmtop/? |/opt/QtPalmtop/?$") &>/dev/null
+ if (echo "${FILES}" | egrep "${palmtopdir}/? |${palmtopdir}/?$") &>/dev/null
then
- echo "NOTE: FILES was set to /opt/QtPalmtop which would include the i18n directory"
- echo -e "\n\nI'll remove /opt/QtPalmtop from FILES and replace it with all directories"
+ echo "NOTE: FILES was set to ${palmtopdir} which would include the i18n directory"
+ echo -e "\n\nI'll remove ${palmtopdir} from FILES and replace it with all directories"
echo "below QtPalmtop, except i18n ($qt_dirs). See classes/opie_i18n.oeclass for details"
# Removes /opt/QtPalmtop from FILES but keeps /opt/QtPalmtop/$some_dir
- FILES="`echo "$FILES"| sed "s#/opt/QtPalmtop[/]\?\$\|/opt/QtPalmtop[/]\? ##"`"
+ FILES="`echo "$FILES"| sed "s#${palmtopdir}[/]\?\$\|${palmtopdir}[/]\? ##"`"
echo "${PN}#$FILES $dir_" >> "${WORKDIR}/FILES.tmp"
fi
@@ -138,7 +138,7 @@ do_build_opie_i18n () {
if test -z "${FILES}"
then
echo "NOTE:"
- echo -e "Since FILES is empty, i'll add all directories below /o/QtPalmtop to it,\nexcluding i18n: ( $qt_dirs )"
+ echo -e "Since FILES is empty, i'll add all directories below ${palmtopdir} to it,\nexcluding i18n: ( $qt_dirs )"
echo "${PN}#$FILES $dir_" >> "${WORKDIR}/FILES.tmp"
fi
diff --git a/packages/nonworking/freenote/freenote_1.6.1.bb b/packages/nonworking/freenote/freenote_1.6.1.bb
index dacafdb365..d8ada414e9 100644
--- a/packages/nonworking/freenote/freenote_1.6.1.bb
+++ b/packages/nonworking/freenote/freenote_1.6.1.bb
@@ -14,9 +14,9 @@ do_configure_prepend() {
}
do_install() {
- install -d ${D}/opt/QtPalmtop/{bin,apps/Applications,pics}
- install -D -m 755 freenoteeintu ${D}/opt/QtPalmtop/bin/freenoteeintu
- install -D -m 644 ${FILESDIR}/freenoteeintu.desktop ${D}/opt/QtPalmtop/apps/Applications/freenoteeintu.desktop
- install -d ${D}/opt/QtPalmtop/pics
- cp -a *.png ${D}/opt/QtPalmtop/pics/
+ install -d ${D}${palmtopdir}/{bin,apps/Applications,pics}
+ install -D -m 755 freenoteeintu ${D}${palmtopdir}/bin/freenoteeintu
+ install -D -m 644 ${FILESDIR}/freenoteeintu.desktop ${D}${palmtopdir}/apps/Applications/freenoteeintu.desktop
+ install -d ${D}/${palmtopdir}/pics
+ cp -a *.png ${D}${palmtopdir}/pics/
}
diff --git a/packages/nonworking/qualendar/qualendar_0.8.0.bb b/packages/nonworking/qualendar/qualendar_0.8.0.bb
index a6a73f19d8..3a4bb15e35 100644
--- a/packages/nonworking/qualendar/qualendar_0.8.0.bb
+++ b/packages/nonworking/qualendar/qualendar_0.8.0.bb
@@ -9,9 +9,9 @@ S = ${WORKDIR}/${PN}/src
inherit palmtop
do_install() {
- install -d ${D}/opt/QtPalmtop/{bin,apps/Applications,pics}
- install -D -m 755 qualendar ${D}/opt/QtPalmtop/bin/qualendar
- install -D -m 644 qualendar.desktop ${D}/opt/QtPalmtop/apps/Applications/qualendar.desktop
- install -d ${D}/opt/QtPalmtop/pics
- cp -a *.png ${D}/opt/QtPalmtop/pics/
+ install -d ${D}${palmtopdir}/{bin,apps/Applications,pics}
+ install -D -m 755 qualendar ${D}${palmtopdir}/bin/qualendar
+ install -D -m 644 qualendar.desktop ${D}${palmtopdir}/apps/Applications/qualendar.desktop
+ install -d ${D}${palmtopdir}/pics
+ cp -a *.png ${D}${palmtopdir}/pics/
}