aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@openmoko.org>2008-08-28 19:20:09 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-10-15 21:04:07 +0200
commitb0252872d7f9fbb0d9d735713a467643405fb4c5 (patch)
tree72368b245805cb96a5b1f5186eb998fd0c590ba9
parent20e32f99b62af471dc08ceab0510c336429e83bc (diff)
downloadopenembedded-b0252872d7f9fbb0d9d735713a467643405fb4c5.tar.gz
[hal] Create hal-info.inc and share it with the releases
-rw-r--r--packages/hal/hal-info.inc20
-rw-r--r--packages/hal/hal-info_20070618.bb21
-rw-r--r--packages/hal/hal-info_20080313.bb21
3 files changed, 22 insertions, 40 deletions
diff --git a/packages/hal/hal-info.inc b/packages/hal/hal-info.inc
new file mode 100644
index 0000000000..635fd0aa41
--- /dev/null
+++ b/packages/hal/hal-info.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Hardware Abstraction Layer device information"
+HOMEPAGE = "http://hal.freedesktop.org/"
+SECTION = "unknown"
+LICENSE = "GPL AFL"
+
+SRC_URI = "http://hal.freedesktop.org/releases/${PN}-${PV}.tar.gz"
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-recall --disable-video"
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} += "${datadir}/hal/"
diff --git a/packages/hal/hal-info_20070618.bb b/packages/hal/hal-info_20070618.bb
index 690dbe614d..e6d50e3981 100644
--- a/packages/hal/hal-info_20070618.bb
+++ b/packages/hal/hal-info_20070618.bb
@@ -1,20 +1 @@
-DESCRIPTION = "Hardware Abstraction Layer device information"
-HOMEPAGE = "http://freedesktop.org/Software/hal"
-SECTION = "unknown"
-LICENSE = "GPL AFL"
-
-SRC_URI = "http://people.freedesktop.org/~david/dist/hal-info-20070618.tar.gz"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--disable-recall --disable-video"
-
-do_configure() {
- gnu-configize
- libtoolize --force
- oe_runconf
-}
-
-
-PACKAGE_ARCH = "all"
-FILES_${PN} += "${datadir}/hal/"
+require hal-info.inc
diff --git a/packages/hal/hal-info_20080313.bb b/packages/hal/hal-info_20080313.bb
index 635fd0aa41..e6d50e3981 100644
--- a/packages/hal/hal-info_20080313.bb
+++ b/packages/hal/hal-info_20080313.bb
@@ -1,20 +1 @@
-DESCRIPTION = "Hardware Abstraction Layer device information"
-HOMEPAGE = "http://hal.freedesktop.org/"
-SECTION = "unknown"
-LICENSE = "GPL AFL"
-
-SRC_URI = "http://hal.freedesktop.org/releases/${PN}-${PV}.tar.gz"
-S = "${WORKDIR}/${PN}-${PV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--disable-recall --disable-video"
-
-do_configure() {
- gnu-configize
- libtoolize --force
- oe_runconf
-}
-
-PACKAGE_ARCH = "all"
-FILES_${PN} += "${datadir}/hal/"
+require hal-info.inc