aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-12-20 22:12:12 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-12-20 22:12:12 +0000
commitc6150944b250086c0375b86ce819a8b9bf9d2820 (patch)
tree045f5632fe15e0d3ffe3057993a3eedbbb10028f
parentffce2eacb62f33a616e3f69c25eff2bb313217ee (diff)
parent7b2f0f5182290ebfe022a12d5fc1b34f9fbc000c (diff)
downloadopenembedded-c6150944b250086c0375b86ce819a8b9bf9d2820.tar.gz
merge of '848e56fa546fe4f9defbbca37a6baee4fab0c6fc'
and 'b0214fe2d462308558a4fdd18ac2097bc53e51b2'
-rw-r--r--packages/flumotion/flumotion_0.4.1.bb16
-rw-r--r--packages/python/python-pygtk_2.10.4.bb8
2 files changed, 16 insertions, 8 deletions
diff --git a/packages/flumotion/flumotion_0.4.1.bb b/packages/flumotion/flumotion_0.4.1.bb
index aad4eb3382..f709086846 100644
--- a/packages/flumotion/flumotion_0.4.1.bb
+++ b/packages/flumotion/flumotion_0.4.1.bb
@@ -1,13 +1,19 @@
DESCRIPTION = "Fluendo Streaming Server"
LICENSE = "GPL"
-DEPENDS = "gstreamer python-imaging python-gst twisted python-pygtk2"
-RDEPENDS = " python-resource python-pprint python-threading python-imaging python-xml python-curses python-compression python-fcntl python-pygobject python-pickle python-netclient python-datetime python-crypt python-twisted-core python-twisted-web python-lang python-zopeinterface python-textutils python-core python-gst python-misc"
-RDEPENDS_${PN}-gui = "${PN} python-pygtk2 python-pycairo "
-PR = "r7"
+DEPENDS = "gstreamer python-imaging python-gst twisted python-pygtk"
+RDEPENDS = "python-resource python-pprint python-threading \
+ python-imaging python-xml python-curses \
+ python-compression python-fcntl python-pygobject \
+ python-pickle python-netclient python-datetime \
+ python-crypt python-twisted-core python-twisted-web \
+ python-lang python-zopeinterface python-textutils \
+ python-gst python-misc"
+RDEPENDS_${PN}-gui = "${PN} python-pygtk python-pycairo"
+PR = "r9"
SRC_URI = "http://www.flumotion.net/src/flumotion/flumotion-${PV}.tar.bz2 \
file://python-path.patch;patch=1 \
- file://no-check-for-python-stuff.patch;patch=1"
+ file://no-check-for-python-stuff.patch;patch=1"
inherit autotools distutils-base pkgconfig
diff --git a/packages/python/python-pygtk_2.10.4.bb b/packages/python/python-pygtk_2.10.4.bb
index 9b4a034ffa..1af2093556 100644
--- a/packages/python/python-pygtk_2.10.4.bb
+++ b/packages/python/python-pygtk_2.10.4.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Python GTK+ 2.10.x Bindings"
SECTION = "devel/python"
# needs gtk+ 2.10.x
-DEPENDS = "gtk+ libglade python-pycairo"
+DEPENDS = "gtk+ libglade python-pycairo python-pygobject"
RDEPENDS = "python-shell python-pycairo python-pygobject"
PROVIDES = "python-pygtk2"
SRCNAME = "pygtk"
@@ -13,8 +13,10 @@ SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.10/${SRCNAME}-${PV}.tar
file://acinclude.m4"
S = "${WORKDIR}/${SRCNAME}-${PV}"
-EXTRA_OECONF = "--disable-docs"
-EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+EXTRA_OECONF = "\
+ --disable-docs \
+ --with-python-includes=${STAGING_INCDIR}/../ \
+"
inherit autotools pkgconfig distutils-base