aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-10-09 09:24:57 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-10-09 09:24:57 +0000
commitcf2a6858576fa48baf9a764f39d3b2c8711624d7 (patch)
tree2f0a0af49e3e2a96284d5607949cc99c03141781
parent10bb92e04748af06ffc43c0cf9773de8a5e8914c (diff)
downloadopenembedded-cf2a6858576fa48baf9a764f39d3b2c8711624d7.tar.gz
libsdl-image: Moved common parts into libsdl-image.inc, added version 1.2.6
-rw-r--r--packages/libsdl/libsdl-image.inc18
-rw-r--r--packages/libsdl/libsdl-image_1.2.3.bb11
-rw-r--r--packages/libsdl/libsdl-image_1.2.6.bb8
3 files changed, 29 insertions, 8 deletions
diff --git a/packages/libsdl/libsdl-image.inc b/packages/libsdl/libsdl-image.inc
new file mode 100644
index 0000000000..1212e9cfa6
--- /dev/null
+++ b/packages/libsdl/libsdl-image.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Simple DirectMedia Layer image library."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "zlib libpng jpeg virtual/libsdl"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz"
+
+S = "${WORKDIR}/SDL_image-${PV}"
+
+inherit autotools
+
+do_stage() {
+ oe_libinstall -so libSDL_image ${STAGING_LIBDIR}
+ ln -sf libSDL_image.so ${STAGING_LIBDIR}/libSDL_image-1.2.so
+ install -m 0644 SDL_image.h ${STAGING_INCDIR}/SDL/SDL_image.h
+}
+
diff --git a/packages/libsdl/libsdl-image_1.2.3.bb b/packages/libsdl/libsdl-image_1.2.3.bb
index 7bf24412d2..0c83158c03 100644
--- a/packages/libsdl/libsdl-image_1.2.3.bb
+++ b/packages/libsdl/libsdl-image_1.2.3.bb
@@ -1,15 +1,10 @@
-DESCRIPTION = "Simple DirectMedia Layer image library."
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "zlib libpng jpeg virtual/libsdl"
-LICENSE = "LGPL"
+require libsdl-image.inc
+
PR = "r2"
-SRC_URI = "\
- http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz \
+SRC_URI += "\
file://autotools.patch;patch=1 \
"
-S = "${WORKDIR}/SDL_image-${PV}"
export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
diff --git a/packages/libsdl/libsdl-image_1.2.6.bb b/packages/libsdl/libsdl-image_1.2.6.bb
new file mode 100644
index 0000000000..27b5aa7d1a
--- /dev/null
+++ b/packages/libsdl/libsdl-image_1.2.6.bb
@@ -0,0 +1,8 @@
+require libsdl-image.inc
+
+do_unpackpost() {
+ # Removing this file fixes a libtool version mismatch.
+ rm acinclude/libtool.m4
+}
+
+addtask unpackpost after do_unpack before do_patch