aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2006-09-18 01:35:29 +0000
committerKristoffer Ericson <kristoffer_e1@hotmail.com>2006-09-18 01:35:29 +0000
commit2c7ccfb4f16b75825f29fa9a6ee2072bc6300fe1 (patch)
tree1f9fecab6f272a29c31eb15e16320947be896c87
parent54a3061ee9a6b045afb7b153167d3e834e040dcf (diff)
downloadopenembedded-2c7ccfb4f16b75825f29fa9a6ee2072bc6300fe1.tar.gz
gtk-webcore/osb-jscore-0.5.0: Addition of Patch
* Addition of patch to modify const declarations (style KJS::<function>) So that gcc likes them abit better (only for superh) * Change to osb-jscore_0.5.0.bb to reflect patch addition.
-rw-r--r--packages/gtk-webcore/osb-jscore-0.5.0/superh-ustring-declaration-error.patch47
-rw-r--r--packages/gtk-webcore/osb-jscore_0.5.0.bb3
2 files changed, 49 insertions, 1 deletions
diff --git a/packages/gtk-webcore/osb-jscore-0.5.0/superh-ustring-declaration-error.patch b/packages/gtk-webcore/osb-jscore-0.5.0/superh-ustring-declaration-error.patch
new file mode 100644
index 0000000000..c0c52444c8
--- /dev/null
+++ b/packages/gtk-webcore/osb-jscore-0.5.0/superh-ustring-declaration-error.patch
@@ -0,0 +1,47 @@
+--- osb-jscore-0.5.0/kjs/ustring.cpp_orig 2006-09-18 01:29:11.000000000 +0000
++++ osb-jscore-0.5.0/kjs/ustring.cpp 2006-09-18 01:29:46.000000000 +0000
+@@ -132,7 +132,7 @@
+ return *this;
+ }
+
+-bool KJS::operator==(const KJS::CString& c1, const KJS::CString& c2)
++bool operator==(const KJS::CString& c1, const KJS::CString& c2)
+ {
+ int len = c1.size();
+ return len == c2.size() && (len == 0 || memcmp(c1.c_str(), c2.c_str(), len) == 0);
+@@ -1094,7 +1094,7 @@
+ rep->deref();
+ }
+
+-bool KJS::operator==(const UString& s1, const UString& s2)
++bool operator==(const UString& s1, const UString& s2)
+ {
+ if (s1.rep->len != s2.rep->len)
+ return false;
+@@ -1103,7 +1103,7 @@
+ s1.rep->len * sizeof(UChar)) == 0);
+ }
+
+-bool KJS::operator==(const UString& s1, const char *s2)
++bool operator==(const UString& s1, const char *s2)
+ {
+ if (s2 == 0) {
+ return s1.isEmpty();
+@@ -1121,7 +1121,7 @@
+ return u == uend && *s2 == 0;
+ }
+
+-bool KJS::operator<(const UString& s1, const UString& s2)
++bool operator<(const UString& s1, const UString& s2)
+ {
+ const int l1 = s1.size();
+ const int l2 = s2.size();
+@@ -1140,7 +1140,7 @@
+ return (l1 < l2);
+ }
+
+-int KJS::compare(const UString& s1, const UString& s2)
++int compare(const UString& s1, const UString& s2)
+ {
+ const int l1 = s1.size();
+ const int l2 = s2.size();
diff --git a/packages/gtk-webcore/osb-jscore_0.5.0.bb b/packages/gtk-webcore/osb-jscore_0.5.0.bb
index 3a1ff2b65e..c5d2fc4e9e 100644
--- a/packages/gtk-webcore/osb-jscore_0.5.0.bb
+++ b/packages/gtk-webcore/osb-jscore_0.5.0.bb
@@ -11,7 +11,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/gtk-webcore/osb-jscore-${PV}.tar.gz \
file://libm.patch;patch=1"
SRC_URI_append_sh3 = " file://superh-aclocal.patch;patch=1 \
- file://gcc4-fno-threadsafe-statics.patch;patch=1"
+ file://gcc4-fno-threadsafe-statics.patch;patch=1 \
+ file://superh-ustring-declaration-error.patch;patch=1"
inherit autotools pkgconfig