aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Schurig <schurig@mn-solutions.de>2005-04-04 10:21:26 +0000
committerHolger Schurig <schurig@mn-solutions.de>2005-04-04 10:21:26 +0000
commit5fa979f5ade9d31d5df4d81b9105ebd4dc75cc9f (patch)
treecd5ac590dd87e0e2c2a22fd7de1e6d6c9476e28f
parent7d1d016d9f60f3d90933c1c207511fc36a53c126 (diff)
downloadopenembedded-5fa979f5ade9d31d5df4d81b9105ebd4dc75cc9f.tar.gz
A couple of packages (util-linux and procps) expect the PAGE_SIZE define from
<asm/page.h> to be a constant (e.g. using it to set the size of a static array) which no longer works since the latest glibc has changed this to use the "getpagesize()" function. There may be others, but these are the two that failed for me. BKrev: 42511526QrKR819dMIxBogIdn-8lIA
-rw-r--r--packages/procps/procps-3.2.1/pagesz-not-constant.patch0
-rw-r--r--packages/procps/procps_3.2.1.bb21
-rw-r--r--packages/util-linux/util-linux-2.12/pagesz-not-constant.patch0
-rw-r--r--packages/util-linux/util-linux_2.12o.bb5
4 files changed, 24 insertions, 2 deletions
diff --git a/packages/procps/procps-3.2.1/pagesz-not-constant.patch b/packages/procps/procps-3.2.1/pagesz-not-constant.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/procps/procps-3.2.1/pagesz-not-constant.patch
diff --git a/packages/procps/procps_3.2.1.bb b/packages/procps/procps_3.2.1.bb
index e69de29bb2..4796bbf7bf 100644
--- a/packages/procps/procps_3.2.1.bb
+++ b/packages/procps/procps_3.2.1.bb
@@ -0,0 +1,21 @@
+LICENSE = GPL
+DESCRIPTION = "Procps is the package that has a bunch \
+of small useful utilities that give information \
+about processes using the /proc filesystem. The package \
+includes the programs ps, top, vmstat, w, kill, and skill."
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = "ncurses"
+PR = "r1"
+
+SRC_URI = "http://procps.sourceforge.net/procps-${PV}.tar.gz \
+ file://install.patch;patch=1 \
+ file://pagesz-not-constant.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OEMAKE = "CFLAGS=-I${STAGING_INCDIR} \
+ LDFLAGS=-L${STAGING_LIBDIR} -Wl,--rpath-link,${STAGING_LIBDIR} \
+ CURSES=-lncurses \
+ install='install -D' \
+ ldconfig=echo"
diff --git a/packages/util-linux/util-linux-2.12/pagesz-not-constant.patch b/packages/util-linux/util-linux-2.12/pagesz-not-constant.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/util-linux/util-linux-2.12/pagesz-not-constant.patch
diff --git a/packages/util-linux/util-linux_2.12o.bb b/packages/util-linux/util-linux_2.12o.bb
index ab6179461b..5bcc761d38 100644
--- a/packages/util-linux/util-linux_2.12o.bb
+++ b/packages/util-linux/util-linux_2.12o.bb
@@ -1,11 +1,12 @@
inherit autotools
include util-linux.inc
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/util-linux/util-linux-${PV}.tar.bz2 \
file://gcc34.patch;patch=1 \
file://MCONFIG \
file://make_include \
file://swapargs.h \
- file://defines.h"
+ file://defines.h \
+ file://pagesz-not-constant.patch;patch=1"