aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-31 17:13:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-31 17:13:37 +0000
commit0181fca36610a03b991be5985aa53f794e9ce323 (patch)
tree46bc41bcc1f0c7b97e663774a712a3eba3833ba5
parent86181904a0f3f872c02c88ad604092101fc65505 (diff)
downloadopenembedded-0181fca36610a03b991be5985aa53f794e9ce323.tar.gz
file-native: fix do_stage in 4.13
- the hand crafted do_stage installed a broken file in staging, the fix is to use the standard native do_stage which does a proper install using the makefile
-rw-r--r--packages/file/file-native_4.13.bb6
-rw-r--r--packages/file/file_4.13.bb4
2 files changed, 2 insertions, 8 deletions
diff --git a/packages/file/file-native_4.13.bb b/packages/file/file-native_4.13.bb
index d030f735ae..f92ff15f78 100644
--- a/packages/file/file-native_4.13.bb
+++ b/packages/file/file-native_4.13.bb
@@ -3,9 +3,3 @@ inherit native
# avoid dependency loop
DEPENDS = ""
-
-do_stage() {
- install -m 0755 src/file ${STAGING_BINDIR}/
- oe_libinstall -so -C src libmagic ${STAGING_LIBDIR}/
-}
-
diff --git a/packages/file/file_4.13.bb b/packages/file/file_4.13.bb
index eac5c8a18f..ac5201b739 100644
--- a/packages/file/file_4.13.bb
+++ b/packages/file/file_4.13.bb
@@ -3,7 +3,7 @@ on their contents and prints a description if a match is found."
SECTION = "console/utils"
LICENSE = "BSD-ADV"
DEPENDS = "file-native"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz"
S = "${WORKDIR}/file-${PV}"
@@ -15,5 +15,5 @@ do_configure_prepend() {
}
do_stage() {
-autotools_stage_all
+ autotools_stage_all
}