aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-05-31 21:59:26 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-31 21:59:26 +0000
commit06b41211b9cec9ffb12c834956cb9d11aeaa11e3 (patch)
tree5b04e2e6dc090b4defaa0d973baf6a7eb923e9c7
parent2de37f2649fbea19b30360e626f9764c43e53918 (diff)
downloadopenembedded-06b41211b9cec9ffb12c834956cb9d11aeaa11e3.tar.gz
classes
bootimg.bbclass - This creates a bootable image using syslinux, your kernel and an optional initrd kernel.bbclass - drivers/crypto and include/acpi are needed by some pkgconfig.bbclass - searching for .pc files syslinux.bbclass - This creates a configuration file suitable for use with syslinux. site mipsel-linux, i486-linux, i686-linux, x86_64-linux updates for: gcc, lmbench, X11R7.0, sudo, audacity conf add db1200 and geodelx machine configurations.
-rw-r--r--classes/kernel.bbclass12
-rw-r--r--classes/pkgconfig.bbclass2
-rw-r--r--site/i486-linux13
-rw-r--r--site/i686-linux5
-rw-r--r--site/mipsel-linux3
-rw-r--r--site/x86_64-linux3
6 files changed, 35 insertions, 3 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index ad51c4e035..502a2a677d 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -109,6 +109,16 @@ kernel_do_stage() {
mkdir -p ${STAGING_KERNEL_DIR}/include/pcmcia
cp -fR include/pcmcia/* ${STAGING_KERNEL_DIR}/include/pcmcia/
+ if [ -d drivers/crypto ]; then
+ mkdir -p ${STAGING_KERNEL_DIR}/drivers/crypto
+ cp -fR drivers/crypto/* ${STAGING_KERNEL_DIR}/drivers/crypto/
+ fi
+
+ if [ -d include/acpi ]; then
+ mkdir -p ${STAGING_KERNEL_DIR}/include/acpi
+ cp -fR include/acpi/* ${STAGING_KERNEL_DIR}/include/acpi/
+ fi
+
if [ -d include/sound ]; then
mkdir -p ${STAGING_KERNEL_DIR}/include/sound
cp -fR include/sound/* ${STAGING_KERNEL_DIR}/include/sound/
@@ -133,7 +143,7 @@ kernel_do_stage() {
# Check if arch/${ARCH}/Makefile exists and install it
if [ -e arch/${ARCH}/Makefile ]; then
install -d ${STAGING_KERNEL_DIR}/arch/${ARCH}
- install -m 0644 arch/${ARCH}/Makefile ${STAGING_KERNEL_DIR}/arch/${ARCH}
+ install -m 0644 arch/${ARCH}/Makefile* ${STAGING_KERNEL_DIR}/arch/${ARCH}
fi
cp -fR include/config* ${STAGING_KERNEL_DIR}/include/
install -m 0644 ${KERNEL_OUTPUT} ${STAGING_KERNEL_DIR}/${KERNEL_IMAGETYPE}
diff --git a/classes/pkgconfig.bbclass b/classes/pkgconfig.bbclass
index 62f15f312d..f2054b0b07 100644
--- a/classes/pkgconfig.bbclass
+++ b/classes/pkgconfig.bbclass
@@ -20,7 +20,7 @@ def get_pkgconfig_mangle(d):
return s
do_stage_append () {
- for pc in `find ${S} -name '*.pc' | grep -v -- '-uninstalled.pc$'`; do
+ for pc in `find ${S} -name '*.pc' -type f | grep -v -- '-uninstalled.pc$'`; do
pcname=`basename $pc`
install -d ${PKG_CONFIG_PATH}
cat $pc | sed ${@get_pkgconfig_mangle(d)} > ${PKG_CONFIG_PATH}/$pcname
diff --git a/site/i486-linux b/site/i486-linux
index 5ead29bb94..1791e58ea7 100644
--- a/site/i486-linux
+++ b/site/i486-linux
@@ -51,6 +51,7 @@ glib_cv_uscore=${glib_cv_uscore=no}
glib_cv___va_copy=${glib_cv___va_copy=yes}
glib_cv_va_copy=${glib_cv_va_copy=yes}
glib_cv_va_val_copy=${glib_cv_va_val_copy=yes}
+glib_cv_rtldglobal_broken=${glib_cv_rtldglobal_broken=yes}
# glib-2.0
glib_cv_stack_grows=${glib_cv_stack_grows=no}
@@ -60,7 +61,7 @@ glib_cv_use_pid_surrogate=${glib_cv_use_pid_surrogate=yes}
# jikes-native
ac_cv_sizeof_wchar_t=4
--
+
# startup-notification
lf_cv_sane_realloc=yes
@@ -129,3 +130,13 @@ am_cv_func_working_getline=${am_cv_func_working_getline=yes}
# intercom
ac_cv_func_fnmatch_works=yes
+
+#sudo
+sudo_cv_uid_t_len=${sudo_cv_uid_t_len=10}
+
+#audacity
+ac_cv_file_lib_src_libmad_frame_h=${ac_cv_file_lib_src_libmad_frame_h=no}
+
+# xorg X11R7
+ac_cv_sys_linker_h=${ac_cv_sys_linker_h=no}
+ac_cv_file__usr_share_X11_sgml_defs_ent=${ac_cv_file__usr_share_X11_sgml_defs_ent=no}
diff --git a/site/i686-linux b/site/i686-linux
index f5915e8e3a..113929adbb 100644
--- a/site/i686-linux
+++ b/site/i686-linux
@@ -52,6 +52,7 @@ glib_cv_uscore=${glib_cv_uscore=no}
glib_cv___va_copy=${glib_cv___va_copy=yes}
glib_cv_va_copy=${glib_cv_va_copy=yes}
glib_cv_va_val_copy=${glib_cv_va_val_copy=yes}
+glib_cv_rtldglobal_broken=${glib_cv_rtldglobal_broken=yes}
utils_cv_sys_open_max=${utils_cv_sys_open_max=1015}
# glib-2.0
@@ -197,3 +198,7 @@ with_broken_putenv=${with_broken_putenv=no}
# xffm
jm_cv_func_working_readdir=yes
+
+#xserver-xorg
+ac_cv_sys_linker_h=${ac_cv_sys_linker_h=no}
+ac_cv_file__usr_share_X11_sgml_defs_ent=${ac_cv_file__usr_share_X11_sgml_defs_ent=no}
diff --git a/site/mipsel-linux b/site/mipsel-linux
index fe0ee88c52..7f776951d5 100644
--- a/site/mipsel-linux
+++ b/site/mipsel-linux
@@ -114,3 +114,6 @@ sudo_cv_uid_t_len=${sudo_cv_uid_t_len=10}
#intercom
ac_cv_func_fnmatch_works=${ac_cv_func_fnmatch_works=yes}
+
+#lmbench
+ac_cv_uint=${ac_cv_unit=yes}
diff --git a/site/x86_64-linux b/site/x86_64-linux
index ba60564d0d..dc7cb09069 100644
--- a/site/x86_64-linux
+++ b/site/x86_64-linux
@@ -78,3 +78,6 @@ utils_cv_sys_open_max=${utils_cv_sys_open_max=1015}
# gettext
am_cv_func_working_getline=${am_cv_func_working_getline=yes}
+
+#gcc
+ac_cv_lib_m_sin=${ac_cv_lib_m_sin=yes}