aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-06-05 04:44:34 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-05 04:44:34 +0000
commit166b2d474b24c32054ac5de1f57acb4b3e56e719 (patch)
treeec41d7c86f42547464034cbaefb4ff7da071d3c9
parente6db327478cc5ff72feb5ca7c221e36ee163dd22 (diff)
downloadopenembedded-166b2d474b24c32054ac5de1f57acb4b3e56e719.tar.gz
mtnpatch: replace split with regex
-rw-r--r--classes/efl.bbclass2
-rwxr-xr-x[-rw-r--r--]contrib/mtnpatch.py14
-rw-r--r--packages/e17/e-utils_20060501.bb (renamed from packages/e17/e-utils_20060128.bb)0
3 files changed, 6 insertions, 10 deletions
diff --git a/classes/efl.bbclass b/classes/efl.bbclass
index 9c490284c2..c258758d30 100644
--- a/classes/efl.bbclass
+++ b/classes/efl.bbclass
@@ -44,6 +44,6 @@ do_stage_append () {
}
PACKAGES = "${PN} ${PN}-themes ${PN}-dev ${PN}-examples"
-FILES_${PN}-dev = "${bindir}/${PN}-config ${libdir}/pkgconfig ${libdir}/lib*.?a ${libdir}/lib*.a"
+FILES_${PN}-dev = "${bindir}/${PN}-config ${libdir}/pkgconfig ${libdir}/lib*.?a ${libdir}/lib*.a ${includedir}"
FILES_${PN}-examples = "${bindir} ${datadir}"
diff --git a/contrib/mtnpatch.py b/contrib/mtnpatch.py
index 520ebfaff0..73143dba69 100644..100755
--- a/contrib/mtnpatch.py
+++ b/contrib/mtnpatch.py
@@ -1,5 +1,5 @@
#!/usr/bin/env python
-import sys, os, string, getopt
+import sys, os, string, getopt, re
mtncmd = "monotone"
@@ -25,14 +25,10 @@ def main(argv = None):
for line in input:
if len(line) > 0:
if line[0] == '#':
- parts = line.split()
- if len(parts) > 2:
- cmd = parts[1]
- # deal with whilespace in filenames (badly)
- fileName = parts[2]
- i = 3
- while i < len(parts) and fileName.count('"') % 2:
- fileName += " %s" % parts[i]
+ matches = re.search("#\s+(\w+)\s+\"(.*)\"", line)
+ if matches is not None:
+ cmd = matches.group(1)
+ fileName = matches.group(2)
if cmd == "delete_file":
if reverse:
print "%s add %s" % (mtncmd, fileName)
diff --git a/packages/e17/e-utils_20060128.bb b/packages/e17/e-utils_20060501.bb
index 3f1af895ae..3f1af895ae 100644
--- a/packages/e17/e-utils_20060128.bb
+++ b/packages/e17/e-utils_20060501.bb