aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-02-14 16:34:08 +0000
committerKoen Kooi <koen@openembedded.org>2007-02-14 16:34:08 +0000
commit2a49beee973cefc70b164d92b95a8f74973a67df (patch)
tree44c7507c217bf1287f77c7a9012de1b213fa4766
parentf7c7958d650d95f0d98ac3c578e8ecc0140242e4 (diff)
downloadopenembedded-2a49beee973cefc70b164d92b95a8f74973a67df.tar.gz
uboot gta01: add patch to get around EABI version 0 versus version 4 problems
-rw-r--r--packages/uboot/files/fix-arm920t-eabi.patch9
-rw-r--r--packages/uboot/uboot-gta01_svn.bb5
2 files changed, 12 insertions, 2 deletions
diff --git a/packages/uboot/files/fix-arm920t-eabi.patch b/packages/uboot/files/fix-arm920t-eabi.patch
new file mode 100644
index 0000000000..9896388c8f
--- /dev/null
+++ b/packages/uboot/files/fix-arm920t-eabi.patch
@@ -0,0 +1,9 @@
+--- /tmp/config.mk 2007-02-14 17:23:15.000000000 +0100
++++ git/cpu/arm920t/config.mk 2007-02-14 17:23:38.475251000 +0100
+@@ -30,5 +30,5 @@
+ # Supply options according to compiler version
+ #
+ # =========================================================================
+-PLATFORM_CPPFLAGS +=$(call cc-option,-mapcs-32,-mabi=apcs-gnu)
++PLATFORM_CPPFLAGS +=$(call cc-option)
+ PLATFORM_RELFLAGS +=$(call cc-option,-mshort-load-bytes,$(call cc-option,-malignment-traps,))
diff --git a/packages/uboot/uboot-gta01_svn.bb b/packages/uboot/uboot-gta01_svn.bb
index ea12a0c334..21c35dada9 100644
--- a/packages/uboot/uboot-gta01_svn.bb
+++ b/packages/uboot/uboot-gta01_svn.bb
@@ -4,13 +4,14 @@ LICENSE = "GPL"
SECTION = "bootloader"
PRIORITY = "optional"
PV = "1.2.0+svn${SRCDATE}"
-PR = "r2"
+PR = "r3"
PROVIDES = "virtual/bootloader"
S = "${WORKDIR}/git"
SRC_URI = "git://www.denx.de/git/u-boot.git/;protocol=git \
- svn://svn.openmoko.org/trunk/src/target/u-boot;module=patches;proto=https"
+ svn://svn.openmoko.org/trunk/src/target/u-boot;module=patches;proto=https \
+ file://fix-arm920t-eabi.patch;patch=1"
EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
TARGET_LDFLAGS = ""