aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-11-20 11:04:45 +0000
committerRichard Purdie <rpurdie@rpsys.net>2006-11-20 11:04:45 +0000
commit3cb946597ed916b167109b9faecb8c6eb0a695e8 (patch)
tree07f9da78aeef27659c771a639c19a2b5d4b93cdb
parentecccb2d03ca2ed8bc4f5811dcfe796a403bf3a55 (diff)
downloadopenembedded-3cb946597ed916b167109b9faecb8c6eb0a695e8.tar.gz
Convert IPKG_ARCHS -> PACKAGE_ARCHS, IPKG_EXTRA_ARCHS -> PACKAGE_EXTRA_ARCHS in preparation for deb handling
-rw-r--r--classes/multimachine.bbclass2
-rw-r--r--classes/package_ipk.bbclass4
-rw-r--r--classes/packaged-staging.bbclass2
-rw-r--r--classes/rootfs_ipk.bbclass2
-rw-r--r--conf/bitbake.conf2
-rw-r--r--conf/distro/openmn.conf2
-rw-r--r--conf/distro/unslung.conf2
-rw-r--r--conf/documentation.conf4
-rw-r--r--conf/machine/a780.conf2
-rw-r--r--conf/machine/akita.conf2
-rw-r--r--conf/machine/blueangel.conf2
-rw-r--r--conf/machine/colinux.conf2
-rw-r--r--conf/machine/compulab-pxa270.conf2
-rw-r--r--conf/machine/db1200.conf2
-rw-r--r--conf/machine/devkitidp-pxa255.conf2
-rw-r--r--conf/machine/dht-walnut.conf2
-rw-r--r--conf/machine/efika.conf2
-rw-r--r--conf/machine/ep93xx.conf2
-rw-r--r--conf/machine/epia.conf2
-rw-r--r--conf/machine/guinness.conf2
-rw-r--r--conf/machine/h1910.conf2
-rw-r--r--conf/machine/h1940.conf2
-rw-r--r--conf/machine/h2200.conf2
-rw-r--r--conf/machine/h3600.conf2
-rw-r--r--conf/machine/h3900.conf2
-rw-r--r--conf/machine/h4000.conf2
-rw-r--r--conf/machine/h5xxx.conf2
-rw-r--r--conf/machine/h6300.conf2
-rw-r--r--conf/machine/htcuniversal.conf2
-rw-r--r--conf/machine/hx2000.conf2
-rw-r--r--conf/machine/hx4700.conf2
-rw-r--r--conf/machine/include/ixp4xx.conf8
-rw-r--r--conf/machine/include/tune-iwmmxt.conf2
-rw-r--r--conf/machine/include/zaurus-clamshell.conf2
-rw-r--r--conf/machine/ipaq-pxa270.conf2
-rw-r--r--conf/machine/ixp4xx.conf2
-rw-r--r--conf/machine/lite5200.conf2
-rw-r--r--conf/machine/logicpd-pxa270.conf2
-rw-r--r--conf/machine/magician.conf2
-rw-r--r--conf/machine/mainstone.conf2
-rw-r--r--conf/machine/mtx-1.conf2
-rw-r--r--conf/machine/mtx-2.conf2
-rw-r--r--conf/machine/mtx-3.conf2
-rw-r--r--conf/machine/mx31ads.conf2
-rw-r--r--conf/machine/navman-icn330.conf2
-rwxr-xr-xconf/machine/netbook-pro.conf2
-rw-r--r--conf/machine/nokia770.conf2
-rw-r--r--conf/machine/omap1510inn.conf2
-rw-r--r--conf/machine/omap1610h2.conf2
-rw-r--r--conf/machine/omap1710h3.conf2
-rw-r--r--conf/machine/omap2420h4.conf2
-rw-r--r--conf/machine/omap5912osk.conf2
-rw-r--r--conf/machine/palmld.conf2
-rw-r--r--conf/machine/poodle.conf2
-rw-r--r--conf/machine/qemuarm.conf2
-rw-r--r--conf/machine/rb500.conf2
-rw-r--r--conf/machine/smdk2440.conf2
-rw-r--r--conf/machine/spitz.conf2
-rw-r--r--conf/machine/tosa.conf2
-rw-r--r--conf/machine/triton.conf2
-rw-r--r--conf/machine/wrap.conf2
-rw-r--r--conf/machine/x86.conf2
-rw-r--r--packages/meta/meta-sdk.bb2
-rw-r--r--packages/meta/meta-toolchain.bb2
64 files changed, 69 insertions, 69 deletions
diff --git a/classes/multimachine.bbclass b/classes/multimachine.bbclass
index d63aeb6d73..4187a00ec3 100644
--- a/classes/multimachine.bbclass
+++ b/classes/multimachine.bbclass
@@ -17,7 +17,7 @@ def multi_machine_after_parse(d):
# We could look for != PACKAGE_ARCH here but how to choose
# if multiple differences are present?
- # Look through IPKG_ARCHS for the priority order?
+ # Look through PACKAGE_ARCHS for the priority order?
if pkgarch and pkgarch == macharch:
multiarch = macharch
diff --git a/classes/package_ipk.bbclass b/classes/package_ipk.bbclass
index 47cff1d27c..02bac7d62b 100644
--- a/classes/package_ipk.bbclass
+++ b/classes/package_ipk.bbclass
@@ -30,9 +30,9 @@ python package_ipk_install () {
# Generate ipk.conf if it or the stamp doesnt exist
conffile = os.path.join(stagingdir,"ipkg.conf")
if not os.access(conffile, os.R_OK):
- ipkg_archs = bb.data.getVar('IPKG_ARCHS',d)
+ ipkg_archs = bb.data.getVar('PACKAGE_ARCHS',d)
if ipkg_archs is None:
- bb.error("IPKG_ARCHS missing")
+ bb.error("PACKAGE_ARCHS missing")
raise FuncFailed
ipkg_archs = ipkg_archs.split()
arch_priority = 1
diff --git a/classes/packaged-staging.bbclass b/classes/packaged-staging.bbclass
index 9aba940da4..4b4ebb58bf 100644
--- a/classes/packaged-staging.bbclass
+++ b/classes/packaged-staging.bbclass
@@ -113,7 +113,7 @@ do_stage_prepend() {
rm ${DEPLOY_DIR_PSTAGE}/ipkg.conf
fi
- ipkgarchs="${BUILD_ARCH} all any noarch ${TARGET_ARCH} ${IPKG_ARCHS} ${IPKG_EXTRA_ARCHS} ${MACHINE}"
+ ipkgarchs="${BUILD_ARCH} all any noarch ${TARGET_ARCH} ${PACKAGE_ARCHS} ${PACKAGE_EXTRA_ARCHS} ${MACHINE}"
priority=1
for arch in $ipkgarchs; do
echo "arch $arch $priority" >> ${DEPLOY_DIR_PSTAGE}/ipkg.conf
diff --git a/classes/rootfs_ipk.bbclass b/classes/rootfs_ipk.bbclass
index c4b2991874..8020fd0ca3 100644
--- a/classes/rootfs_ipk.bbclass
+++ b/classes/rootfs_ipk.bbclass
@@ -42,7 +42,7 @@ real_do_rootfs () {
fi
mkdir -p ${T}
echo "src oe file:${DEPLOY_DIR_IPK}" > ${T}/ipkg.conf
- ipkgarchs="${IPKG_ARCHS}"
+ ipkgarchs="${PACKAGE_ARCHS}"
priority=1
for arch in $ipkgarchs; do
echo "arch $arch $priority" >> ${T}/ipkg.conf
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index 7da0a9a28d..b2d7e2b875 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -57,7 +57,7 @@ TARGET_CC_ARCH = ""
PACKAGE_ARCH = "${HOST_ARCH}"
MACHINE_ARCH = "${@[bb.data.getVar('HOST_ARCH', d, 1), bb.data.getVar('MACHINE', d, 1)][bool(bb.data.getVar('MACHINE', d, 1))]}"
-IPKG_ARCHS = "all any noarch ${TARGET_ARCH} ${IPKG_EXTRA_ARCHS} ${MACHINE}"
+PACKAGE_ARCHS = "all any noarch ${TARGET_ARCH} ${PACKAGE_EXTRA_ARCHS} ${MACHINE}"
##################################################################
# Date/time variables.
diff --git a/conf/distro/openmn.conf b/conf/distro/openmn.conf
index 8118acb1da..9de6c7d9e1 100644
--- a/conf/distro/openmn.conf
+++ b/conf/distro/openmn.conf
@@ -12,7 +12,7 @@ TARGET_OS = "linux"
INHERIT += "package_ipk"
INHERIT += "debian"
-IPKG_EXTRA_ARCHS = "armv5te openmn"
+PACKAGE_EXTRA_ARCHS = "armv5te openmn"
FEED_URIS = "mnci54##http://www.mn-solutions.de/feed/mnci54/base"
diff --git a/conf/distro/unslung.conf b/conf/distro/unslung.conf
index 541eaef852..892c589389 100644
--- a/conf/distro/unslung.conf
+++ b/conf/distro/unslung.conf
@@ -26,7 +26,7 @@ THUMB_INTERWORK = "no"
# to armeb - this makes this stuff independent of changes in machine/nslu2.conf
TARGET_ARCH = "armeb"
PACKAGE_ARCH = "${TARGET_ARCH}"
-# IPKG_EXTRA_ARCHS has the full list of supported architectures (from nslu2.conf)
+# PACKAGE_EXTRA_ARCHS has the full list of supported architectures (from nslu2.conf)
# match the optimisation settings to that which has traditionally been used
# in unslung
diff --git a/conf/documentation.conf b/conf/documentation.conf
index 9996b27d48..62622ea255 100644
--- a/conf/documentation.conf
+++ b/conf/documentation.conf
@@ -38,8 +38,8 @@ PACKAGE_ARCH[doc] = 'The architecture needed for using a resulting package. If y
machine dependant configuration options in your bitbake file add a \
PACKAGE_ARCH = "${MACHINE_ARCH}" to the file.'
-IPKG_ARCHS[doc] = 'A list of architectures compatible with the given target in order of priority'
-IPKG_EXTRA_ARCHS[doc] = 'Set this variable to add extra architectures to the list of supported architectures'
+PACKAGE_ARCHS[doc] = 'A list of architectures compatible with the given target in order of priority'
+PACKAGE_EXTRA_ARCHS[doc] = 'Set this variable to add extra architectures to the list of supported architectures'
DATE[doc] = "The date the build was started Ymd"
TIME[doc] = "The time the build was started HMS"
diff --git a/conf/machine/a780.conf b/conf/machine/a780.conf
index 6b6e5a8ea9..a62fafbc39 100644
--- a/conf/machine/a780.conf
+++ b/conf/machine/a780.conf
@@ -5,7 +5,7 @@
require conf/machine/include/motorola-ezx.conf
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
diff --git a/conf/machine/akita.conf b/conf/machine/akita.conf
index e14efa76a0..27695be4bb 100644
--- a/conf/machine/akita.conf
+++ b/conf/machine/akita.conf
@@ -5,7 +5,7 @@
include conf/machine/include/zaurus-clamshell.conf
include conf/machine/include/zaurus-2.6.conf
-IPKG_EXTRA_ARCHS += "iwmmxt"
+PACKAGE_EXTRA_ARCHS += "iwmmxt"
IMAGE_FSTYPES ?= "jffs2"
ROOT_FLASH_SIZE = "58"
diff --git a/conf/machine/blueangel.conf b/conf/machine/blueangel.conf
index 979c002d11..dd079c244b 100644
--- a/conf/machine/blueangel.conf
+++ b/conf/machine/blueangel.conf
@@ -7,7 +7,7 @@ KERNEL ?= "kernel26"
OVERRIDES =. "${KERNEL}:"
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel_kernel26 = "xanadux-ba-2.6"
PREFERRED_PROVIDER_virtual/kernel = "xanadux-ba-2.6"
diff --git a/conf/machine/colinux.conf b/conf/machine/colinux.conf
index 556944ef8e..31e55e924f 100644
--- a/conf/machine/colinux.conf
+++ b/conf/machine/colinux.conf
@@ -3,6 +3,6 @@
#@DESCRIPTION: Machine configuration for Cooperative Linux running on an x86 compatible PC
TARGET_ARCH = "i686"
-IPKG_EXTRA_ARCHS = "i386 x86"
+PACKAGE_EXTRA_ARCHS = "i386 x86"
PREFERRED_PROVIDER_virtual/kernel = "linux-colinux"
BOOTSTRAP_EXTRA_RDEPENDS = "kernel kernel-modules"
diff --git a/conf/machine/compulab-pxa270.conf b/conf/machine/compulab-pxa270.conf
index 38bc900050..b49bf48d07 100644
--- a/conf/machine/compulab-pxa270.conf
+++ b/conf/machine/compulab-pxa270.conf
@@ -7,7 +7,7 @@ PREFERRED_VERSION_logicpd-pxa270 = "2.6.17"
GUI_MACHINE_CLASS = "bigscreen"
PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
include conf/machine/include/tune-xscale.conf
diff --git a/conf/machine/db1200.conf b/conf/machine/db1200.conf
index d46636cccf..efa45f6a2a 100644
--- a/conf/machine/db1200.conf
+++ b/conf/machine/db1200.conf
@@ -1,7 +1,7 @@
# Alchemy db1200
TARGET_ARCH = "mipsel"
-IPKG_ARCHS = "${TARGET_ARCH} ${MACHINE}"
+PACKAGE_ARCHS = "${TARGET_ARCH} ${MACHINE}"
PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
diff --git a/conf/machine/devkitidp-pxa255.conf b/conf/machine/devkitidp-pxa255.conf
index 6bc632dbdd..7d19d02439 100644
--- a/conf/machine/devkitidp-pxa255.conf
+++ b/conf/machine/devkitidp-pxa255.conf
@@ -5,7 +5,7 @@
TARGET_ARCH = "arm"
GUI_MACHINE_CLASS = "bigscreen"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
PREFERRED_PROVIDER_virtual/bootloader = "uboot-${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
diff --git a/conf/machine/dht-walnut.conf b/conf/machine/dht-walnut.conf
index 68b754f2d3..eae1a3433d 100644
--- a/conf/machine/dht-walnut.conf
+++ b/conf/machine/dht-walnut.conf
@@ -1,5 +1,5 @@
TARGET_ARCH = "powerpc"
-IPKG_ARCHS = "all powerpc ${MACHINE}"
+PACKAGE_ARCHS = "all powerpc ${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "linux-dht-walnut"
diff --git a/conf/machine/efika.conf b/conf/machine/efika.conf
index 2faf6ebed9..33fac1ae6a 100644
--- a/conf/machine/efika.conf
+++ b/conf/machine/efika.conf
@@ -4,7 +4,7 @@
TARGET_ARCH = "powerpc"
-IPKG_EXTRA_ARCHS = "ppc"
+PACKAGE_EXTRA_ARCHS = "ppc"
PREFERRED_PROVIDER_virtual/kernel = "linux-${MACHINE}"
diff --git a/conf/machine/ep93xx.conf b/conf/machine/ep93xx.conf
index 82905dd089..67efb585c1 100644
--- a/conf/machine/ep93xx.conf
+++ b/conf/machine/ep93xx.conf
@@ -4,7 +4,7 @@
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4t"
+PACKAGE_EXTRA_ARCHS = "armv4t"
PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
diff --git a/conf/machine/epia.conf b/conf/machine/epia.conf
index e82da27574..08f12a0ac6 100644
--- a/conf/machine/epia.conf
+++ b/conf/machine/epia.conf
@@ -7,7 +7,7 @@ udevdir = "/dev"
OLDEST_KERNEL = "2.6.5"
GLIBC_ADDONS = "nptl"
GLIBC_EXTRA_OECONF = "--with-tls"
-IPKG_EXTRA_ARCHS = "i386"
+PACKAGE_EXTRA_ARCHS = "i386"
include conf/machine/include/tune-c3.conf
diff --git a/conf/machine/guinness.conf b/conf/machine/guinness.conf
index 4890f3cecd..bcbd6e8023 100644
--- a/conf/machine/guinness.conf
+++ b/conf/machine/guinness.conf
@@ -5,7 +5,7 @@
# i386 doesn't work with NTPL, see http://ecos.sourceware.org/ml/libc-ports/2006-03/msg00030.html
TARGET_ARCH = "i686"
-IPKG_EXTRA_ARCHS = "x86 i386 i486 i586"
+PACKAGE_EXTRA_ARCHS = "x86 i386 i486 i586"
PREFERRED_PROVIDER_virtual/kernel = "linux-x86"
# todo: convert to task-base
diff --git a/conf/machine/h1910.conf b/conf/machine/h1910.conf
index a2c4a9c10e..c8b2fad2fd 100644
--- a/conf/machine/h1910.conf
+++ b/conf/machine/h1910.conf
@@ -6,7 +6,7 @@
# Hardware-based properties
#
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
require conf/machine/include/tune-xscale.conf
diff --git a/conf/machine/h1940.conf b/conf/machine/h1940.conf
index 1ea4a68639..08104624ca 100644
--- a/conf/machine/h1940.conf
+++ b/conf/machine/h1940.conf
@@ -2,7 +2,7 @@
#@NAME: h1940
#@DESCRIPTION: Machine configuration for the HP iPAQ h1930 and h1940
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
TARGET_ARCH = "arm"
PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "linux-h1940"
diff --git a/conf/machine/h2200.conf b/conf/machine/h2200.conf
index 8a6cee312c..91c733b191 100644
--- a/conf/machine/h2200.conf
+++ b/conf/machine/h2200.conf
@@ -6,7 +6,7 @@
# Hardware-based properties
#
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
#Compile with armv5te optimizations, incompatible with armv4(t) cpus
require conf/machine/include/tune-xscale.conf
diff --git a/conf/machine/h3600.conf b/conf/machine/h3600.conf
index 14a9bb6ba5..104d518ad3 100644
--- a/conf/machine/h3600.conf
+++ b/conf/machine/h3600.conf
@@ -6,7 +6,7 @@
# Hardware-based properties
#
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "ipaqsa"
+PACKAGE_EXTRA_ARCHS = "ipaqsa"
require conf/machine/include/tune-strongarm.conf
diff --git a/conf/machine/h3900.conf b/conf/machine/h3900.conf
index 61024584b5..f00dc9eb96 100644
--- a/conf/machine/h3900.conf
+++ b/conf/machine/h3900.conf
@@ -10,7 +10,7 @@ INHERIT += "linux-kernel-base"
OVERRIDES =. "${KERNEL}:"
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel_kernel24 = "handhelds-pxa"
PREFERRED_PROVIDER_virtual/kernel_kernel26 = "linux-handhelds-2.6"
diff --git a/conf/machine/h4000.conf b/conf/machine/h4000.conf
index f2ecbc5883..4eef599aaf 100644
--- a/conf/machine/h4000.conf
+++ b/conf/machine/h4000.conf
@@ -6,7 +6,7 @@
# Hardware-based properties
#
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
require conf/machine/include/tune-xscale.conf
diff --git a/conf/machine/h5xxx.conf b/conf/machine/h5xxx.conf
index 941d08c013..5aac579e91 100644
--- a/conf/machine/h5xxx.conf
+++ b/conf/machine/h5xxx.conf
@@ -6,7 +6,7 @@
# Hardware-based properties
#
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ipaqpxa"
require conf/machine/include/tune-xscale.conf
diff --git a/conf/machine/h6300.conf b/conf/machine/h6300.conf
index 8cce5f61b9..f793b49c70 100644
--- a/conf/machine/h6300.conf
+++ b/conf/machine/h6300.conf
@@ -7,7 +7,7 @@
#
TARGET_ARCH = "arm"
PACKAGE_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "arm armv4 armv4t"
+PACKAGE_EXTRA_ARCHS = "arm armv4 armv4t"
#Use OMAP 1510 cpu specifig arm9tdmi options for gcc
require conf/machine/include/tune-arm9tdmi.conf
diff --git a/conf/machine/htcuniversal.conf b/conf/machine/htcuniversal.conf
index 4366cb16df..efb92518a5 100644
--- a/conf/machine/htcuniversal.conf
+++ b/conf/machine/htcuniversal.conf
@@ -6,7 +6,7 @@
# Hardware-based properties
#
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "ipaqpxa armv4t armv5te iwmmxt"
+PACKAGE_EXTRA_ARCHS = "ipaqpxa armv4t armv5te iwmmxt"
# Use tune-xscale per default. Machine independent feeds should be built with tune-strongarm.
require conf/machine/include/tune-xscale.conf
diff --git a/conf/machine/hx2000.conf b/conf/machine/hx2000.conf
index da2e466425..25f093e1b8 100644
--- a/conf/machine/hx2000.conf
+++ b/conf/machine/hx2000.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the hx2000 iPAQs with a pxa27x CPU
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
PREFERRED_PROVIDER_virtual/kernel = "linux-openzaurus"
diff --git a/conf/machine/hx4700.conf b/conf/machine/hx4700.conf
index d43d16fb46..3a94220968 100644
--- a/conf/machine/hx4700.conf
+++ b/conf/machine/hx4700.conf
@@ -6,7 +6,7 @@
# Hardware-based properties
#
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
# Use tune-xscale per default. Machine independent feeds should be built with tune-strongarm.
require conf/machine/include/tune-xscale.conf
diff --git a/conf/machine/include/ixp4xx.conf b/conf/machine/include/ixp4xx.conf
index 541d350f21..190ebe1c8c 100644
--- a/conf/machine/include/ixp4xx.conf
+++ b/conf/machine/include/ixp4xx.conf
@@ -111,7 +111,7 @@ TARGET_PACKAGE_ARCH = "${TARGET_PACKAGE_ARCH_BASE}${BYTE_SEX_CHAR}"
# because everything built here is no more specific than that.
MACHINE_ARCH = "ixp4xx${ARCH_BYTE_SEX}"
-# IPKG_EXTRA_ARCHS
+# PACKAGE_EXTRA_ARCHS
# The full list of package architectures which should run on the system.
# This takes into account both the board level issues and the INPUTS set
# by the distro. The arm list is derived from the architecture settings
@@ -126,12 +126,12 @@ THUMB_ARCHITECTURES = "thumbe${BYTE_SEX_CHAR} thumbv4t${BYTE_SEX_CHAR} thumbv5t$
# NOTE: this list contains just the things which rootfs_ipk.bbclass does
# not add, rootfs_ipk.bbclass evaluates:
#
-# ipkgarchs="all any noarch ${TARGET_ARCH} ${IPKG_EXTRA_ARCHS} ${MACHINE}"
+# ipkgarchs="all any noarch ${TARGET_ARCH} ${PACKAGE_EXTRA_ARCHS} ${MACHINE}"
#
# This is a priority ordered list - most desireable architecture at the end,
# so put <ARM_INSTRUCTION_SET>_ARCHITECTURES at the end and, if
# THUMB_INTERWORK precede this with the other architectures.
-IPKG_EXTRA_ARCHS = "ixp4xx ${MACHINE} \
+PACKAGE_EXTRA_ARCHS = "ixp4xx ${MACHINE} \
${@(lambda arch_thumb, arch_arm, is_arm, interwork: \
(interwork and (is_arm and arch_thumb or arch_arm) + ' ' or '') \
+ '${TARGET_ARCH} ' + (is_arm and arch_arm or arch_thumb)) \
@@ -146,7 +146,7 @@ IPKG_EXTRA_ARCHS = "ixp4xx ${MACHINE} \
# the removal of the raw "${MACHINE}" from the end of the list. ${MACHINE} and
# ixp4xx are included at the start (lower priority) as the non-byte-sex specific
# versions.
-IPKG_ARCH_LIST = "all any noarch ixp4xx ${MACHINE} ${IPKG_EXTRA_ARCHS}"
+IPKG_ARCH_LIST = "all any noarch ixp4xx ${MACHINE} ${PACKAGE_EXTRA_ARCHS}"
#-------------------------------------------------------------------------------
# Board defaults
diff --git a/conf/machine/include/tune-iwmmxt.conf b/conf/machine/include/tune-iwmmxt.conf
index 990aee54bc..8376faca74 100644
--- a/conf/machine/include/tune-iwmmxt.conf
+++ b/conf/machine/include/tune-iwmmxt.conf
@@ -1,6 +1,6 @@
# Configurations for the Intel PXA27x Appications Processor Family.
# Please use tune-xscale for PXA255/PXA26x based processors.
-IPKG_EXTRA_ARCHS += "iwmmxt"
TARGET_CC_ARCH = "-march=iwmmxt -mcpu=iwmmxt -mtune=iwmmxt"
PACKAGE_ARCH = "iwmmxt"
+PACKAGE_EXTRA_ARCHS += "iwmmxt"
diff --git a/conf/machine/include/zaurus-clamshell.conf b/conf/machine/include/zaurus-clamshell.conf
index e600a4926d..3c02f7bfd9 100644
--- a/conf/machine/include/zaurus-clamshell.conf
+++ b/conf/machine/include/zaurus-clamshell.conf
@@ -1,5 +1,5 @@
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
diff --git a/conf/machine/ipaq-pxa270.conf b/conf/machine/ipaq-pxa270.conf
index b3db5c8268..afc1318f40 100644
--- a/conf/machine/ipaq-pxa270.conf
+++ b/conf/machine/ipaq-pxa270.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the iPAQ with a pxa27x CPU devices
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa hx4700"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa hx4700"
#use this for a hx47xx ipaq
PREFERRED_PROVIDER_virtual/kernel = "linux-handhelds-2.6"
diff --git a/conf/machine/ixp4xx.conf b/conf/machine/ixp4xx.conf
index c3e56067cd..dc174b8e35 100644
--- a/conf/machine/ixp4xx.conf
+++ b/conf/machine/ixp4xx.conf
@@ -6,4 +6,4 @@ MACHINE_FEATURES = "kernel26 usbhost ext2"
include conf/machine/include/ixp4xx.conf
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ixp4xx${ARCH_BYTE_SEX}"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te ixp4xx${ARCH_BYTE_SEX}"
diff --git a/conf/machine/lite5200.conf b/conf/machine/lite5200.conf
index cd943f7e65..3cbc44485d 100644
--- a/conf/machine/lite5200.conf
+++ b/conf/machine/lite5200.conf
@@ -1,5 +1,5 @@
TARGET_ARCH = "powerpc"
-IPKG_EXTRA_ARCHS = "ppc"
+PACKAGE_EXTRA_ARCHS = "ppc"
UBOOT_MACHINE = "Lite5200"
SERIAL_CONSOLE="38400 ttyS0"
diff --git a/conf/machine/logicpd-pxa270.conf b/conf/machine/logicpd-pxa270.conf
index efb19aea93..dc41e7c2fd 100644
--- a/conf/machine/logicpd-pxa270.conf
+++ b/conf/machine/logicpd-pxa270.conf
@@ -7,7 +7,7 @@ PREFERRED_VERSION_logicpd-pxa270 = "2.6.17-rc5"
GUI_MACHINE_CLASS = "smallscreen"
PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
include conf/machine/include/tune-xscale.conf
diff --git a/conf/machine/magician.conf b/conf/machine/magician.conf
index d2cc9b1f49..e5138be1c8 100644
--- a/conf/machine/magician.conf
+++ b/conf/machine/magician.conf
@@ -6,7 +6,7 @@
# Hardware-based properties
#
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te iwmmxt ipaqpxa ipaq-pxa270"
# Use tune-xscale per default. Machine independent feeds should be built with tune-strongarm.
require conf/machine/include/tune-xscale.conf
diff --git a/conf/machine/mainstone.conf b/conf/machine/mainstone.conf
index 72a305df38..914022c7bc 100644
--- a/conf/machine/mainstone.conf
+++ b/conf/machine/mainstone.conf
@@ -5,7 +5,7 @@
TARGET_ARCH = "arm"
GUI_MACHINE_CLASS = "smallscreen"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
diff --git a/conf/machine/mtx-1.conf b/conf/machine/mtx-1.conf
index 73500b501d..33a69f45b3 100644
--- a/conf/machine/mtx-1.conf
+++ b/conf/machine/mtx-1.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the mtx-1 (aka MeshCube)
TARGET_ARCH = "mipsel"
-IPKG_ARCHS = "all mipsel ${MACHINE}"
+PACKAGE_ARCHS = "all mipsel ${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-1"
diff --git a/conf/machine/mtx-2.conf b/conf/machine/mtx-2.conf
index d3e15afc9e..438c1fed79 100644
--- a/conf/machine/mtx-2.conf
+++ b/conf/machine/mtx-2.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the mtx-2 (aka SurfBox 2nd generation)
TARGET_ARCH = "mipsel"
-IPKG_ARCHS = "all mipsel ${MACHINE}"
+PACKAGE_ARCHS = "all mipsel ${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-2"
diff --git a/conf/machine/mtx-3.conf b/conf/machine/mtx-3.conf
index bdd39ab57f..dd848ea021 100644
--- a/conf/machine/mtx-3.conf
+++ b/conf/machine/mtx-3.conf
@@ -9,7 +9,7 @@
# For compiling the kernel, ARCH will be derived form it by kernel-arch.bbclass
TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm ${MACHINE}"
+PACKAGE_ARCHS = "all arm ${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-3"
diff --git a/conf/machine/mx31ads.conf b/conf/machine/mx31ads.conf
index 4b3fff7061..33456a4b03 100644
--- a/conf/machine/mx31ads.conf
+++ b/conf/machine/mx31ads.conf
@@ -8,7 +8,7 @@ TARGET_FPU_arm = "hard"
MACHINE_FEATURES = "kernel26 apm alsa ext2 pcmcia usbhost usbgadget"
GUI_MACHINE_CLASS = "smallscreen"
-IPKG_EXTRA_ARCHS = "arm armv4t armv5te armv6"
+PACKAGE_EXTRA_ARCHS = "arm armv4t armv5te armv6"
PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
diff --git a/conf/machine/navman-icn330.conf b/conf/machine/navman-icn330.conf
index 79bafd1230..c5fbdf2e97 100644
--- a/conf/machine/navman-icn330.conf
+++ b/conf/machine/navman-icn330.conf
@@ -8,7 +8,7 @@
# Hardware-based properties
#
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5e armv5te"
#Compile with armv5te optimizations, incompatible with armv4(t) cpus
require conf/machine/include/tune-xscale.conf
diff --git a/conf/machine/netbook-pro.conf b/conf/machine/netbook-pro.conf
index 095cd95d31..1048cb1d6c 100755
--- a/conf/machine/netbook-pro.conf
+++ b/conf/machine/netbook-pro.conf
@@ -5,7 +5,7 @@
INHERIT += "linux-kernel-base"
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "arm armv4 armv4t armv5te"
+PACKAGE_EXTRA_ARCHS = "arm armv4 armv4t armv5te"
PREFERRED_PROVIDER_virtual/kernel = "${MACHINE}-kernel"
diff --git a/conf/machine/nokia770.conf b/conf/machine/nokia770.conf
index aa57bb4563..6bde574d02 100644
--- a/conf/machine/nokia770.conf
+++ b/conf/machine/nokia770.conf
@@ -2,7 +2,7 @@
#@NAME: Nokia 770 internet tablet
#@DESCRIPTION: Machine configuration for the Nokia 770, an omap 1710 based tablet
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv4t armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te"
PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-omap"
PREFERRED_PROVIDER_virtual/bootloader = ""
diff --git a/conf/machine/omap1510inn.conf b/conf/machine/omap1510inn.conf
index bd367d43a0..51d5b12f9d 100644
--- a/conf/machine/omap1510inn.conf
+++ b/conf/machine/omap1510inn.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
diff --git a/conf/machine/omap1610h2.conf b/conf/machine/omap1610h2.conf
index bd367d43a0..51d5b12f9d 100644
--- a/conf/machine/omap1610h2.conf
+++ b/conf/machine/omap1610h2.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
diff --git a/conf/machine/omap1710h3.conf b/conf/machine/omap1710h3.conf
index bd367d43a0..51d5b12f9d 100644
--- a/conf/machine/omap1710h3.conf
+++ b/conf/machine/omap1710h3.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
diff --git a/conf/machine/omap2420h4.conf b/conf/machine/omap2420h4.conf
index 514069264e..70a3082956 100644
--- a/conf/machine/omap2420h4.conf
+++ b/conf/machine/omap2420h4.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the OMAP H2 development board with a 1610 processor
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te armv6te"
+PACKAGE_EXTRA_ARCHS = "armv5te armv6te"
PREFERRED_PROVIDER_xserver = "xserver-kdrive"
PREFERRED_PROVIDER_virtual/kernel = "linux-omap-2.6"
diff --git a/conf/machine/omap5912osk.conf b/conf/machine/omap5912osk.conf
index c6bb20948a..f8a3472f78 100644
--- a/conf/machine/omap5912osk.conf
+++ b/conf/machine/omap5912osk.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the OMAP Starter Kit with a 5912 processor
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
HOTPLUG = "udev"
diff --git a/conf/machine/palmld.conf b/conf/machine/palmld.conf
index 35a31aa00b..ef8f4ca57b 100644
--- a/conf/machine/palmld.conf
+++ b/conf/machine/palmld.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the Palm LifeDrive
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "arm armv4t armv5te"
+PACKAGE_EXTRA_ARCHS = "arm armv4t armv5te"
PREFERRED_PROVIDER_virtual/kernel = "hackndev-2.6trunk"
diff --git a/conf/machine/poodle.conf b/conf/machine/poodle.conf
index fc8fb718f2..c904372535 100644
--- a/conf/machine/poodle.conf
+++ b/conf/machine/poodle.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the PXA250 based Sharp Zaurus SL-B500 and SHarp Zaurus SL-5600 devices
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
MACHINE_KERNEL_VERSION ?= "2.4"
include conf/machine/include/poodle-${MACHINE_KERNEL_VERSION}.conf
diff --git a/conf/machine/qemuarm.conf b/conf/machine/qemuarm.conf
index c32353f01e..d67acac50f 100644
--- a/conf/machine/qemuarm.conf
+++ b/conf/machine/qemuarm.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for running an ARM system under qemu emulation
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
require conf/machine/include/qemu.conf
require conf/machine/include/tune-arm926ejs.conf
diff --git a/conf/machine/rb500.conf b/conf/machine/rb500.conf
index aec2a8f726..ab669aee49 100644
--- a/conf/machine/rb500.conf
+++ b/conf/machine/rb500.conf
@@ -4,5 +4,5 @@
TARGET_ARCH = "mipsel"
TARGET_CC_ARCH = "-Os -mips2"
-IPKG_ARCHS = "all mipsel ${MACHINE}"
+PACKAGE_ARCHS = "all mipsel ${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "linux-rb500"
diff --git a/conf/machine/smdk2440.conf b/conf/machine/smdk2440.conf
index 04694cd3d3..c054cf6195 100644
--- a/conf/machine/smdk2440.conf
+++ b/conf/machine/smdk2440.conf
@@ -4,7 +4,7 @@
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4t"
+PACKAGE_EXTRA_ARCHS = "armv4t"
PREFERRED_PROVIDER_virtual/kernel = "linux-smdk2440"
diff --git a/conf/machine/spitz.conf b/conf/machine/spitz.conf
index 5434efbaf6..2c4e10935e 100644
--- a/conf/machine/spitz.conf
+++ b/conf/machine/spitz.conf
@@ -7,7 +7,7 @@ include conf/machine/include/zaurus-2.6.conf
PIVOTBOOT_EXTRA_RDEPENDS += "pivotinit ${PCMCIA_MANAGER}"
-IPKG_EXTRA_ARCHS += "iwmmxt"
+PACKAGE_EXTRA_ARCHS += "iwmmxt"
IMAGE_FSTYPES ?= "tar.gz"
ROOT_FLASH_SIZE = "100"
diff --git a/conf/machine/tosa.conf b/conf/machine/tosa.conf
index e7f2aa204a..1d7b04e24e 100644
--- a/conf/machine/tosa.conf
+++ b/conf/machine/tosa.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the PXA255 based Sharp Zaurus SL-6000 device
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv4 armv5te"
+PACKAGE_EXTRA_ARCHS = "armv4 armv5te"
MACHINE_KERNEL_VERSION ?= "2.6"
include conf/machine/include/tosa-${MACHINE_KERNEL_VERSION}.conf
diff --git a/conf/machine/triton.conf b/conf/machine/triton.conf
index 671def34c3..685dcd91fb 100644
--- a/conf/machine/triton.conf
+++ b/conf/machine/triton.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the XScale based triton boards from KaRo Electronics
TARGET_ARCH = "arm"
-IPKG_EXTRA_ARCHS = "armv5te"
+PACKAGE_EXTRA_ARCHS = "armv5te"
PREFERRED_PROVIDER_virtual/kernel = "triton-kernel"
BOOTSTRAP_EXTRA_RDEPENDS = "virtual/kernel"
diff --git a/conf/machine/wrap.conf b/conf/machine/wrap.conf
index 1073259e7a..592be8dd3c 100644
--- a/conf/machine/wrap.conf
+++ b/conf/machine/wrap.conf
@@ -3,7 +3,7 @@
#@DESCRIPTION: Machine configuration for the PC Engines WRAP (Wireless Router Application Platform) boards.
TARGET_ARCH = "i486"
-IPKG_EXTRA_ARCHS = "i386"
+PACKAGE_EXTRA_ARCHS = "i386"
PREFERRED_PROVIDER_virtual/kernel = "linux-wrap-geode"
PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}depmod:module-init-tools-cross"
diff --git a/conf/machine/x86.conf b/conf/machine/x86.conf
index 0953f6d041..b2147f2c0d 100644
--- a/conf/machine/x86.conf
+++ b/conf/machine/x86.conf
@@ -5,7 +5,7 @@
# i386 doesn't work with NTPL, see http://ecos.sourceware.org/ml/libc-ports/2006-03/msg00030.html
TARGET_ARCH = "i486"
# TARGET_VENDOR = "-oe"
-IPKG_EXTRA_ARCHS = "x86"
+PACKAGE_EXTRA_ARCHS = "x86"
PREFERRED_PROVIDER_virtual/kernel = "linux-x86"
# todo: convert to task-base
BOOTSTRAP_EXTRA_RDEPENDS = "kernel pciutils udev kernel-modules"
diff --git a/packages/meta/meta-sdk.bb b/packages/meta/meta-sdk.bb
index 0714e506b7..35ea8630c9 100644
--- a/packages/meta/meta-sdk.bb
+++ b/packages/meta/meta-sdk.bb
@@ -42,7 +42,7 @@ EOF
cat <<EOF >${SDK_DIR}/ipkg-target.conf
src oe file:${DEPLOY_DIR_IPK}
EOF
- ipkgarchs="${IPKG_ARCHS}"
+ ipkgarchs="${PACKAGE_ARCHS}"
priority=1
for arch in $ipkgarchs; do
echo "arch $arch $priority" >> ${SDK_DIR}/ipkg-target.conf
diff --git a/packages/meta/meta-toolchain.bb b/packages/meta/meta-toolchain.bb
index 45ce8520df..f3a0332ac7 100644
--- a/packages/meta/meta-toolchain.bb
+++ b/packages/meta/meta-toolchain.bb
@@ -39,7 +39,7 @@ EOF
cat <<EOF >${SDK_DIR}/ipkg-target.conf
src oe file:${DEPLOY_DIR_IPK}
EOF
- ipkgarchs="${IPKG_ARCHS}"
+ ipkgarchs="${PACKAGE_ARCHS}"
priority=1
for arch in $ipkgarchs; do
echo "arch $arch $priority" >> ${SDK_DIR}/ipkg-target.conf