aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-07-26 21:51:38 +0000
committerRichard Purdie <rpurdie@rpsys.net>2006-07-26 21:51:38 +0000
commit5774b8e796732a7c475efa1b91f0a25c1416cf7e (patch)
treec43af1973192ca1ff04186bebee6d45d21a133bc
parentdb328d243fcdb3cca30000df0b798f06ba6b43ac (diff)
downloadopenembedded-5774b8e796732a7c475efa1b91f0a25c1416cf7e.tar.gz
udev 092: Fix ARM inotify syscall
-rw-r--r--packages/udev/udev-092/arm_inotify_fix.patch17
-rw-r--r--packages/udev/udev_092.bb3
2 files changed, 19 insertions, 1 deletions
diff --git a/packages/udev/udev-092/arm_inotify_fix.patch b/packages/udev/udev-092/arm_inotify_fix.patch
new file mode 100644
index 0000000000..4bd0d4d9b9
--- /dev/null
+++ b/packages/udev/udev-092/arm_inotify_fix.patch
@@ -0,0 +1,17 @@
+Index: udev-092/udev_libc_wrapper.h
+===================================================================
+--- udev-092.orig/udev_libc_wrapper.h 2006-07-26 21:55:06.000000000 +0100
++++ udev-092/udev_libc_wrapper.h 2006-07-26 21:55:37.000000000 +0100
+@@ -58,9 +58,9 @@
+ # define __NR_inotify_add_watch 152
+ # define __NR_inotify_rm_watch 156
+ #elif defined (__arm__)
+-# define __NR_inotify_init 316
+-# define __NR_inotify_add_watch 317
+-# define __NR_inotify_rm_watch 318
++# define __NR_inotify_init __NR_SYSCALL_BASE+316
++# define __NR_inotify_add_watch __NR_SYSCALL_BASE+317
++# define __NR_inotify_rm_watch __NR_SYSCALL_BASE+318
+ #elif defined (__sh__)
+ # define __NR_inotify_init 290
+ # define __NR_inotify_add_watch 291
diff --git a/packages/udev/udev_092.bb b/packages/udev/udev_092.bb
index f25eeb0946..081269404e 100644
--- a/packages/udev/udev_092.bb
+++ b/packages/udev/udev_092.bb
@@ -3,13 +3,14 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
RPROVIDES = "hotplug"
-PR = "r5"
+PR = "r6"
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
file://flags.patch;patch=1 \
file://udevsynthesize.patch;patch=1 \
file://udevsynthesize.sh \
+ file://arm_inotify_fix.patch;patch=1 \
file://mount.blacklist"
include udev.inc