aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-06-21 04:11:10 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-06-21 04:11:10 +0000
commit63a46ebd4748ea1b0c925427a3d08ce7a6d82679 (patch)
tree6b35df5489bcfb6ac129af6b96fe2e3cf8e9558b
parent298840ee2cef7e2c2eaa1fc614579dceb2688454 (diff)
downloadopenembedded-63a46ebd4748ea1b0c925427a3d08ce7a6d82679.tar.gz
python-2.4.4: update manifest, update manifest generator, close #2487
-rwxr-xr-xcontrib/python/generate-manifest.py20
-rw-r--r--packages/python/python-2.4.4-manifest.inc45
-rw-r--r--packages/python/python_2.4.4.bb4
3 files changed, 40 insertions, 29 deletions
diff --git a/contrib/python/generate-manifest.py b/contrib/python/generate-manifest.py
index ec65d221c3..1c0a024db7 100755
--- a/contrib/python/generate-manifest.py
+++ b/contrib/python/generate-manifest.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python
# generate Python Manifest for the OpenEmbedded build system
-# (C) 2002-2006 Michael Lauer <mickey@Vanille.de>
+# (C) 2002-2007 Michael 'Mickey' Lauer <mickey@Vanille.de>
# MIT license
import os
@@ -158,8 +158,8 @@ if __name__ == "__main__":
m.setPrefix( "/", "/usr/" )
- m.addPackage( 0, "python-core", "Python Interpreter and core modules (needed!)", "",
- "lib/python2.4/__future__.* lib/python2.4/copy.* lib/python2.4/copy_reg.* lib/python2.4/ConfigParser.py " +
+ m.addPackage( 2, "python-core", "Python Interpreter and core modules (needed!)", "",
+ "lib/python2.4/__future__.* lib/python2.4/copy.* lib/python2.4/copy_reg.* lib/python2.4/ConfigParser.* " +
"lib/python2.4/getopt.* lib/python2.4/linecache.* lib/python2.4/new.* " +
"lib/python2.4/os.* lib/python2.4/posixpath.* " +
"lib/python2.4/warnings.* lib/python2.4/site.* lib/python2.4/stat.* " +
@@ -167,6 +167,9 @@ if __name__ == "__main__":
"lib/python2.4/lib-dynload/binascii.so lib/python2.4/lib-dynload/struct.so lib/python2.4/lib-dynload/time.so " +
"lib/python2.4/lib-dynload/xreadlines.so lib/python2.4/types.* bin/python" )
+ m.addPackage( 0, "python-core-debug", "Python core module debug information", "python-core",
+ "lib/python2.4/lib-dynload/.debug" ) # package
+
m.addPackage( 0, "python-devel", "Python Development Package", "python-core",
"include lib/python2.4/config" ) # package
@@ -179,7 +182,7 @@ if __name__ == "__main__":
m.setPrefix( "/lib/python2.4/", "${libdir}/python2.4/" )
m.addPackage( 0, "python-audio", "Python Audio Handling", "python-core",
- "wave.* chunk.* lib-dynload/ossaudiodev.so lib-dynload/audioop.so" )
+ "wave.* chunk.* sndhdr.* lib-dynload/ossaudiodev.so lib-dynload/audioop.so" )
m.addPackage( 0, "python-bsddb", "Python Berkeley Database Bindings", "python-core",
"bsddb" ) # package
@@ -214,7 +217,7 @@ if __name__ == "__main__":
m.addPackage( 0, "python-distutils", "Python Distribution Utilities", "python-core",
"config distutils" ) # package
- m.addPackage( 0, "python-email", "Python Email Support", "python-core, python-io, python-re",
+ m.addPackage( 0, "python-email", "Python Email Support", "python-core, python-io, python-re, python-mime, python-audio python-image",
"email" ) # package
m.addPackage( 0, "python-fcntl", "Python's fcntl Interface", "python-core",
@@ -255,7 +258,7 @@ if __name__ == "__main__":
"lib-dynload/cmath.so lib-dynload/math.so lib-dynload/_random.so random.* sets.*" )
m.addPackage( 0, "python-mime", "Python MIME Handling APIs", "python-core, python-io",
- "mimetools.* quopri.* rfc822.*" )
+ "mimetools.* uu.* quopri.* rfc822.*" )
m.addPackage( 0, "python-mmap", "Python Memory-Mapped-File Support", "python-core, python-io",
"lib-dynload/mmap.so " )
@@ -291,7 +294,10 @@ if __name__ == "__main__":
m.addPackage( 0, "python-shell", "Python Shell-Like Functionality", "python-core, python-re",
"commands.* dircache.* fnmatch.* glob.* popen2.* shutil.*" )
- m.addPackage( 0, "python-subprocess", "Python Subprocess Support", "python-core, python-io, python-re",
+ m.addPackage( 0, "python-robotparser", "Python robots.txt parser", "python-core, python-netclient",
+ "robotparser.*")
+
+ m.addPackage( 0, "python-subprocess", "Python Subprocess Support", "python-core, python-io, python-re, python-fcntl, python-pickle",
"subprocess.*" )
m.addPackage( 0, "python-stringold", "Python String APIs [deprecated]", "python-core, python-re",
diff --git a/packages/python/python-2.4.4-manifest.inc b/packages/python/python-2.4.4-manifest.inc
index 33f5bac2f2..6f86fa56de 100644
--- a/packages/python/python-2.4.4-manifest.inc
+++ b/packages/python/python-2.4.4-manifest.inc
@@ -1,5 +1,5 @@
########################################################################################################################
-### AUTO-GENERATED by '/local/pkg/oe/org.openembedded.dev/contrib/python/generate-manifest.py' [(C) 2002-2007 Michael 'Mickey' Lauer <mickey@Vanille.de>] on Mon Dec 25 00:05:05 2006
+### AUTO-GENERATED by './generate-manifest.py' [(C) 2002-2007 Michael 'Mickey' Lauer <mickey@Vanille.de>] on Thu Jun 21 06:08:34 2007
###
### Visit THE Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
###
@@ -8,18 +8,9 @@
########################################################################################################################
-PROVIDES+="python-profile python-threading python-distutils python-textutils python-codecs python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-resource python-devel python-math python-hotshot python-unixadmin python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-syslog python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-tests python-unittest python-stringold python-lib-old-and-deprecated python-compile python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio python-misc"
+PROVIDES+="python-profile python-threading python-distutils python-textutils python-codecs python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-resource python-devel python-math python-hotshot python-unixadmin python-tkinter python-gdbm python-fcntl python-core-debug python-pprint python-netserver python-curses python-syslog python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-shell python-bsddb python-netclient python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
-PACKAGES="python-profile python-threading python-distutils python-textutils python-codecs python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-resource python-devel python-math python-hotshot python-unixadmin python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-syslog python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-tests python-unittest python-stringold python-lib-old-and-deprecated python-compile python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio python-misc-dbg python-misc"
-
-DESCRIPTION_python-misc-dbg="Misc Python debug files"
-FILES_python-misc-dbg="${libdir}/python2.4/lib-dynload/.debug"
-RDEPENDS_python-misc-dbg="python-core"
-
-DESCRIPTION_python-misc="Misc Python files"
-PR_python-misc="ml1"
-FILES_python-misc="${libdir}/python2.4/"
-RDEPENDS_python-misc="python-core"
+PACKAGES="python-profile python-threading python-distutils python-textutils python-codecs python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-resource python-devel python-math python-hotshot python-unixadmin python-tkinter python-gdbm python-fcntl python-core-debug python-pprint python-netserver python-curses python-syslog python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-shell python-bsddb python-netclient python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
DESCRIPTION_python-profile="Python Basic Profiling Support"
PR_python-profile="ml0"
@@ -57,9 +48,9 @@ RDEPENDS_python-datetime="python-core python-codecs"
FILES_python-datetime="${libdir}/python2.4/_strptime.* ${libdir}/python2.4/calendar.* ${libdir}/python2.4/lib-dynload/datetime.so "
DESCRIPTION_python-core="Python Interpreter and core modules (needed!)"
-PR_python-core="ml0"
+PR_python-core="ml2"
RDEPENDS_python-core=""
-FILES_python-core="/usr/lib/python2.4/__future__.* /usr/lib/python2.4/copy.* /usr/lib/python2.4/copy_reg.* /usr/lib/python2.4/ConfigParser.py /usr/lib/python2.4/getopt.* /usr/lib/python2.4/linecache.* /usr/lib/python2.4/new.* /usr/lib/python2.4/os.* /usr/lib/python2.4/posixpath.* /usr/lib/python2.4/warnings.* /usr/lib/python2.4/site.* /usr/lib/python2.4/stat.* /usr/lib/python2.4/UserDict.* /usr/lib/python2.4/UserList.* /usr/lib/python2.4/UserString.* /usr/lib/python2.4/lib-dynload/binascii.so /usr/lib/python2.4/lib-dynload/struct.so /usr/lib/python2.4/lib-dynload/time.so /usr/lib/python2.4/lib-dynload/xreadlines.so /usr/lib/python2.4/types.* /usr/bin/python "
+FILES_python-core="/usr/lib/python2.4/__future__.* /usr/lib/python2.4/copy.* /usr/lib/python2.4/copy_reg.* /usr/lib/python2.4/ConfigParser.* /usr/lib/python2.4/getopt.* /usr/lib/python2.4/linecache.* /usr/lib/python2.4/new.* /usr/lib/python2.4/os.* /usr/lib/python2.4/posixpath.* /usr/lib/python2.4/warnings.* /usr/lib/python2.4/site.* /usr/lib/python2.4/stat.* /usr/lib/python2.4/UserDict.* /usr/lib/python2.4/UserList.* /usr/lib/python2.4/UserString.* /usr/lib/python2.4/lib-dynload/binascii.so /usr/lib/python2.4/lib-dynload/struct.so /usr/lib/python2.4/lib-dynload/time.so /usr/lib/python2.4/lib-dynload/xreadlines.so /usr/lib/python2.4/types.* /usr/bin/python "
DESCRIPTION_python-io="Python Low-Level I/O"
PR_python-io="ml0"
@@ -93,7 +84,7 @@ FILES_python-terminal="${libdir}/python2.4/pty.* ${libdir}/python2.4/tty.* "
DESCRIPTION_python-email="Python Email Support"
PR_python-email="ml0"
-RDEPENDS_python-email="python-core python-io python-re"
+RDEPENDS_python-email="python-core python-io python-re python-mime python-audio python-image"
FILES_python-email="${libdir}/python2.4/email "
DESCRIPTION_python-image="Python Graphical Image Handling"
@@ -141,10 +132,10 @@ PR_python-fcntl="ml0"
RDEPENDS_python-fcntl="python-core"
FILES_python-fcntl="${libdir}/python2.4/lib-dynload/fcntl.so "
-DESCRIPTION_python-netclient="Python Internet Protocol Clients"
-PR_python-netclient="ml0"
-RDEPENDS_python-netclient="python-core python-datetime python-io python-lang python-logging python-mime"
-FILES_python-netclient="${libdir}/python2.4/*Cookie*.* ${libdir}/python2.4/base64.* ${libdir}/python2.4/cookielib.* ${libdir}/python2.4/ftplib.* ${libdir}/python2.4/gopherlib.* ${libdir}/python2.4/hmac.* ${libdir}/python2.4/httplib.* ${libdir}/python2.4/mimetypes.* ${libdir}/python2.4/nntplib.* ${libdir}/python2.4/poplib.* ${libdir}/python2.4/smtplib.* ${libdir}/python2.4/telnetlib.* ${libdir}/python2.4/urllib.* ${libdir}/python2.4/urllib2.* ${libdir}/python2.4/urlparse.* "
+DESCRIPTION_python-core-debug="Python core module debug information"
+PR_python-core-debug="ml0"
+RDEPENDS_python-core-debug="python-core"
+FILES_python-core-debug="/usr/lib/python2.4/lib-dynload/.debug "
DESCRIPTION_python-pprint="Python Pretty-Print Support"
PR_python-pprint="ml0"
@@ -178,7 +169,7 @@ FILES_python-readline="${libdir}/python2.4/lib-dynload/readline.so ${libdir}/pyt
DESCRIPTION_python-subprocess="Python Subprocess Support"
PR_python-subprocess="ml0"
-RDEPENDS_python-subprocess="python-core python-io python-re"
+RDEPENDS_python-subprocess="python-core python-io python-re python-fcntl python-pickle"
FILES_python-subprocess="${libdir}/python2.4/subprocess.* "
DESCRIPTION_python-pydoc="Python Interactive Help Support"
@@ -204,7 +195,7 @@ FILES_python-xml="${libdir}/python2.4/lib-dynload/pyexpat.so ${libdir}/python2.4
DESCRIPTION_python-mime="Python MIME Handling APIs"
PR_python-mime="ml0"
RDEPENDS_python-mime="python-core python-io"
-FILES_python-mime="${libdir}/python2.4/mimetools.* ${libdir}/python2.4/quopri.* ${libdir}/python2.4/rfc822.* "
+FILES_python-mime="${libdir}/python2.4/mimetools.* ${libdir}/python2.4/uu.* ${libdir}/python2.4/quopri.* ${libdir}/python2.4/rfc822.* "
DESCRIPTION_python-tests="Python Tests"
PR_python-tests="ml0"
@@ -221,6 +212,11 @@ PR_python-stringold="ml0"
RDEPENDS_python-stringold="python-core python-re"
FILES_python-stringold="${libdir}/python2.4/lib-dynload/strop.so ${libdir}/python2.4/string.* "
+DESCRIPTION_python-robotparser="Python robots.txt parser"
+PR_python-robotparser="ml0"
+RDEPENDS_python-robotparser="python-core python-netclient"
+FILES_python-robotparser="${libdir}/python2.4/robotparser.* "
+
DESCRIPTION_python-lib-old-and-deprecated="Python Deprecated Libraries"
PR_python-lib-old-and-deprecated="ml0"
RDEPENDS_python-lib-old-and-deprecated="python-core"
@@ -241,6 +237,11 @@ PR_python-bsddb="ml0"
RDEPENDS_python-bsddb="python-core"
FILES_python-bsddb="${libdir}/python2.4/bsddb "
+DESCRIPTION_python-netclient="Python Internet Protocol Clients"
+PR_python-netclient="ml0"
+RDEPENDS_python-netclient="python-core python-datetime python-io python-lang python-logging python-mime"
+FILES_python-netclient="${libdir}/python2.4/*Cookie*.* ${libdir}/python2.4/base64.* ${libdir}/python2.4/cookielib.* ${libdir}/python2.4/ftplib.* ${libdir}/python2.4/gopherlib.* ${libdir}/python2.4/hmac.* ${libdir}/python2.4/httplib.* ${libdir}/python2.4/mimetypes.* ${libdir}/python2.4/nntplib.* ${libdir}/python2.4/poplib.* ${libdir}/python2.4/smtplib.* ${libdir}/python2.4/telnetlib.* ${libdir}/python2.4/urllib.* ${libdir}/python2.4/urllib2.* ${libdir}/python2.4/urlparse.* "
+
DESCRIPTION_python-mmap="Python Memory-Mapped-File Support"
PR_python-mmap="ml0"
RDEPENDS_python-mmap="python-core python-io"
@@ -274,7 +275,7 @@ FILES_python-lang="${libdir}/python2.4/lib-dynload/array.so ${libdir}/python2.4/
DESCRIPTION_python-audio="Python Audio Handling"
PR_python-audio="ml0"
RDEPENDS_python-audio="python-core"
-FILES_python-audio="${libdir}/python2.4/wave.* ${libdir}/python2.4/chunk.* ${libdir}/python2.4/lib-dynload/ossaudiodev.so ${libdir}/python2.4/lib-dynload/audioop.so "
+FILES_python-audio="${libdir}/python2.4/wave.* ${libdir}/python2.4/chunk.* ${libdir}/python2.4/sndhdr.* ${libdir}/python2.4/lib-dynload/ossaudiodev.so ${libdir}/python2.4/lib-dynload/audioop.so "
diff --git a/packages/python/python_2.4.4.bb b/packages/python/python_2.4.4.bb
index 303f956721..81c83ebbd3 100644
--- a/packages/python/python_2.4.4.bb
+++ b/packages/python/python_2.4.4.bb
@@ -68,3 +68,7 @@ RPROVIDES_python-core = "python"
RPROVIDES_python-curses = "python"
PACKAGES =+ "libpython2"
FILES_libpython2 = "${libdir}/libpython*"
+
+# catch all the rest (unsorted)
+PACKAGES += "python-misc"
+FILES_python-misc = "${libdir}/python2.4"