aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-08 12:09:11 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-08 12:09:11 +0000
commit8f45e70704dbb504d0922ad4277d7bcca7023697 (patch)
tree810389b13cb5303febca719aa5a70345ea872f36
parent2a1348f4d4469c2a0cb820172c5762644652ace6 (diff)
downloadopenembedded-8f45e70704dbb504d0922ad4277d7bcca7023697.tar.gz
- add curl-native
- explicitly disable libidn support
-rw-r--r--packages/curl/curl-native_7.14.0.bb3
-rw-r--r--packages/curl/curl_7.14.0.bb24
2 files changed, 11 insertions, 16 deletions
diff --git a/packages/curl/curl-native_7.14.0.bb b/packages/curl/curl-native_7.14.0.bb
new file mode 100644
index 0000000000..7b99c7c3b4
--- /dev/null
+++ b/packages/curl/curl-native_7.14.0.bb
@@ -0,0 +1,3 @@
+include curl_${PV}.bb
+inherit native
+
diff --git a/packages/curl/curl_7.14.0.bb b/packages/curl/curl_7.14.0.bb
index 1b8a88df84..609320c69e 100644
--- a/packages/curl/curl_7.14.0.bb
+++ b/packages/curl/curl_7.14.0.bb
@@ -1,31 +1,23 @@
-# NOTE: FIXME: curl puts its LDFLAGS in its curl-config and curl.pc files.
-# This is flawed, as the LDFLAGS are often overridden by the user, and in
-# addition, are generally specific to the *build* environment, not target.
-# curl's build should be fixed to manipulate LIBS where appropriate and
-# use that. -CL
-
-DESCRIPTION = "Command line tool and library for \
-client-side URL transfers."
-LICENSE = "MIT"
+DESCRIPTION = "Command line tool and library for client-side URL transfers."
+LICENSE = "MIT"
DEPENDS = "zlib"
SECTION = "console/network"
-PR = "r0"
+PR = "r2"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2"
+S = "${WORKDIR}/curl-${PV}"
-inherit autotools pkgconfig
+inherit autotools pkgconfig binconfig
EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
- --without-ssl --with-random=/dev/urandom"
+ --without-ssl \
+ --with-random=/dev/urandom \
+ --without-idn"
do_stage () {
install -d ${STAGING_INCDIR}/curl
install -m 0644 ${S}/include/curl/*.h ${STAGING_INCDIR}/curl/
oe_libinstall -so -a -C lib libcurl ${STAGING_LIBDIR}
-
- cat curl-config | sed -e "s,-I/usr/include,-I${STAGING_INCDIR}/," \
- | sed -e "s,-L/usr/lib , , "> ${STAGING_BINDIR}/curl-config
- chmod a+rx ${STAGING_BINDIR}/curl-config
}
PACKAGES = "curl curl-doc libcurl libcurl-dev libcurl-doc"