aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-03-18 15:27:07 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-03-18 15:27:07 +0000
commitac76c6f6b02b16d46fd90166828ec257c9f4529f (patch)
tree5d4e8d056060d3fc3ae1929255fb4ee171004dfe
parent4513d932767a810f70d3450113a517c5e1f6e43a (diff)
parent30b0ecaf2330bd79e909a4c0b0c283dd9e517c7a (diff)
downloadopenembedded-ac76c6f6b02b16d46fd90166828ec257c9f4529f.tar.gz
merge of '4657aa1d7f504b72dd4d75e3ffc5a1067390a4d1'
and '72025f26ef1ef6cd7b981232c1a7fb056193282c'
-rw-r--r--packages/openpbx/.mtn2git_empty0
-rw-r--r--packages/openpbx/files/.mtn2git_empty0
-rw-r--r--packages/openpbx/files/init75
-rw-r--r--packages/openpbx/files/logrotate13
-rw-r--r--packages/openpbx/files/volatiles6
-rw-r--r--packages/openpbx/openpbx.org-1.2-rc3/.mtn2git_empty0
-rw-r--r--packages/openpbx/openpbx.org-1.2-rc3/bootstrap.patch37
-rw-r--r--packages/openpbx/openpbx.org-1.2-rc3/openssl.m4.patch46
-rw-r--r--packages/openpbx/openpbx.org_1.2_rc3.bb105
-rw-r--r--packages/spandsp/spandsp_0.0.3.bb18
10 files changed, 300 insertions, 0 deletions
diff --git a/packages/openpbx/.mtn2git_empty b/packages/openpbx/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openpbx/.mtn2git_empty
diff --git a/packages/openpbx/files/.mtn2git_empty b/packages/openpbx/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openpbx/files/.mtn2git_empty
diff --git a/packages/openpbx/files/init b/packages/openpbx/files/init
new file mode 100644
index 0000000000..0ce88c4626
--- /dev/null
+++ b/packages/openpbx/files/init
@@ -0,0 +1,75 @@
+#! /bin/sh
+#
+# This is an init script for openembedded
+# Copy it to /etc/init.d/openpbx and type
+# > update-rc.d openpbx defaults 60
+#
+openpbx=/usr/sbin/openpbx
+pidfile=/var/run/openpbx.org/openpbx.pid
+
+test -x "$openpbx" || exit 0
+
+case "$1" in
+ start)
+ echo -n "Starting OpenPBX"
+ start-stop-daemon --start --quiet --exec $openpbx -- -npq
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping OpenPBX"
+ $openpbx -rx "stop gracefully"
+ sleep 4
+ if [ -f $pidfile ]; then
+ start-stop-daemon --stop --quiet --pidfile $pidfile
+ fi
+ echo "."
+ ;;
+ force-stop)
+ echo -n "Stopping OpenPBX"
+ $openpbx -rx "stop now"
+ sleep 2
+ if [ -f $pidfile ]; then
+ start-stop-daemon --stop --quiet --pidfile $pidfile
+ fi
+ echo "."
+ ;;
+ restart)
+ echo -n "Restarting OpenPBX"
+ if [ -f $pidfile ]; then
+ $openpbx -rx "restart gracefully"
+ sleep 2
+ else
+ start-stop-daemon --start --quiet --exec $openpbx -- -npq
+ fi
+ ;;
+ force-restart)
+ echo -n "Forcibly Restarting OpenPBX"
+ if [ -f $pidfile ]; then
+ $openpbx -rx "restart now"
+ sleep 2
+ else
+ start-stop-daemon --start --quiet --exec $openpbx -- -npq
+ fi
+ ;;
+ reload)
+ echo -n "Reloading OpenPBX Configuration"
+ if [ -f $pidfile ]; then
+ $openpbx -rx "reload"
+ else
+ start-stop-daemon --start --quiet --exec $openpbx -- -npq
+ fi
+ echo "."
+ ;;
+ logger-reload)
+# echo -n "Restating OpenPBX Logger"
+ if [ -f $pidfile ]; then
+ $openpbx -rx "logger reload"
+ fi
+# echo "."
+ ;;
+ *)
+ echo "Usage: /etc/init.d/openpbx {start|stop|force-stop|restart|force-restart|reload|logger-reload}"
+ exit 1
+esac
+
+exit 0
diff --git a/packages/openpbx/files/logrotate b/packages/openpbx/files/logrotate
new file mode 100644
index 0000000000..a0192538a3
--- /dev/null
+++ b/packages/openpbx/files/logrotate
@@ -0,0 +1,13 @@
+/var/log/openpbx.org/cdr-csv/Master.csv /var/log/openpbx.org/queue_log /var/log/openpbx.org/event_log /var/log/openpbx.org/messages
+/var/log/openpbx.org/full {
+ daily
+ missingok
+ compress
+ delaycompress
+ rotate 30
+ sharedscripts
+ postrotate
+ /etc/init.d/openpbx logger-reload
+ endscript
+}
+
diff --git a/packages/openpbx/files/volatiles b/packages/openpbx/files/volatiles
new file mode 100644
index 0000000000..716d469e86
--- /dev/null
+++ b/packages/openpbx/files/volatiles
@@ -0,0 +1,6 @@
+d openpbx openpbx 0775 /var/run/openpbx.org none
+d openpbx openpbx 0775 /var/lib/openpbx.org none
+d openpbx openpbx 0775 /var/log/openpbx.org/cdr-csv none
+d openpbx openpbx 0775 /var/log/openpbx.org/cdr-custom none
+d openpbx openpbx 0775 /var/spool/openpbx.org/outgoing none
+d openpbx openpbx 0775 /var/spool/openpbx.org/voicemail none
diff --git a/packages/openpbx/openpbx.org-1.2-rc3/.mtn2git_empty b/packages/openpbx/openpbx.org-1.2-rc3/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openpbx/openpbx.org-1.2-rc3/.mtn2git_empty
diff --git a/packages/openpbx/openpbx.org-1.2-rc3/bootstrap.patch b/packages/openpbx/openpbx.org-1.2-rc3/bootstrap.patch
new file mode 100644
index 0000000000..7f89772efa
--- /dev/null
+++ b/packages/openpbx/openpbx.org-1.2-rc3/bootstrap.patch
@@ -0,0 +1,37 @@
+*** openpbx.org-1.2_rc3.old/bootstrap.sh Mon Feb 26 16:02:40 2007
+--- openpbx.org-1.2_rc3/bootstrap.sh Mon Feb 26 16:04:11 2007
+***************
+*** 89,104 ****
+ # Check for required version and die if unhappy
+
+ if [ "x$UNAME" = "xFreeBSD" ]; then
+! version_compare libtoolize 1 5 20 || exit 1
+! version_compare automake19 1 9 6 || exit 1
+ version_compare autoconf259 2 59 || exit 1
+ ACLOCAL=aclocal19
+ AUTOHEADER=autoheader259
+ AUTOMAKE=automake19
+ AUTOCONF=autoconf259
+ else
+! version_compare libtoolize 1 5 20 || exit 1
+! version_compare automake 1 9 6 || exit 1
+ version_compare autoconf 2 59 || exit 1
+ ACLOCAL=aclocal
+ AUTOHEADER=autoheader
+--- 89,104 ----
+ # Check for required version and die if unhappy
+
+ if [ "x$UNAME" = "xFreeBSD" ]; then
+! version_compare libtoolize 1 5 10 || exit 1
+! version_compare automake19 1 9 3 || exit 1
+ version_compare autoconf259 2 59 || exit 1
+ ACLOCAL=aclocal19
+ AUTOHEADER=autoheader259
+ AUTOMAKE=automake19
+ AUTOCONF=autoconf259
+ else
+! version_compare libtoolize 1 5 10 || exit 1
+! version_compare automake 1 9 3 || exit 1
+ version_compare autoconf 2 59 || exit 1
+ ACLOCAL=aclocal
+ AUTOHEADER=autoheader
diff --git a/packages/openpbx/openpbx.org-1.2-rc3/openssl.m4.patch b/packages/openpbx/openpbx.org-1.2-rc3/openssl.m4.patch
new file mode 100644
index 0000000000..55d0d33832
--- /dev/null
+++ b/packages/openpbx/openpbx.org-1.2-rc3/openssl.m4.patch
@@ -0,0 +1,46 @@
+*** openpbx.org-1.2_rc3.old/acmacros/openssl.m4 Tue Mar 6 15:21:39 2007
+--- openpbx.org-1.2_rc3/acmacros/openssl.m4 Tue Mar 6 15:23:18 2007
+***************
+*** 3,13 ****
+ #
+ AC_DEFUN([CHECK_SSL],
+ [AC_MSG_CHECKING(if ssl is wanted)
+! # AC_ARG_WITH(ssl,
+! # [ --with-ssl enable ssl [will check /usr/local/ssl
+! # /usr/lib/ssl /usr/ssl /usr/pkg /usr/local /usr /usr/sfw ]
+! # ],
+! #[ AC_MSG_RESULT(yes)
+ for dir in $withval /usr/local/ssl /usr/lib/ssl /usr/ssl /usr/pkg /usr/local /usr /usr/sfw; do
+ ssldir="$dir"
+ if test -f "$dir/include/openssl/ssl.h"; then
+--- 3,13 ----
+ #
+ AC_DEFUN([CHECK_SSL],
+ [AC_MSG_CHECKING(if ssl is wanted)
+! AC_ARG_WITH(ssl,
+! [ --with-ssl enable ssl [will check /usr/local/ssl
+! /usr/lib/ssl /usr/ssl /usr/pkg /usr/local /usr /usr/sfw ]
+! ],
+! [ AC_MSG_RESULT(yes)
+ for dir in $withval /usr/local/ssl /usr/lib/ssl /usr/ssl /usr/pkg /usr/local /usr /usr/sfw; do
+ ssldir="$dir"
+ if test -f "$dir/include/openssl/ssl.h"; then
+***************
+*** 33,40 ****
+ AC_SUBST([HAVE_SSL])
+ AC_SUBST([SSL_LIBS])
+ AC_SUBST([SSL_CFLAGS])
+! #],
+! #[
+! # AC_MSG_RESULT(no)
+! #])
+ ])dnl
+--- 33,40 ----
+ AC_SUBST([HAVE_SSL])
+ AC_SUBST([SSL_LIBS])
+ AC_SUBST([SSL_CFLAGS])
+! ],
+! [
+! AC_MSG_RESULT(no)
+! ])
+ ])dnl
diff --git a/packages/openpbx/openpbx.org_1.2_rc3.bb b/packages/openpbx/openpbx.org_1.2_rc3.bb
new file mode 100644
index 0000000000..64778d0f7c
--- /dev/null
+++ b/packages/openpbx/openpbx.org_1.2_rc3.bb
@@ -0,0 +1,105 @@
+DESCRIPTION = "A flexible VOIP soft switch/PBX."
+HOMEPAGE = "http://www.openpbx.org"
+#RDEPENDS = "ssmtp"
+SECTION = "voip"
+LICENSE = "GPL"
+DEPENDS = "openssl zlib tiff libcap spandsp speex readline js"
+DEPENDS_${PN}-ldap = "openldap"
+RRECOMMENDS = "logrotate"
+RRECOMMENDS_${PN}-ogi = "perl perl-module-strict"
+PV = "1.2_rc3"
+PR = "r0"
+
+SRC_URI = "http://www.openpbx.org/releases/${P}.tar.gz \
+ file://bootstrap.patch;patch=1 \
+ file://openssl.m4.patch;patch=1 \
+ file://logrotate \
+ file://volatiles \
+ file://init"
+
+PARALLEL_MAKE = ""
+INITSCRIPT_NAME = "openpbx"
+INITSCRIPT_PARAMS = "defaults 60"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF = " --with-ssl=${STAGING_DIR}/${HOST_SYS} --enable-low_memory \
+ --disable-zaptel --with-directory-layout=lsb --with-chan_fax \
+ --with-codec-speex=${STAGING_DIR}/${HOST_SYS} --with-app_ldap \
+ --with-perl-shebang='#!${bindir}/perl' --with-jabber --with-res_jabber \
+ --enable-t38 --with-javascript --with-res_js \
+ --bindir=${bindir} --datadir=${datadir} --sysconfdir=${sysconfdir} \
+ --includedir=${includedir} --infodir=${infodir} --mandir=${mandir} \
+ --localstatedir=${localstatedir} --libdir=${libdir}"
+
+do_configure_prepend () {
+ ${S}/bootstrap.sh
+ # Fix some stupidness with the VoiceMail app naming. Case Matters!
+ sed -i 's:Voicemail:VoiceMail:' ${S}/configs/extensions.conf.sample
+ sed -i 's:/var:${localstatedir}:' ${WORKDIR}/volatiles
+ sed -i 's:/var:${localstatedir}:' ${WORKDIR}/logrotate
+ sed -i 's:/etc/init.d:${sysconfdir}/init.d:' ${WORKDIR}/logrotate
+}
+
+do_install_append() {
+ install -c -D -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/openpbx
+ install -c -D -m 644 ${WORKDIR}/logrotate ${D}${sysconfdir}/logrotate.d/openpbx
+ install -c -D -m 644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/openpbx
+}
+
+PACKAGES =+ "${PN}-fax ${PN}-ogi ${PN}-musiconhold ${PN}-ldap"
+
+FILES_${PN}-fax = "${libdir}/openpbx.org/modules/chan_fax.* \
+ ${libdir}/openpbx.org/modules/app_rxfax.* \
+ ${libdir}/openpbx.org/modules/app_txfax.* \
+ ${sysconfdir}/openpbx.org/chan_fax.conf"
+FILES_${PN}-musiconhold = "${libdir}/openpbx.org/modules/res_musiconhold.* \
+ ${sysconfdir}/openpbx.org/musiconhold.conf"
+FILES_${PN}-ogi = "${libdir}/openpbx.org/modules/res_ogi.* \
+ ${datadir}/openpbx.org/ogi/*"
+FILES_${PN}-ldap = "${libdir}/openpbx.org/modules/app_ldap.*"
+
+pkg_postinst_prepend() {
+ grep -q openpbx ${sysconfdir}/group || addgroup --system openpbx
+ grep -q openpbx ${sysconfdir}/passwd || adduser --system --home ${localstatedir}/run/openpbx.org --no-create-home --disabled-password --ingroup openpbx -s ${base_bindir}/false openpbx
+ chown -R openpbx:openpbx ${localstatedir}/lib/openpbx.org ${localstatedir}/spool/openpbx.org ${localstatedir}/log/openpbx.org ${localstatedir}/run/openpbx.org ${sysconfdir}/openpbx.org ${datadir}/openpbx.org
+ /etc/init.d/populate-volatile.sh update
+}
+
+CONFFILES_${PN}-fax += "${sysconfdir}/openpbx.org/chan_fax.conf"
+CONFFILES_${PN}-musiconhold += "${sysconfdir}/openpbx.org/musiconhold.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/adsi.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/adtranvofr.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/agents.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/cdr.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/cdr_custom.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/cdr_manager.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/cdr_tds.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/codecs.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/dnsmgr.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/dundi.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/enum.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/extconfig.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/extensions.ael"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/features.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/iax.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/indications.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/logger.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/manager.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/meetme.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/mgcp.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/modem.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/modules.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/muted.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/openpbx.adsi"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/openpbx.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/osp.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/privacy.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/queues.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/rpt.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/rtp.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/sip.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/sip_notify.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/udptl.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/voicemail.conf"
+CONFFILES_${PN} += "${sysconfdir}/openpbx.org/woomera.conf"
diff --git a/packages/spandsp/spandsp_0.0.3.bb b/packages/spandsp/spandsp_0.0.3.bb
new file mode 100644
index 0000000000..26702f998b
--- /dev/null
+++ b/packages/spandsp/spandsp_0.0.3.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "A library of many DSP functions for telephony."
+HOMEPAGE = "http://www.soft-switch.org"
+DEPENDS = "tiff libxml2"
+SECTION = "voip"
+LICENSE = "GPL"
+PV = "0.0.3"
+PSUBV = "pre27"
+PR = "r0"
+
+SRC_URI = "http://www.soft-switch.org/downloads/snapshots/spandsp/spandsp-20070123.tar.gz"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+do_stage () {
+ autotools_stage_all
+}