aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-01-04 12:04:58 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-04 12:04:58 +0000
commitcd0145e046c950354df6518ff3982d48bb38945e (patch)
treeeb3e6bff044672284a1d09d3694479d131123190
parent003e359e96f7362b62adb564507c8bbd15fb4bd1 (diff)
downloadopenembedded-cd0145e046c950354df6518ff3982d48bb38945e.tar.gz
debianslug: new distro for little-endian nslu2 kernel suitable for running debian
-rw-r--r--conf/distro/debianslug-packages.conf2
-rw-r--r--conf/distro/debianslug.conf130
2 files changed, 132 insertions, 0 deletions
diff --git a/conf/distro/debianslug-packages.conf b/conf/distro/debianslug-packages.conf
new file mode 100644
index 0000000000..eaf6b8fe31
--- /dev/null
+++ b/conf/distro/debianslug-packages.conf
@@ -0,0 +1,2 @@
+SLUGOS_EXTRA_BBFILES=${DEBIANSLUG_EXTRA_BBFILES}
+include conf/distro/slugos-packages.conf
diff --git a/conf/distro/debianslug.conf b/conf/distro/debianslug.conf
new file mode 100644
index 0000000000..67563a8dd2
--- /dev/null
+++ b/conf/distro/debianslug.conf
@@ -0,0 +1,130 @@
+#@TYPE: Distribution
+#@NAME: DebianSlug
+#@DESCRIPTION: DebianSlug Linux Distribution for the NSLU2
+
+#----------------------------------------------------------------------------------
+# STANDARD DebianSlug DEFINITIONS
+#----------------------------------------------------------------------------------
+DISTRO_NAME = "DebianSlug"
+DISTRO_VERSION = "3.1-beta"
+DISTRO_FEED = "unstable"
+DISTRO_TYPE = "beta"
+SLUGOS_IMAGENAME = "debianslug"
+
+# debianslug builds a complete image (not just the parts)
+SLUGOS_FLASH_IMAGE = "yes"
+
+# NOTE: to build new packages set DEBIANSLUG_EXTRA_BBFILES to the full path name to
+# the .bb files for the packages to build - see debianslug-packages.conf in this
+# directory
+DEBIANSLUG_EXTRA_BBFILES ?= ""
+
+#----------------------------------------------------------------------------------
+# FEEDS
+# The following lines define where on the internet DebianSlug looks for packages
+# when downloading new packages or updating existing packages. Additional feeds
+# (such as a local feed) can be defined in local.conf
+#----------------------------------------------------------------------------------
+# Add to the user's feeds from local.conf (there may be none)
+FEED_URIS_append += "cross##http://ipkg.nslu2-linux.org/feeds/slugos-lag/cross/${DISTRO_FEED}"
+FEED_URIS_append += "native##http://ipkg.nslu2-linux.org/feeds/slugos-lag/native/${DISTRO_FEED}"
+
+#----------------------------------------------------------------------------------
+# FIRMWARE CONFIGURATION
+#----------------------------------------------------------------------------------
+# EXTRA PACKAGES
+# --------------
+# Filesystem support modules are listed in here for easy removal,
+# as is the lrzsz serial package and other kernel modules which are
+# not absolutely required for boot.
+# NOTE: only jffs2 support is an absolute requirement of boot, even
+# the ext2/ext3 support is optional!
+DEBIANSLUG_EXT2_PROGS = "e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-e2fsck"
+DEBIANSLUG_REISER_PROGS = "reiserfsprogs"
+
+# The standard firmware contents and additional packages built as requirements
+# of the firmware are defined here in DEBIANSLUG_STANDARD_RDEPENDS and
+# DEBIANSLUG_STANDARD_DEPENDS respectively.
+DEBIANSLUG_STANDARD_DEPENDS = ""
+DEBIANSLUG_STANDARD_RDEPENDS = ""
+
+# Support for a variety of file systems is built in to the debianslug
+# image, programs to format disks with these file systems may be
+# added or removed. By default ext2. ext3 and reiserfs supported
+# is included by the following lines.
+#
+# These lines add support for formatting ext2 and ext3 file systems
+# on a hard disk attached to the NSLU2. ext3 is the standard Linux
+# file system.
+DEBIANSLUG_STANDARD_DEPENDS += "e2fsprogs"
+DEBIANSLUG_STANDARD_RDEPENDS += "${DEBIANSLUG_EXT2_PROGS}"
+
+# These lines add support for formatting reiserfs file systems on
+# a hard disk.
+DEBIANSLUG_STANDARD_DEPENDS += "reiserfsprogs"
+DEBIANSLUG_STANDARD_RDEPENDS += "${DEBIANSLUG_REISER_PROGS}"
+
+# These lines add support for an X/Y/ZModem package called lrzsz
+# (this is of use for people with modified NSLU2 hardware which
+# supports a serial port.)
+DEBIANSLUG_STANDARD_DEPENDS += "lrzsz"
+DEBIANSLUG_STANDARD_RDEPENDS += "lrzsz"
+
+# Filesystem selection. Adding entries here adds the module to the
+# image. The module must be built as part of nslu2-kernel (i.e. it
+# must be specified as a module in the defconfig file). The NLS
+# support charset modules must be given explicitly and must match
+# the codepage/iocharset and NLS handling for the file systems which
+# require them. The installed lanugage set is minimal but sufficient
+# for any file system (since it uses utf8). See
+# http://www.nslu2-linux.orgwiki/HowTo/MountFATFileSystems
+# for more information on the language behaviour of the DOS file
+# systems.
+#
+# KERNEL LEVEL FILE SYSTEM SUPPORT
+# --------------------------------
+# NOTE: removing kernel-module-nfs from this list will prevent NFS
+# boot (however you can do a simple flash file system boot - no
+# attached disk - and install the nfs modules from ssh.)
+DEBIANSLUG_STANDARD_RDEPENDS += "\
+kernel-module-ext2 \
+kernel-module-jbd \
+kernel-module-ext3 \
+kernel-module-nfs \
+kernel-module-vfat \
+kernel-module-ntfs \
+kernel-module-isofs \
+kernel-module-udf \
+kernel-module-reiserfs \
+kernel-module-nls-cp437 \
+kernel-module-nls-utf8 \
+"
+
+# This documents other file systems which are built but not installed
+# by default in the flash image.
+#
+# kernel-module-msdos - mounts a FAT file system without long file names
+# (use kernel-module-vfat, it shows the long names
+# if present.)
+
+# The 'standard' values are the defaults for the 'extra' packages added
+# to the firmware image. None of these things are requirements to have
+# a bootable, useable, system however they *are* expected to be present
+# in DebianSlug - see slugos-lag for a more minimal configuration and some
+# more instructions about how to make a non-debianslug image.
+SLUGOS_EXTRA_DEPENDS = "${DEBIANSLUG_STANDARD_DEPENDS}"
+SLUGOS_EXTRA_RDEPENDS = "${DEBIANSLUG_STANDARD_RDEPENDS}"
+
+#----------------------------------------------------------------------------------
+# PACKAGE VERSION CONTROL
+#----------------------------------------------------------------------------------
+PREFERRED_VERSION_nslu2-linksys-firmware ?= "2.3r63"
+
+#----------------------------------------------------------------------------------
+# BASE VERSION SELECTION
+#----------------------------------------------------------------------------------
+# l - little-endian
+# a - ARM instruction set
+# g - glibc
+#
+include conf/distro/slugos-lag.conf