aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorccsmart <ccsmart@smartpal.de>2007-01-18 20:22:00 +0000
committerccsmart <ccsmart@smartpal.de>2007-01-18 20:22:00 +0000
commitf0767dfd368f1df9dcb40816cab65a89946237fb (patch)
tree1c1624a47c2570d428a1f428188755f96c6b9d4b
parent2254c2110b3d8cded176e7d56268e77c64b4879d (diff)
downloadopenembedded-f0767dfd368f1df9dcb40816cab65a89946237fb.tar.gz
g15daemon: added runtime dependency and header files
-rw-r--r--packages/g15daemon/g15daemon_1.2.6a.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/packages/g15daemon/g15daemon_1.2.6a.bb b/packages/g15daemon/g15daemon_1.2.6a.bb
index 872d61d848..e6f3c19e55 100644
--- a/packages/g15daemon/g15daemon_1.2.6a.bb
+++ b/packages/g15daemon/g15daemon_1.2.6a.bb
@@ -9,7 +9,8 @@ LICENSE = "GPLv2"
SECTION = "console/utils"
PRIORITY = "optional"
DEPENDS = "libdaemon libg15"
-RDEPENDS = "libg15"
+RDEPENDS = "kernel-module-uinput libg15"
+PR="r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/g15daemon/g15daemon-${PV}.tar.bz2"
@@ -17,3 +18,9 @@ inherit autotools
EXTRA_OECONF = "--disable-build-docs"
+do_stage () {
+ for i in libg15daemon_client/g15daemon_client.h; do
+ install -m 0644 ${S}/$i ${STAGING_INCDIR}/
+ done
+}
+