aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-02-11 21:17:39 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-11 21:17:39 +0000
commit269cb6277fed3b198feb6f2a95daae0e84cebd1c (patch)
tree06888591c7b6047eeaec6809485a4449dc448434
parent92f271865c4af0d07917b36e06ebda5043b36607 (diff)
downloadopenembedded-269cb6277fed3b198feb6f2a95daae0e84cebd1c.tar.gz
e17-gpe-menu-convert: remove , add PATH_TO_PIXMAPS, switch tabs to spaces, switch RDEPENDS back to libedje-dev, remove postinst for now
-rw-r--r--packages/e17/e17-gpe-menu-convert/e17-gpe-menu-convert.sh157
-rw-r--r--packages/e17/e17-gpe-menu-convert_0.2.bb11
2 files changed, 85 insertions, 83 deletions
diff --git a/packages/e17/e17-gpe-menu-convert/e17-gpe-menu-convert.sh b/packages/e17/e17-gpe-menu-convert/e17-gpe-menu-convert.sh
index cf144272ec..63e984d7f6 100644
--- a/packages/e17/e17-gpe-menu-convert/e17-gpe-menu-convert.sh
+++ b/packages/e17/e17-gpe-menu-convert/e17-gpe-menu-convert.sh
@@ -2,26 +2,26 @@
setVar() {
if [ ! "$value" = "" ]; then
- name=`echo "$name" | sed 'y:-\[\]:_____:'`
- value=`echo "$value" | sed 's:":\\\":g'`
- export $name="$value"
+ name=`echo "$name" | sed 'y:-\[\]:_____:'`
+ value=`echo "$value" | sed 's:":\\\":g'`
+ export $name="$value"
fi
}
#convert true/false to 1/0
bool() {
if [ ! "$1" = "" ]; then
- if [ "$1" = "True" ]; then
- cmd="$cmd $2 1"
- else
- cmd="$cmd $2 0"
- fi
+ if [ "$1" = "True" ]; then
+ cmd="$cmd $2 1"
+ else
+ cmd="$cmd $2 0"
+ fi
fi
}
str() {
if [ ! "$1" = "" ]; then
- cmd="$cmd $2 \"$1"\"
+ cmd="$cmd $2 \"$1"\"
fi
}
@@ -29,30 +29,30 @@ convert_desktop_to_eap() {
echo "Converting $1 to $2"
for l in `cat $1`; do
#on empty line clear vars
- if [ "$l" = "" ]; then
-
- #grab previous var if it exists
- setVar
-
- name=""
- value=""
- else
- #if an = is in the line it's a name/value pair
- if echo "$l" | grep -q "="; then
-
- #grab previous var if it exists
- setVar
-
- name=`echo "$l" | cut -d "=" -f 1`
- value=`echo "$l" | cut -d "=" -f 2-`
- else
-
- #if previous value assume this is a continuation
- if [ ! "$value" = "" ]; then
- value="$value $l"
- fi
- fi
- fi
+ if [ "$l" = "" ]; then
+
+ #grab previous var if it exists
+ setVar
+
+ name=""
+ value=""
+ else
+ #if an = is in the line it's a name/value pair
+ if echo "$l" | grep -q "="; then
+
+ #grab previous var if it exists
+ setVar
+
+ name=`echo "$l" | cut -d "=" -f 1`
+ value=`echo "$l" | cut -d "=" -f 2-`
+ else
+
+ #if previous value assume this is a continuation
+ if [ ! "$value" = "" ]; then
+ value="$value $l"
+ fi
+ fi
+ fi
done
setVar
@@ -70,66 +70,67 @@ convert_desktop_to_eap() {
##enlightenment_eapp | grep -- -set- | cut -d " " -f 3 | xargs -iCMD enlightenment_eapp gpe-othello.eap CMD \"\"
#enlightenment_eapp gpe-othello.eap -del-all
- cat <<EOF > /tmp/gpeEap.edc
+ cat <<EOF > /tmp/gpeEap.edc
images {
image: "$Icon" COMP;
}
collections {
group {
- name: "icon";
- max: 48 48;
- parts {
- part {
- name: "image";
- mouse_events: 0;
- description {
- state: "default" 0.0;
- aspect: 1.0 1.0;
- image.normal: "$Icon";
- }
- }
- }
+ name: "icon";
+ max: 48 48;
+ parts {
+ part {
+ name: "image";
+ mouse_events: 0;
+ description {
+ state: "default" 0.0;
+ aspect: 1.0 1.0;
+ image.normal: "$Icon";
+ }
+ }
+ }
}
}
EOF
- edje_cc --image_dir /usr/share/pixmaps /tmp/gpeEap.edc "$PATH_TO_EAP/$2"
- rm /tmp/gpeEap.edc
+ edje_cc --image_dir "$PATH_TO_PIXMAPS" /tmp/gpeEap.edc "$PATH_TO_EAP/$2"
+ rm /tmp/gpeEap.edc
- cmd="enlightenment_eapp \"$PATH_TO_EAP/$2\" $cmd"
+ cmd="enlightenment_eapp \"$PATH_TO_EAP/$2\" $cmd"
#pipe command in sh to allow it to re-interpret quotes
- echo $cmd | /bin/sh -s
-
- if `echo "$Categories" | grep -q "SystemSettings"`; then
- dir="Settings"
- elif `echo "$Categories" | grep -q "PIM"`; then
- dir="PIM"
- elif `echo "$Categories" | grep -q "Network"`; then
- dir="Network"
- elif `echo "$Categories" | grep -q "Games"`; then
- dir="Games"
- elif `echo "$Categories" | grep -q "Game"`; then
- dir="Games"
- elif `echo "$Categories" | grep -q "AudioVideo"`; then
- dir="Multimedia"
- elif `echo "$Categories" | grep -q "Panel"`; then
- dir="Utility/Panel"
- elif `echo "$Categories" | grep -q "Utility"`; then
- dir="Utlity"
- else
- dir=""
- fi
-
- #dir=`echo "$Categories" | sed 'y:;:/:'`
- mkdir -p "$PATH_TO_E_GPE/$dir"
- echo "$2" >> "$PATH_TO_E_GPE/$dir"/.order
+ echo $cmd | /bin/sh -s
+
+ if `echo "$Categories" | grep -q "SystemSettings"`; then
+ dir="Settings"
+ elif `echo "$Categories" | grep -q "PIM"`; then
+ dir="PIM"
+ elif `echo "$Categories" | grep -q "Network"`; then
+ dir="Network"
+ elif `echo "$Categories" | grep -q "Games"`; then
+ dir="Games"
+ elif `echo "$Categories" | grep -q "Game"`; then
+ dir="Games"
+ elif `echo "$Categories" | grep -q "AudioVideo"`; then
+ dir="Multimedia"
+ elif `echo "$Categories" | grep -q "Panel"`; then
+ dir="Utility/Panel"
+ elif `echo "$Categories" | grep -q "Utility"`; then
+ dir="Utlity"
+ else
+ dir=""
+ fi
+
+ #dir=`echo "$Categories" | sed 'y:;:/:'`
+ mkdir -p "$PATH_TO_E_GPE/$dir"
+ echo "$2" >> "$PATH_TO_E_GPE/$dir"/.order
fi
}
-PATH_TO_DESKTOP="${IMAGE_ROOTFS}/usr/share/applications"
-PATH_TO_EAP="${IMAGE_ROOTFS}/home/root/.e/e/applications/all"
-PATH_TO_E_GPE="${IMAGE_ROOTFS}/home/root/.e/e/applications/favorite/GPE"
+PATH_TO_DESKTOP="/usr/share/applications"
+PATH_TO_PIXMAPS="/usr/share/pixmaps"
+PATH_TO_EAP="/home/root/.e/e/applications/all"
+PATH_TO_E_GPE="/home/root/.e/e/applications/favorite/GPE"
if [ ! -d $PATH_TO_E_GPE ]; then
mkdir -p $PATH_TO_E_GPE
diff --git a/packages/e17/e17-gpe-menu-convert_0.2.bb b/packages/e17/e17-gpe-menu-convert_0.2.bb
index b83cba6209..fd55d34915 100644
--- a/packages/e17/e17-gpe-menu-convert_0.2.bb
+++ b/packages/e17/e17-gpe-menu-convert_0.2.bb
@@ -1,10 +1,11 @@
DESCRIPTION = "Shell script to convert GPE .desktop files into e17 eap files and menus"
DEPENDS = "edje e-wm"
-RDEPENDS += "edje-utils e-wm"
+#RDEPENDS += "edje-utils e-wm"
+RDEPENDS += "libedje-dev e-wm"
LICENSE = "MIT"
SECTION = "e/apps"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
-PR = "r0"
+PR = "r1"
SRC_URI = "file://e17-gpe-menu-convert.sh"
@@ -13,6 +14,6 @@ do_install() {
install -m 755 ${WORKDIR}/e17-gpe-menu-convert.sh ${D}/usr/bin/e17-gpe-menu-convert.sh
}
-pkg_postinst() {
- /usr/bin/e17-gpe-menu-convert.sh 2>&1 > /tmp/gpe-menu-convert.log
-} \ No newline at end of file
+#pkg_postinst() {
+# /usr/bin/e17-gpe-menu-convert.sh
+#} \ No newline at end of file