aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-04-01 14:12:07 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-04-01 14:12:07 +0000
commit749247ebc88eee2142d3aa507f542866c3035ac2 (patch)
tree0aa006dce68b91dfd7e71ab9774bde0cc21d9ef7
parent0325c6d653f312f1cb7f86b85c33a721c9b4cd5b (diff)
downloadopenembedded-749247ebc88eee2142d3aa507f542866c3035ac2.tar.gz
fix typo and packaging for gpsd. folks, packaging a hard coded link to /dev/ttyS3 looks wrong to me. that should be made by the start script depending on the actual serial tty. S3 is not always correct.
BKrev: 424d56b7xOgpx5asQTIjseMrYwViQg
-rw-r--r--packages/gpsd/gpsd_2.20.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/gpsd/gpsd_2.20.bb b/packages/gpsd/gpsd_2.20.bb
index e69de29bb2..5f509f9f39 100644
--- a/packages/gpsd/gpsd_2.20.bb
+++ b/packages/gpsd/gpsd_2.20.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "A TCP/IP Daemon simplifying the communication with GPS devices"
+SECTION = "net"
+PRIORITY = "optional"
+MAINTAINER = "Jose Bernardo Silva <jbs@bandos.homelinux.com> \
+ Robert Anderson <rea@sr.unh.edu> \
+ Stephan Zalewski <stephan.zalewski@uni-dusseldorf.de>"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://download.berlios.de/gpsd/gpsd-${PV}.tar.gz \
+ file://gpsd"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "gpsd"
+INITSCRIPT_PARAMS = "defaults 35"
+
+export LDFLAGS = "-L${STAGING_LIBDIR} -lm"
+export X_LIBS = ""
+
+do_stage() {
+ oe_libinstall -so -C ${S}/.libs libgps ${STAGING_LIBDIR}
+ install -m 0655 ${S}/libgps.la ${STAGING_LIBDIR}
+ install -m 0655 ${S}/gps.h ${STAGING_INCDIR}
+ install -m 0655 ${S}/gpsd.h ${STAGING_INCDIR}
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}/dev
+ install -m 0755 ${WORKDIR}/gpsd ${D}/${sysconfdir}/init.d/
+ ln -sf /dev/ttyS3 ${D}/dev/gps
+}
+
+FILES_${PN} += "${sysconfdir} /dev/gps"
+PACKAGES =+ "libgps"
+FILES_libgps = "${libdir}/*.so*"