aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-22 19:22:45 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-22 19:22:45 +0100
commitdc5457b68bfccca1f7a3be247b0af7500422e8a3 (patch)
tree146ca1b9f1f5111b1de42d15754200ffab415d40
parentee13a2cd8dd056674cee4da5ce1d26a1828333b6 (diff)
downloadopenembedded-dc5457b68bfccca1f7a3be247b0af7500422e8a3.tar.gz
motion: fix ffmpeg support
-rw-r--r--packages/motion/motion-3.2.11/ffmpeg-0.4.9.15594svn-20081010.diff14
-rw-r--r--packages/motion/motion_3.2.11.bb7
2 files changed, 18 insertions, 3 deletions
diff --git a/packages/motion/motion-3.2.11/ffmpeg-0.4.9.15594svn-20081010.diff b/packages/motion/motion-3.2.11/ffmpeg-0.4.9.15594svn-20081010.diff
new file mode 100644
index 0000000000..af85599f20
--- /dev/null
+++ b/packages/motion/motion-3.2.11/ffmpeg-0.4.9.15594svn-20081010.diff
@@ -0,0 +1,14 @@
+Index: ffmpeg.c
+===================================================================
+--- trunk/ffmpeg.c (revision 434)
++++ trunk/ffmpeg.c (working copy)
+@@ -164,7 +164,8 @@
+ return write(fd, buf, size);
+ }
+
+-static offset_t file_seek(URLContext *h, offset_t pos, int whence)
++
++static int64_t file_seek(URLContext *h, int64_t pos, int whence)
+ {
+ int fd = (size_t)h->priv_data;
+ return lseek(fd, pos, whence);
diff --git a/packages/motion/motion_3.2.11.bb b/packages/motion/motion_3.2.11.bb
index dc7c0ecdbb..999a0ab6bd 100644
--- a/packages/motion/motion_3.2.11.bb
+++ b/packages/motion/motion_3.2.11.bb
@@ -7,13 +7,14 @@ DEPENDS = "jpeg ffmpeg mysql postgresql"
RSUGGESTS = "mysql-client postgresql-client"
-PR = "r0"
+PR = "r1"
-SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
+ file://ffmpeg-0.4.9.15594svn-20081010.diff;patch=1 "
inherit autotools
-EXTRA_OECONF = " --with-ffmpeg=${STAGING_LIBDIR} \
+EXTRA_OECONF = " --with-ffmpeg=${STAGING_LIBDIR}/../ \
--with-mysql-lib=${STAGING_LIBDIR} \
--with-mysql-include=${STAGING_INCDIR}/mysql \
--with-pgsql-lib=${STAGING_LIBDIR} \