aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2008-06-02 08:56:32 +0000
committerKoen Kooi <koen@openembedded.org>2008-06-02 08:56:32 +0000
commit9abb0a36610b88e38d48c4e964c47a07cc7cbedd (patch)
treedfcba68afcbd3abab2d4934cac7df8169f08846f
parent65872f1b9c484492d5e6640cca5beae8929fbb6a (diff)
downloadopenembedded-9abb0a36610b88e38d48c4e964c47a07cc7cbedd.tar.gz
mtd-utils: install and package headers
Acked-by: Koen Kooi <koen@openembedded.org> Acked-By: Marcin Juszkiewicz <hrw@openembedded.org>
-rw-r--r--packages/mtd/mtd-utils_1.0.0+git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/mtd/mtd-utils_1.0.0+git.bb b/packages/mtd/mtd-utils_1.0.0+git.bb
index 33f95853f6..f09189063a 100644
--- a/packages/mtd/mtd-utils_1.0.0+git.bb
+++ b/packages/mtd/mtd-utils_1.0.0+git.bb
@@ -3,7 +3,7 @@ SECTION = "base"
DEPENDS = "zlib lzo"
HOMEPAGE = "http://www.linux-mtd.infradead.org/"
LICENSE = "GPLv2"
-PR = "r6"
+PR = "r7"
# This is the default package, thus we lock to a specific git version so
# upstream changes will not break builds.
@@ -36,7 +36,11 @@ mtd_utils = "ftl_format flash_erase flash_eraseall nanddump doc_loadbios \
do_install () {
install -d ${D}${bindir}
+ install -d ${D}${includedir}/mtd
for binary in ${mtd_utils}; do
install -m 0755 $binary ${D}${bindir}
done
+ for f in ${S}/include/mtd/*.h; do
+ install -m 0644 $f ${D}${includedir}/mtd/
+ done
}