aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-02-03 19:20:48 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-02-03 19:20:48 +0100
commitb977bbd442f3d00c884b68c1307bd9b14fb96446 (patch)
tree74b8a3a9a8e7d32cc4af7bc93cff3db409f9ebc2
parenta44e5b4cfd8b0b32386e65cbc30f816c062cc162 (diff)
downloadopenembedded-b977bbd442f3d00c884b68c1307bd9b14fb96446.tar.gz
packaged-staging.bbclass: removed two few superfluous slashes
${SYSROOT_DESTDIR} ends on a / but there is also a / after the variable and a slash as the first character of the next variable. This patch removes the / that is explicitly added so in the generated code we get // instead of the even sillier looking (and probably more confusing) /// Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-rw-r--r--classes/packaged-staging.bbclass4
-rw-r--r--recipes/u-boot/u-boot_1.1.4.bb4
2 files changed, 6 insertions, 2 deletions
diff --git a/classes/packaged-staging.bbclass b/classes/packaged-staging.bbclass
index 108cfb096b..1ede25cef0 100644
--- a/classes/packaged-staging.bbclass
+++ b/classes/packaged-staging.bbclass
@@ -288,8 +288,8 @@ packagedstaging_fastpath () {
if [ "$PSTAGING_ACTIVE" = "1" ]; then
mkdir -p ${PSTAGE_TMPDIR_STAGE}/staging/
mkdir -p ${PSTAGE_TMPDIR_STAGE}/cross/
- cp -fpPR ${SYSROOT_DESTDIR}/${STAGING_DIR}/* ${PSTAGE_TMPDIR_STAGE}/staging/ || /bin/true
- cp -fpPR ${SYSROOT_DESTDIR}/${CROSS_DIR}/* ${PSTAGE_TMPDIR_STAGE}/cross/ || /bin/true
+ cp -fpPR ${SYSROOT_DESTDIR}${STAGING_DIR}/* ${PSTAGE_TMPDIR_STAGE}/staging/ || /bin/true
+ cp -fpPR ${SYSROOT_DESTDIR}${CROSS_DIR}/* ${PSTAGE_TMPDIR_STAGE}/cross/ || /bin/true
fi
}
diff --git a/recipes/u-boot/u-boot_1.1.4.bb b/recipes/u-boot/u-boot_1.1.4.bb
index df6a357c63..dacd88655f 100644
--- a/recipes/u-boot/u-boot_1.1.4.bb
+++ b/recipes/u-boot/u-boot_1.1.4.bb
@@ -47,6 +47,10 @@ SRC_URI_append_avr32= "\
file://fix-mmc-data-timeout.patch;patch=1 \
"
+SRC_URI_append_openrd-client = "\
+ file://0001-OpenRD-Support-Uboot.patch;pach=1 \
+"
+
EXTRA_OEMAKE_gumstix = "CROSS_COMPILE=${TARGET_PREFIX} GUMSTIX_400MHZ=${GUMSTIX_400MHZ}"
TARGET_LDFLAGS = ""