aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-04-28 19:31:48 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-28 19:31:48 +0000
commitc529526f2d51cc6c574ba52bd7e814319536fab3 (patch)
treed10eafcdc210957f7824618b53078b2613f0859e
parent451dbfc418dcc6e729760f5cdddda390fe656c2d (diff)
downloadopenembedded-c529526f2d51cc6c574ba52bd7e814319536fab3.tar.gz
* new grub version 0.97 built and tested
* create a /boot/grub symlink so stage_1.5 and stage_2 files can be found by bootloader - close #863
-rw-r--r--packages/grub/grub_0.97.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/grub/grub_0.97.bb b/packages/grub/grub_0.97.bb
new file mode 100644
index 0000000000..d0dddd0189
--- /dev/null
+++ b/packages/grub/grub_0.97.bb
@@ -0,0 +1,22 @@
+SECTION = "base"
+DESCRIPTION = "grand unified bootloader"
+
+SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz"
+
+S = "${WORKDIR}/grub-${PV}"
+
+inherit autotools
+
+python __anonymous () {
+ import re
+ host = bb.data.getVar('HOST_SYS', d, 1)
+ if not re.match('i.86.*-linux', host):
+ raise bb.parse.SkipPackage("incompatible with host %s" % host)
+}
+
+do_install_append_vmware() {
+ mkdir -p ${D}/boot/
+ ln -sf ../usr/lib/grub/{$TARGET_ARCH}{$TARGET_VENDOR}/ ${D}/boot/grub
+}
+
+FILES_${PN} = "/boot /usr"