aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-07 00:48:49 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-07 00:48:49 +0000
commitda49fe48efae614c0b7b61f99779efae5611f53e (patch)
treec535b300bf24b78ba8d917b07c0dc201fcba100c
parentc665e9631f8d5b2953b01390db44fdca3ce74482 (diff)
parent7e873d9f0c70ca04dea117735b22dd174bbe1b01 (diff)
downloadopenembedded-da49fe48efae614c0b7b61f99779efae5611f53e.tar.gz
merge of '23aaca50b161d66de0dd1f96937010f0ad1f1f54'
and '7dbeb5e383fa2bee20df397e69caddaee824c644'
-rw-r--r--packages/ruby/ruby_1.8.5.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/packages/ruby/ruby_1.8.5.bb b/packages/ruby/ruby_1.8.5.bb
index 981f826dc6..972d56e14c 100644
--- a/packages/ruby/ruby_1.8.5.bb
+++ b/packages/ruby/ruby_1.8.5.bb
@@ -1,11 +1,25 @@
DESCRIPTION = "Ruby is an interpreted scripting language \
for quick and easy object-oriented programming."
SECTION = "devel/ruby"
-DEPENDS = "ruby-native"
+DEPENDS = "ruby-native zlib openssl"
PRIORITY = "optional"
LICENSE = "GPL"
-SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/ruby-${PV}.tar.gz"
+SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/ruby-${PV}.tar.gz \
+ file://extmk_run.patch;patch=1 \
+ file://disable_wide_getaddrinfo_check.patch;patch=1"
+
S = "${WORKDIR}/ruby-${PV}"
inherit autotools
+
+# This snippet lets compiled extensions which rely on external libraries,
+# such as zlib, compile properly. If we don't do this, then when extmk.rb
+# runs, it uses the native libraries instead of the target libraries, and so
+# none of the linking operations succeed -- which makes extconf.rb think
+# that the libraries aren't available and hence that the extension can't be
+# built.
+
+do_configure_prepend() {
+ sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
+}