aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-07-06 15:31:56 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-07-06 15:35:07 +0400
commitbd48453a5e2a9361b63c32a68642fea2857017d5 (patch)
tree5964485aaf95a6d7bd1b5ec8dd4dc4e96082bd9a
parent9d90c5c0cf1f778d7f259c8f2f9d3d12221407f6 (diff)
downloadopenembedded-bd48453a5e2a9361b63c32a68642fea2857017d5.tar.gz
linux-mainstone: fix building with current gcc
Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
-rw-r--r--recipes/linux/linux-mainstone/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch15
-rw-r--r--recipes/linux/linux-mainstone_2.6.25.bb3
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/linux/linux-mainstone/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch b/recipes/linux/linux-mainstone/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch
new file mode 100644
index 0000000000..9d7020d9f1
--- /dev/null
+++ b/recipes/linux/linux-mainstone/0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch
@@ -0,0 +1,15 @@
+Index: linux-2.6.24/include/linux/time.h
+===================================================================
+--- a/include/linux/time.h
++++ b/include/linux/time.h
+@@ -172,6 +172,10 @@ static inline void timespec_add_ns(struct timespec *a, u64 ns)
+ {
+ ns += a->tv_nsec;
+ while(unlikely(ns >= NSEC_PER_SEC)) {
++ /* The following asm() prevents the compiler from
++ * optimising this loop into a modulo operation. */
++ asm("" : "+r"(ns));
++
+ ns -= NSEC_PER_SEC;
+ a->tv_sec++;
+ }
diff --git a/recipes/linux/linux-mainstone_2.6.25.bb b/recipes/linux/linux-mainstone_2.6.25.bb
index d9599ef76c..f2d972dd78 100644
--- a/recipes/linux/linux-mainstone_2.6.25.bb
+++ b/recipes/linux/linux-mainstone_2.6.25.bb
@@ -3,11 +3,12 @@ require linux.inc
SECTION = "kernel"
DESCRIPTION = "Linux kernel for the Mainstone (PXA270 ref design)"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/v2.6.25/patch-2.6.25-rc4.bz2;patch=1 \
file://mainstone-keypad.patch;patch=1 \
+ file://0001-time-prevent-the-loop-in-timespec_add_ns-from-bei.patch;patch=1 \
file://defconfig"
S = "${WORKDIR}/linux-2.6.24"