aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-02-16 16:46:06 +0100
committerThomas Zimmermann <zimmermann@vdm-design.de>2011-02-20 13:27:21 +0100
commit23a89fbb4cf47be1fbb5e034f0d4b5fe943387be (patch)
tree8018b8f999b4b6d33fb934795d3aadfca1b76fd9
parentb2acf0f04f92cb95f439956da2965e67a1582553 (diff)
downloadopenembedded-23a89fbb4cf47be1fbb5e034f0d4b5fe943387be.tar.gz
openmoko-gps: bump SRCREV, fix QA issues, fix hardcoded path, use bindir/datadir and rename recipe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb33
-rw-r--r--recipes/openmoko-3rdparty/openmoko-gps_svn.bb42
2 files changed, 42 insertions, 33 deletions
diff --git a/recipes/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb b/recipes/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb
deleted file mode 100644
index bb906f5173..0000000000
--- a/recipes/openmoko-3rdparty/openmoko-gps_0.0.1+svnr9.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-#! /bin/sh
-#
-# Copyright Matthias Hentges <devel@hentges.net> (c) 2008
-# License: MIT (see http://www.opensource.org/licenses/mit-license.php
-# for a copy of the license)
-#
-# Filename: openmoko-gps_svn.bb
-# Date: 20080101 (YMD)
-
-DESCRIPTION = "A tiny GPS output parser for the Openmoko platform."
-HOMEPAGE = "http://forge.bearstech.com/trac/wiki/OpenmokoGPS"
-SECTION = "base"
-LICENSE = "GPL"
-
-RDEPENDS_${PN} = "python-pygtk"
-
-PR = "r1"
-
-######################################################################################
-
-SRC_URI = "svn://forge.bearstech.com/forge/openmoko;module=gps;rev=9"
-
-S = "${WORKDIR}/gps"
-
-do_install() {
- install -d ${D}/usr/bin
- install -d ${D}/usr/share/applications/
- install -d ${D}/usr/share/pixmaps/
-
- install -m 0755 ${S}/gps_reader.py ${D}/usr/bin
- install -m 0644 ${S}/openmoko-gps.desktop ${D}/usr/share/applications/
- install -m 0644 ${S}/*.png ${D}/usr/share/pixmaps/
-}
diff --git a/recipes/openmoko-3rdparty/openmoko-gps_svn.bb b/recipes/openmoko-3rdparty/openmoko-gps_svn.bb
new file mode 100644
index 0000000000..47b1fbf9d7
--- /dev/null
+++ b/recipes/openmoko-3rdparty/openmoko-gps_svn.bb
@@ -0,0 +1,42 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2008
+# License: MIT (see http://www.opensource.org/licenses/mit-license.php
+# for a copy of the license)
+#
+# Filename: openmoko-gps_svn.bb
+# Date: 20080101 (YMD)
+
+DESCRIPTION = "A tiny GPS output parser for the Openmoko platform."
+HOMEPAGE = "http://forge.bearstech.com/trac/wiki/OpenmokoGPS"
+SECTION = "base"
+LICENSE = "GPL"
+
+RDEPENDS_${PN} = "python-pygtk"
+
+SRCREV = "12"
+PV = "0.0.1+svnr${SRCPV}"
+PR = "r2"
+
+######################################################################################
+
+SRC_URI = "svn://forge.bearstech.com/forge/openmoko;module=gps"
+
+S = "${WORKDIR}/gps"
+
+do_compile() {
+ # fix hardcoded path
+ sed -i "s#/usr/bin/python#env python#g" gps_reader.py
+ # fix QA issues
+ sed -i "/^Encoding/d; /^SingleInstance/d; s/Categories=GTK;Application;Utilities;/Categories=Utility;/g" openmoko-gps.desktop
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -d ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps/
+
+ install -m 0755 ${S}/gps_reader.py ${D}${bindir}/
+ install -m 0644 ${S}/openmoko-gps.desktop ${D}${datadir}/applications/
+ install -m 0644 ${S}/*.png ${D}${datadir}/pixmaps/
+}