aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <clarson@mvista.com>2009-05-21 16:32:41 -0700
committerChris Larson <clarson@mvista.com>2009-12-16 11:18:36 -0700
commit05019cad32a0ebc0b44a0fbe48c27320417b760d (patch)
tree7aaa88b67d236a66784c8e8d95c1ca6df63bfd31
parentbedc7cb2e83bcfde2cf28ff5774d7f4829d8f0bd (diff)
downloadopenembedded-05019cad32a0ebc0b44a0fbe48c27320417b760d.tar.gz
coreutils: don't patch the autotools files in the native recipes
If we patch autotools files in the native recipes and build them, the make results in the make rules trying to rerun autoconf, automake, aclocal, etc, and those don't yet exist when coreutils-native is built. So we split out the common target (not native) specific bits so that native recipes aren't including the target recipes, so we can avoid applying those patches for native. This also avoids some duplication of target bits between the versions. Signed-off-by: Chris Larson <clarson@mvista.com>
-rw-r--r--recipes/coreutils/coreutils-6.0.inc7
-rw-r--r--recipes/coreutils/coreutils-7.1.inc6
-rw-r--r--recipes/coreutils/coreutils-7.2.inc4
-rw-r--r--recipes/coreutils/coreutils-native_6.0.bb7
-rw-r--r--recipes/coreutils/coreutils-native_7.1.bb7
-rw-r--r--recipes/coreutils/coreutils-native_7.2.bb7
-rw-r--r--recipes/coreutils/coreutils-target.inc82
-rw-r--r--recipes/coreutils/coreutils_6.0.bb86
-rw-r--r--recipes/coreutils/coreutils_7.1.bb95
-rw-r--r--recipes/coreutils/coreutils_7.2.bb92
10 files changed, 121 insertions, 272 deletions
diff --git a/recipes/coreutils/coreutils-6.0.inc b/recipes/coreutils/coreutils-6.0.inc
new file mode 100644
index 0000000000..0dd2512021
--- /dev/null
+++ b/recipes/coreutils/coreutils-6.0.inc
@@ -0,0 +1,7 @@
+require coreutils.inc
+
+SRC_URI = "\
+ ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
+ file://futimens.patch;patch=1 \
+ file://coreutils-install-use-STRIP.patch;patch=1 \
+"
diff --git a/recipes/coreutils/coreutils-7.1.inc b/recipes/coreutils/coreutils-7.1.inc
new file mode 100644
index 0000000000..7f77b9b1ca
--- /dev/null
+++ b/recipes/coreutils/coreutils-7.1.inc
@@ -0,0 +1,6 @@
+require coreutils.inc
+
+SRC_URI = "ftp://ftp.gnu.org/gnu/coreutils/coreutils-${PV}.tar.gz"
+
+# not thoroughly tested yet
+DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/coreutils/coreutils-7.2.inc b/recipes/coreutils/coreutils-7.2.inc
new file mode 100644
index 0000000000..7ab42213c9
--- /dev/null
+++ b/recipes/coreutils/coreutils-7.2.inc
@@ -0,0 +1,4 @@
+require coreutils.inc
+
+SRC_URI = "ftp://ftp.gnu.org/gnu/coreutils/coreutils-${PV}.tar.gz \
+ file://coreutils-7.2-fix-sort-segfault.patch;patch=1"
diff --git a/recipes/coreutils/coreutils-native_6.0.bb b/recipes/coreutils/coreutils-native_6.0.bb
index a3754df123..800aacc568 100644
--- a/recipes/coreutils/coreutils-native_6.0.bb
+++ b/recipes/coreutils/coreutils-native_6.0.bb
@@ -1,5 +1,4 @@
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/coreutils-${PV}"
-S = "${WORKDIR}/coreutils-${PV}"
-
-require coreutils_${PV}.bb
+require coreutils-${PV}.inc
require coreutils-native.inc
+
+PR = "r4"
diff --git a/recipes/coreutils/coreutils-native_7.1.bb b/recipes/coreutils/coreutils-native_7.1.bb
index a3754df123..6370c04ef7 100644
--- a/recipes/coreutils/coreutils-native_7.1.bb
+++ b/recipes/coreutils/coreutils-native_7.1.bb
@@ -1,5 +1,4 @@
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/coreutils-${PV}"
-S = "${WORKDIR}/coreutils-${PV}"
-
-require coreutils_${PV}.bb
+require coreutils-${PV}.inc
require coreutils-native.inc
+
+PR = "r1"
diff --git a/recipes/coreutils/coreutils-native_7.2.bb b/recipes/coreutils/coreutils-native_7.2.bb
index a3754df123..6370c04ef7 100644
--- a/recipes/coreutils/coreutils-native_7.2.bb
+++ b/recipes/coreutils/coreutils-native_7.2.bb
@@ -1,5 +1,4 @@
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/coreutils-${PV}"
-S = "${WORKDIR}/coreutils-${PV}"
-
-require coreutils_${PV}.bb
+require coreutils-${PV}.inc
require coreutils-native.inc
+
+PR = "r1"
diff --git a/recipes/coreutils/coreutils-target.inc b/recipes/coreutils/coreutils-target.inc
new file mode 100644
index 0000000000..1dd1d369f3
--- /dev/null
+++ b/recipes/coreutils/coreutils-target.inc
@@ -0,0 +1,82 @@
+EXTRA_AUTORECONF += "-I ${S}/m4"
+SRC_URI += "file://onceonly.m4"
+
+# [ gets a special treatment and is not included in this
+bindir_progs = "basename cksum comm csplit cut df dir dircolors dirname du \
+ env expand expr factor fmt fold groups head hostid id install \
+ join link logname md5sum mkfifo nice nl nohup od paste pathchk \
+ pinky pr printenv printf ptx readlink seq sha1sum shred sort \
+ split stat sum tac tail tee test tr tsort tty unexpand uniq \
+ unlink users vdir wc who whoami yes \
+ "
+
+# hostname gets a special treatment and is not included in this
+base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill \
+ ln ls mkdir mknod mv pwd rm rmdir sleep stty sync touch \
+ true uname \
+ "
+
+sbindir_progs= "chroot"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/onceonly.m4 ${S}/m4
+}
+
+do_install () {
+ autotools_do_install
+
+ # Renaming the utilities that should go in /usr/bin
+ for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
+
+ # Renaming and moving the utilities that should go in /bin (FHS)
+ install -d ${D}${base_bindir}
+ for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
+
+ # Renaming and moving the utilities that should go in /usr/sbin (FHS)
+ install -d ${D}${sbindir}
+ for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
+
+ # [ requires special handling because [.coreutils will cause the sed stuff
+ # in update-alternatives to fail, therefore use lbracket - the name used
+ # for the actual source file.
+ mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
+ # hostname and uptime separated. busybox's versions are preferred
+ if [ -e ${D}${bindir}/hostname ]; then
+ mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
+ fi
+ if [ -e ${D}${bindir}/uptime ]; then
+ mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
+ fi
+}
+
+pkg_postinst_${PN} () {
+ # The utilities in /usr/bin
+ for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
+
+ # The utilities in /bin
+ for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
+
+ # The utilities in /usr/sbin
+ for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
+
+ # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
+ update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 10
+ update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
+ update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
+}
+
+pkg_prerm_${PN} () {
+ # The utilities in /usr/bin
+ for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
+
+ # The utilities in /bin
+ for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
+
+ # The utilities in /usr/sbin
+ for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
+
+ # The special cases
+ update-alternatives --remove hostname hostname.${PN}
+ update-alternatives --remove uptime uptime.${PN}
+ update-alternatives --remove '[' 'lbracket.${PN}'
+}
diff --git a/recipes/coreutils/coreutils_6.0.bb b/recipes/coreutils/coreutils_6.0.bb
index d0d082bc63..009dad34cf 100644
--- a/recipes/coreutils/coreutils_6.0.bb
+++ b/recipes/coreutils/coreutils_6.0.bb
@@ -1,89 +1,9 @@
-require coreutils.inc
+require coreutils-${PV}.inc
+require coreutils-target.inc
PR = "r3"
-SRC_URI = "\
- ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
+SRC_URI += "\
file://man.patch;patch=1 \
file://oe-old-tools.patch;patch=1 \
- file://futimens.patch;patch=1 \
- file://coreutils-install-use-STRIP.patch;patch=1 \
- file://onceonly.m4 \
"
-
-# [ gets a special treatment and is not included in this
-bindir_progs = "basename cksum comm csplit cut df dir dircolors dirname du \
- env expand expr factor fmt fold groups head hostid id install \
- join link logname md5sum mkfifo nice nl nohup od paste pathchk \
- pinky pr printenv printf ptx readlink seq sha1sum shred sort \
- split stat sum tac tail tee test tr tsort tty unexpand uniq \
- unlink users vdir wc who whoami yes \
- "
-
-# hostname gets a special treatment and is not included in this
-base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill \
- ln ls mkdir mknod mv pwd rm rmdir sleep stty sync touch \
- true uname \
- "
-
-sbindir_progs= "chroot"
-
-do_configure_prepend() {
- install -m 0644 ${WORKDIR}/onceonly.m4 ${S}/m4
-}
-
-do_install () {
- autotools_do_install
-
- # Renaming the utilities that should go in /usr/bin
- for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
-
- # Renaming and moving the utilities that should go in /bin (FHS)
- install -d ${D}${base_bindir}
- for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
-
- # Renaming and moving the utilities that should go in /usr/sbin (FHS)
- install -d ${D}${sbindir}
- for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
-
- # [ requires special handling because [.coreutils will cause the sed stuff
- # in update-alternatives to fail, therefore use lbracket - the name used
- # for the actual source file.
- mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
- # hostname and uptime separated. busybox's versions are preferred
- mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
- mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
-
-}
-
-pkg_postinst_${PN} () {
- # The utilities in /usr/bin
- for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
-
- # The utilities in /bin
- for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
-
- # The utilities in /usr/sbin
- for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
-
- # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
- update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 10
- update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
- update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
-}
-
-pkg_prerm_${PN} () {
- # The utilities in /usr/bin
- for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The utilities in /bin
- for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The utilities in /usr/sbin
- for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The special cases
- update-alternatives --remove hostname hostname.${PN}
- update-alternatives --remove uptime uptime.${PN}
- update-alternatives --remove '[' 'lbracket.${PN}'
-}
diff --git a/recipes/coreutils/coreutils_7.1.bb b/recipes/coreutils/coreutils_7.1.bb
index 6488e11a79..18ee4e36e1 100644
--- a/recipes/coreutils/coreutils_7.1.bb
+++ b/recipes/coreutils/coreutils_7.1.bb
@@ -1,92 +1,7 @@
-require coreutils.inc
-PR = "r0"
+require coreutils-${PV}.inc
+require coreutils-target.inc
-# not thoroughly testes yet
-DEFAULT_PREFERENCE = "-1"
+PR = "r0.1"
-SRC_URI = "\
- ftp://ftp.gnu.org/gnu/coreutils/coreutils-${PV}.tar.gz \
- file://automake-version.patch;patch=1 \
- file://man.patch;patch=1 \
- file://onceonly.m4 \
-"
-
-# [ gets a special treatment and is not included in this
-bindir_progs = "basename cksum comm csplit cut df dir dircolors dirname du \
- env expand expr factor fmt fold groups head hostid id install \
- join link logname md5sum mkfifo nice nl nohup od paste pathchk \
- pinky pr printenv printf ptx readlink seq sha1sum shred sort \
- split stat sum tac tail tee test tr tsort tty unexpand uniq \
- unlink users vdir wc who whoami yes \
- "
-
-# hostname gets a special treatment and is not included in this
-base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill \
- ln ls mkdir mknod mv pwd rm rmdir sleep stty sync touch \
- true uname \
- "
-
-sbindir_progs= "chroot"
-
-do_configure_prepend() {
- install -m 0644 ${WORKDIR}/onceonly.m4 ${S}/m4
-}
-
-do_install () {
- autotools_do_install
-
- # Renaming the utilities that should go in /usr/bin
- for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
-
- # Renaming and moving the utilities that should go in /bin (FHS)
- install -d ${D}${base_bindir}
- for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
-
- # Renaming and moving the utilities that should go in /usr/sbin (FHS)
- install -d ${D}${sbindir}
- for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
-
- # [ requires special handling because [.coreutils will cause the sed stuff
- # in update-alternatives to fail, therefore use lbracket - the name used
- # for the actual source file.
- mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
- # hostname and uptime separated. busybox's versions are preferred
- if [ -e ${D}${bindir}/hostname ]; then
- mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
- fi
- if [ -e ${D}${bindir}/uptime ]; then
- mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
- fi
-}
-
-pkg_postinst_${PN} () {
- # The utilities in /usr/bin
- for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
-
- # The utilities in /bin
- for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
-
- # The utilities in /usr/sbin
- for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
-
- # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
- update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 10
- update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
- update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
-}
-
-pkg_prerm_${PN} () {
- # The utilities in /usr/bin
- for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The utilities in /bin
- for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The utilities in /usr/sbin
- for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The special cases
- update-alternatives --remove hostname hostname.${PN}
- update-alternatives --remove uptime uptime.${PN}
- update-alternatives --remove '[' 'lbracket.${PN}'
-}
+SRC_URI += "file://automake-version.patch;patch=1 \
+ file://man.patch;patch=1"
diff --git a/recipes/coreutils/coreutils_7.2.bb b/recipes/coreutils/coreutils_7.2.bb
index f80921a288..46333be148 100644
--- a/recipes/coreutils/coreutils_7.2.bb
+++ b/recipes/coreutils/coreutils_7.2.bb
@@ -1,89 +1,7 @@
-require coreutils.inc
+require coreutils-${PV}.inc
+require coreutils-target.inc
-SRC_URI = "\
- ftp://ftp.gnu.org/gnu/coreutils/coreutils-${PV}.tar.gz \
- file://automake-version.patch;patch=1 \
- file://man.patch;patch=1 \
- file://coreutils-7.2-fix-sort-segfault.patch;patch=1 \
- file://onceonly.m4 \
-"
+PR = "r0"
-# [ gets a special treatment and is not included in this
-bindir_progs = "basename cksum comm csplit cut df dir dircolors dirname du \
- env expand expr factor fmt fold groups head hostid id install \
- join link logname md5sum mkfifo nice nl nohup od paste pathchk \
- pinky pr printenv printf ptx readlink seq sha1sum shred sort \
- split stat sum tac tail tee test tr tsort tty unexpand uniq \
- unlink users vdir wc who whoami yes \
- "
-
-# hostname gets a special treatment and is not included in this
-base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill \
- ln ls mkdir mknod mv pwd rm rmdir sleep stty sync touch \
- true uname \
- "
-
-sbindir_progs= "chroot"
-
-do_configure_prepend() {
- install -m 0644 ${WORKDIR}/onceonly.m4 ${S}/m4
-}
-
-do_install () {
- autotools_do_install
-
- # Renaming the utilities that should go in /usr/bin
- for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
-
- # Renaming and moving the utilities that should go in /bin (FHS)
- install -d ${D}${base_bindir}
- for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
-
- # Renaming and moving the utilities that should go in /usr/sbin (FHS)
- install -d ${D}${sbindir}
- for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
-
- # [ requires special handling because [.coreutils will cause the sed stuff
- # in update-alternatives to fail, therefore use lbracket - the name used
- # for the actual source file.
- mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
- # hostname and uptime separated. busybox's versions are preferred
- if [ -e ${D}${bindir}/hostname ]; then
- mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
- fi
- if [ -e ${D}${bindir}/uptime ]; then
- mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
- fi
-}
-
-pkg_postinst_${PN} () {
- # The utilities in /usr/bin
- for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
-
- # The utilities in /bin
- for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
-
- # The utilities in /usr/sbin
- for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
-
- # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
- update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 10
- update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
- update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
-}
-
-pkg_prerm_${PN} () {
- # The utilities in /usr/bin
- for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The utilities in /bin
- for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The utilities in /usr/sbin
- for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
-
- # The special cases
- update-alternatives --remove hostname hostname.${PN}
- update-alternatives --remove uptime uptime.${PN}
- update-alternatives --remove '[' 'lbracket.${PN}'
-}
+SRC_URI += "file://automake-version.patch;patch=1 \
+ file://man.patch;patch=1"