aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-05-26 14:51:33 +0100
committerKoen Kooi <koen@openembedded.org>2010-05-28 09:21:13 +0200
commit88d514d4b61c65dd81420a98074f2f5fec3ac168 (patch)
treef6b3700a7c69565f8304babc1a4edd2ab15b23a2
parent2b363197c06f9c61fb924bee40bc83b533cac01b (diff)
downloadopenembedded-88d514d4b61c65dd81420a98074f2f5fec3ac168.tar.gz
x-load: Install MLO_BINARY in /boot
* Install MLO inside target /boot for bootfile consistency * Bump PR Acked-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/x-load/x-load.inc14
-rw-r--r--recipes/x-load/x-load_git.bb2
2 files changed, 13 insertions, 3 deletions
diff --git a/recipes/x-load/x-load.inc b/recipes/x-load/x-load.inc
index a340958d7e..0699c011ab 100644
--- a/recipes/x-load/x-load.inc
+++ b/recipes/x-load/x-load.inc
@@ -17,6 +17,7 @@ XLOAD_USB_IMAGE ?= "x-load-usb-${MACHINE}-${PV}-${PR}.bin"
XLOAD_USB_SYMLINK ?= "x-load-usb-${MACHINE}.bin"
MLO_IMAGE ?= "MLO-${MACHINE}-${PV}-${PR}"
MLO_SYMLINK ?= "MLO-${MACHINE}"
+MLO_SYMLINK_NOMACHINE ?= "MLO"
do_compile () {
unset LDFLAGS
@@ -27,8 +28,17 @@ do_compile () {
oe_runmake
}
-do_deploy () {
+do_install () {
signGP ${S}/x-load.bin
+
+ install -d ${D}/boot
+ install ${S}/x-load.bin.ift ${D}/boot/${MLO_IMAGE}
+ ln -sf ${MLO_IMAGE} ${D}/boot/${MLO_SYMLINK_NOMACHINE}
+}
+
+FILES_${PN} = "/boot"
+
+do_deploy () {
install -d ${DEPLOY_DIR_IMAGE}
install ${S}/x-load.bin.ift ${DEPLOY_DIR_IMAGE}/${XLOAD_IMAGE}
install ${S}/x-load.bin ${DEPLOY_DIR_IMAGE}/${XLOAD_USB_IMAGE}
@@ -49,4 +59,4 @@ do_deploy () {
package_stagefile_shell ${DEPLOY_DIR_IMAGE}/${MLO_SYMLINK}
}
do_deploy[dirs] = "${S}"
-addtask deploy before do_build after do_compile
+addtask deploy before do_build after do_install
diff --git a/recipes/x-load/x-load_git.bb b/recipes/x-load/x-load_git.bb
index d40e094916..c0e7af3a53 100644
--- a/recipes/x-load/x-load_git.bb
+++ b/recipes/x-load/x-load_git.bb
@@ -10,7 +10,7 @@ SRCREV_beagleboard = "1c9276af4d6a5b7014a7630a1abeddf3b3177563"
PV = "1.42+${PR}+gitr${SRCREV}"
PV_beagleboard = "1.44+${PR}+gitr${SRCREV}"
-PR ="r10"
+PR ="r11"
PE = "1"
SRC_URI = "git://gitorious.org/x-load-omap3/mainline.git;branch=master;protocol=git"