aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@buglabs.net>2009-07-02 05:43:49 +0000
committerMarcin Juszkiewicz <marcin@buglabs.net>2009-11-02 17:10:52 +0100
commit011d932ac8abc72dec68bb679738f700d562b34f (patch)
treea4c65dd4f7cb1c9e57b1f05056b3c55fc1bdddc2
parent7d8346ea044df5d1ed515e83ad5ed3e42da0bb6b (diff)
downloadopenembedded-011d932ac8abc72dec68bb679738f700d562b34f.tar.gz
classpath: depend on gmp (for libjavamath) and do not use system one
Signed-off-by: Marcin Juszkiewicz <marcin@buglabs.net> Acked-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/classpath/classpath.inc2
-rw-r--r--recipes/classpath/classpath_0.98.bb3
-rw-r--r--recipes/classpath/files/fix-gmp.patch19
3 files changed, 22 insertions, 2 deletions
diff --git a/recipes/classpath/classpath.inc b/recipes/classpath/classpath.inc
index da3273bc97..bf630bf569 100644
--- a/recipes/classpath/classpath.inc
+++ b/recipes/classpath/classpath.inc
@@ -5,7 +5,7 @@ PRIORITY = "optional"
LICENSE = "Classpath"
PBN = "classpath"
-DEPENDS = "virtual/javac-native fastjar-native zip-native"
+DEPENDS = "virtual/javac-native fastjar-native zip-native gmp"
RPROVIDES = ""
RDEPENDS_${PN} = "${PBN}-common (>= ${PV})"
diff --git a/recipes/classpath/classpath_0.98.bb b/recipes/classpath/classpath_0.98.bb
index 292c49ff1a..13f7a72b44 100644
--- a/recipes/classpath/classpath_0.98.bb
+++ b/recipes/classpath/classpath_0.98.bb
@@ -4,9 +4,10 @@ SRC_URI += "\
file://SimpleName.diff;patch=1;pnum=0 \
file://ecj_java_dir.patch;patch=1 \
file://autotools.patch;patch=1 \
+ file://fix-gmp.patch;patch=1 \
"
-PR = "r0"
+PR = "r1"
DEPENDS += "gtk+ gconf libxtst"
diff --git a/recipes/classpath/files/fix-gmp.patch b/recipes/classpath/files/fix-gmp.patch
new file mode 100644
index 0000000000..3f0dfbe084
--- /dev/null
+++ b/recipes/classpath/files/fix-gmp.patch
@@ -0,0 +1,19 @@
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- classpath-0.98.orig/configure.ac
++++ classpath-0.98/configure.ac
+@@ -766,11 +766,11 @@ if test "x${COMPILE_JNI}" = xyes; then
+ dnl __gmpz_mul_si for earlier versions (>= 3.1).
+ dnl IMPORTANT: if you decide to look for __gmpz_combit, don't forget to
+ dnl change the name of the corresponding ac_ variable on lines 860...
+ if test "x${COMPILE_GMP}" = xyes; then
+ AC_CHECK_LIB(gmp, __gmpz_mul_si,
+- [GMP_CFLAGS=-I/usr/include
++ [GMP_CFLAGS=
+ GMP_LIBS=-lgmp ],
+ [GMP_CFLAGS=
+ GMP_LIBS= ])
+ AC_SUBST(GMP_CFLAGS)
+ AC_SUBST(GMP_LIBS)