aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <h.heinold@tarent.de>2010-07-12 15:34:11 +0200
committerHenning Heinold <h.heinold@tarent.de>2010-07-26 15:35:20 +0200
commit8bd0b4ed5485c532e6ea4e6f23a207d3a2d66ade (patch)
tree03496a5df01c3c19edc153b8c307746cc16215df
parent6ba36b085f47d1a8dc76f344ec6d7b21faf88f88 (diff)
downloadopenembedded-8bd0b4ed5485c532e6ea4e6f23a207d3a2d66ade.tar.gz
xml-commons: backport from openembedded-dev
* checksums already in conf/checksums.ini Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
-rw-r--r--recipes/xml-commons/jaxp1.3-native_1.3.04.bb4
-rw-r--r--recipes/xml-commons/jaxp1.3_1.3.04.bb24
-rw-r--r--recipes/xml-commons/xml-commons-resolver1.1-native_1.2.bb6
-rw-r--r--recipes/xml-commons/xml-commons-resolver1.1_1.2.bb35
4 files changed, 69 insertions, 0 deletions
diff --git a/recipes/xml-commons/jaxp1.3-native_1.3.04.bb b/recipes/xml-commons/jaxp1.3-native_1.3.04.bb
new file mode 100644
index 0000000000..ae94b80140
--- /dev/null
+++ b/recipes/xml-commons/jaxp1.3-native_1.3.04.bb
@@ -0,0 +1,4 @@
+require jaxp1.3_${PV}.bb
+
+inherit java-native
+
diff --git a/recipes/xml-commons/jaxp1.3_1.3.04.bb b/recipes/xml-commons/jaxp1.3_1.3.04.bb
new file mode 100644
index 0000000000..f66ae574fa
--- /dev/null
+++ b/recipes/xml-commons/jaxp1.3_1.3.04.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Java XML parser and transformer APIs (DOM, SAX, JAXP, TrAX)"
+LICENSES = "AL2.0 W3C Public Domain"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://archive.apache.org/dist/xml/commons/source/xml-commons-external-${PV}-src.tar.gz"
+
+inherit java-library
+
+S = "${WORKDIR}"
+
+DEPENDS = "fastjar-native"
+
+JARFILENAME = "jaxp-1.3.jar"
+ALTJARFILENAMES = "xml-apis.jar"
+
+do_compile() {
+ mkdir -p build/license
+ javac -d build `find javax org -name \*.java`
+
+ cp LICENSE.*.txt README.*.txt build/license
+
+ fastjar -c -m manifest.commons -f ${JARFILENAME} -C build .
+}
+
diff --git a/recipes/xml-commons/xml-commons-resolver1.1-native_1.2.bb b/recipes/xml-commons/xml-commons-resolver1.1-native_1.2.bb
new file mode 100644
index 0000000000..382be4373d
--- /dev/null
+++ b/recipes/xml-commons/xml-commons-resolver1.1-native_1.2.bb
@@ -0,0 +1,6 @@
+require xml-commons-resolver1.1_${PV}.bb
+
+inherit java-native
+
+DEPENDS = "fastjar-native jaxp1.3-native"
+
diff --git a/recipes/xml-commons/xml-commons-resolver1.1_1.2.bb b/recipes/xml-commons/xml-commons-resolver1.1_1.2.bb
new file mode 100644
index 0000000000..9059dba28a
--- /dev/null
+++ b/recipes/xml-commons/xml-commons-resolver1.1_1.2.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Library to resolve various public or system identifiers into accessible URLs (Java)"
+LICENSES = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://archive.apache.org/dist/xml/commons/xml-commons-resolver-${PV}.tar.gz"
+
+inherit java-library
+
+S = "${WORKDIR}/xml-commons-resolver-${PV}"
+
+DEPENDS = "fastjar-native jaxp1.3"
+
+do_unpackpost() {
+ find src -exec \
+ sed -i -e "s|@impl.name@|XmlResolver|" \
+ -e "s|@impl.version@|1.2|" {} \;
+}
+
+addtask unpackpost after do_unpack before do_patch
+
+JARFILENAME = "resolver.jar"
+ALTJARFILENAMES = ""
+
+do_compile() {
+ mkdir -p build
+
+ cp=${STAGING_DATADIR_JAVA}/jaxp1.3.jar
+
+ javac -sourcepath src -d build -classpath $cp `find src -name "*.java" -and -not -wholename "*tests*"`
+
+ (cd src && find org -name "*.xml" -o -name "*.txt" -o -name "*.src" -exec cp {} ../build/{} \;)
+
+ fastjar -C build -c -m src/manifest.resolver -f ${JARFILENAME} org
+}
+