aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <h.heinold@tarent.de>2010-07-12 14:33:32 +0200
committerHenning Heinold <h.heinold@tarent.de>2010-07-26 15:34:20 +0200
commitd220e474d4a3619a876ba9f1d393ece8d3567e53 (patch)
tree0c7a7665b16d35c932dc2bba12a8121d3071b00f
parent63fe962867e2017d18a333d7306ba64ef6a62dee (diff)
downloadopenembedded-d220e474d4a3619a876ba9f1d393ece8d3567e53.tar.gz
bcel: backport from openembedded-dev
* checksum already in conf/checksums.ini Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
-rw-r--r--recipes/bcel/bcel-native_5.2.bb6
-rw-r--r--recipes/bcel/bcel_5.2.bb19
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes/bcel/bcel-native_5.2.bb b/recipes/bcel/bcel-native_5.2.bb
new file mode 100644
index 0000000000..478b770bff
--- /dev/null
+++ b/recipes/bcel/bcel-native_5.2.bb
@@ -0,0 +1,6 @@
+require bcel_${PV}.bb
+
+inherit java-native
+
+DEPENDS = "fastjar-native xerces-j-native regexp-native"
+
diff --git a/recipes/bcel/bcel_5.2.bb b/recipes/bcel/bcel_5.2.bb
new file mode 100644
index 0000000000..faf6043c00
--- /dev/null
+++ b/recipes/bcel/bcel_5.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Java Bytecode manipulation library"
+LICENSE = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://archive.apache.org/dist/jakarta/bcel/source/${BP}-src.tar.gz"
+
+inherit java-library
+
+DEPENDS = "fastjar-native xerces-j regexp"
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s xercesImpl regexp
+
+ javac -sourcepath src/java -d build -cp $cp `find src/java -name \*.java`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}