aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-17 22:08:07 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-17 23:15:18 +0100
commit61243cb8af1b2667e5c856bf2eba09fe3b12805d (patch)
treeb328f5f6048d5b5d2da6e9b76fc3c9499b63a64b
parent27843e9fca3ce747abc3b6621f5277dbdf5b8eb5 (diff)
downloadopenembedded-61243cb8af1b2667e5c856bf2eba09fe3b12805d.tar.gz
sip-native: promote 4.7.7 as default, 4.7.8 is incompatible w/ PyQt 4.4.3 *sigh*
-rw-r--r--packages/sip/sip-native_4.7.7.bb30
-rw-r--r--packages/sip/sip-native_4.7.8.bb2
2 files changed, 32 insertions, 0 deletions
diff --git a/packages/sip/sip-native_4.7.7.bb b/packages/sip/sip-native_4.7.7.bb
new file mode 100644
index 0000000000..4fb4eba9e3
--- /dev/null
+++ b/packages/sip/sip-native_4.7.7.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "SIP is a C++/Python Wrapper Generator"
+SECTION = "devel"
+HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
+AUTHOR = "Phil Thompson"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "ml0"
+
+SRC_URI = "http://cvs.fedora.redhat.com/repo/pkgs/sip/sip-4.7.7.tar.gz/9cabe6a0f61b73582cfc38b903576211/sip-4.7.7.tar.gz"
+S = "${WORKDIR}/sip-${PV}/sipgen"
+
+inherit qt4x11 native
+
+export BUILD_SYS
+export HOST_SYS
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
+
+do_configure_prepend() {
+ cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
+}
+
+do_stage() {
+ install -m 0755 sip ${STAGING_BINDIR_NATIVE}/sip
+ cd ${WORKDIR}/sip-${PV} && python configure.py
+ install -d ${STAGING_PYDIR}/site-packages
+ install -m 0755 sip*.py ${STAGING_PYDIR}/site-packages
+}
diff --git a/packages/sip/sip-native_4.7.8.bb b/packages/sip/sip-native_4.7.8.bb
index eace44359d..127d26f389 100644
--- a/packages/sip/sip-native_4.7.8.bb
+++ b/packages/sip/sip-native_4.7.8.bb
@@ -6,6 +6,8 @@ PRIORITY = "optional"
LICENSE = "GPL"
PR = "ml0"
+DEFAULT_PREFERENCE = "-1"
+
SRC_URI = "http://www.riverbankcomputing.co.uk/static/Downloads/sip4/sip-${PV}.tar.gz"
S = "${WORKDIR}/sip-${PV}/sipgen"