aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2010-11-03 06:39:10 +0000
committerMichael Smith <msmith@cbnco.com>2010-11-04 11:37:02 -0400
commit57388be76e78c8718c2c0e57a7db13495b2b82b3 (patch)
tree789bac90c7acb76822e83376e57762a4a479d7a9
parent0ef914b250df46a41348479446214575668943fb (diff)
downloadopenembedded-57388be76e78c8718c2c0e57a7db13495b2b82b3.tar.gz
liboil 0.3.17: fix cross-compile on x86_64
Fix typo in whitelist of hosts allowing unaligned memory access. Signed-off-by: Michael Smith <msmith@cbnco.com>
-rw-r--r--recipes/liboil/liboil-0.3.17/fix-unaligned-whitelist.patch17
-rw-r--r--recipes/liboil/liboil_0.3.17.bb7
2 files changed, 22 insertions, 2 deletions
diff --git a/recipes/liboil/liboil-0.3.17/fix-unaligned-whitelist.patch b/recipes/liboil/liboil-0.3.17/fix-unaligned-whitelist.patch
new file mode 100644
index 0000000000..79d53b6e5d
--- /dev/null
+++ b/recipes/liboil/liboil-0.3.17/fix-unaligned-whitelist.patch
@@ -0,0 +1,17 @@
+Upstream: https://bugs.freedesktop.org/show_bug.cgi?id=31358
+
+configure: fix whitelisting of x86_64 unaligned memory access
+
+Fix typo in whitelist so cross-compile works for x86_64.
+
+--- liboil-0.3.17/m4/as-unaligned-access.m4.orig 2009-02-26 14:40:08.000000000 -0500
++++ liboil-0.3.17/m4/as-unaligned-access.m4 2010-11-03 12:19:55.000000000 -0400
+@@ -9,7 +9,7 @@
+ _AS_ECHO_N([(blacklisted) ])
+ as_cv_unaligned_access=no
+ ;;
+- i?86*|x86_64|amd64|powerpc*|m68k*|cris*)
++ i?86*|x86_64*|amd64*|powerpc*|m68k*|cris*)
+ _AS_ECHO_N([(whitelisted) ])
+ as_cv_unaligned_access=yes
+ ;;
diff --git a/recipes/liboil/liboil_0.3.17.bb b/recipes/liboil/liboil_0.3.17.bb
index 83cf4c1ec9..22678210e0 100644
--- a/recipes/liboil/liboil_0.3.17.bb
+++ b/recipes/liboil/liboil_0.3.17.bb
@@ -1,11 +1,14 @@
DESCRIPTION = "Liboil is a library of simple functions that are optimized for various CPUs."
HOMEPAGE = "http://liboil.freedesktop.org/"
LICENSE = "liboil"
-PR = "r0"
+PR = "r1"
DEPENDS = "glib-2.0"
-SRC_URI = "http://liboil.freedesktop.org/download/${P}.tar.gz"
+SRC_URI = " \
+ http://liboil.freedesktop.org/download/${P}.tar.gz \
+ file://fix-unaligned-whitelist.patch;apply=yes \
+"
inherit autotools pkgconfig