summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-11-11 08:16:23 -0700
committerTom Rini <tom_rini@mentor.com>2010-11-11 09:56:07 -0700
commit5c5d48e2a92610b64729f7fd24504bba3a5adc1c (patch)
treeacb4eefe557d82affe87050d3ee26914b2b4906f
parent13a0c4a2f19a68436f9fa9a493968c4c4a72621d (diff)
downloadopenembedded-5c5d48e2a92610b64729f7fd24504bba3a5adc1c.tar.gz
inetutils: Use fakeroot in do_install
rsh/related and traceroute will otherwise be usuable. Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/inetutils/inetutils_1.4.2.bb8
-rw-r--r--recipes/inetutils/inetutils_1.5.bb6
-rw-r--r--recipes/inetutils/inetutils_1.8.bb6
3 files changed, 12 insertions, 8 deletions
diff --git a/recipes/inetutils/inetutils_1.4.2.bb b/recipes/inetutils/inetutils_1.4.2.bb
index ec7934980b..37ff965838 100644
--- a/recipes/inetutils/inetutils_1.4.2.bb
+++ b/recipes/inetutils/inetutils_1.4.2.bb
@@ -1,12 +1,12 @@
SECTION = "libs"
-DEPENDS = "ncurses"
+DEPENDS = "ncurses fakeroot-native"
LICENSE = "GPL"
DESCRIPTION = "The GNU inetutils are a collection of common \
networking utilities and servers including ftp, ftpd, rcp, \
rexec, rlogin, rlogind, rsh, rshd, syslog, syslogd, talk, \
talkd, telnet, telnetd, tftp, tftpd, and uucpd."
-PR = "r1"
+PR = "r2"
SRC_URI = "${GNU_MIRROR}/inetutils/inetutils-${PV}.tar.gz \
file://configure.patch"
@@ -19,5 +19,9 @@ do_configure_prepend () {
rm -f ${S}/glob/configure*
}
+fakeroot do_install () {
+ autotools_do_install
+}
+
SRC_URI[md5sum] = "df0909a586ddac2b7a0d62795eea4206"
SRC_URI[sha256sum] = "9f001daa0f3d571ae35aac88f04d5dd982a14e90257e4dfb535c143fa18d5830"
diff --git a/recipes/inetutils/inetutils_1.5.bb b/recipes/inetutils/inetutils_1.5.bb
index f51c3b0144..dba140f3a8 100644
--- a/recipes/inetutils/inetutils_1.5.bb
+++ b/recipes/inetutils/inetutils_1.5.bb
@@ -1,12 +1,12 @@
SECTION = "libs"
-DEPENDS = "ncurses"
+DEPENDS = "ncurses fakeroot-native"
LICENSE = "GPL"
DESCRIPTION = "The GNU inetutils are a collection of common \
networking utilities and servers including ftp, ftpd, rcp, \
rexec, rlogin, rlogind, rsh, rshd, syslog, syslogd, talk, \
talkd, telnet, telnetd, tftp, tftpd, and uucpd."
-PR = "r6"
+PR = "r7"
SRC_URI = "${GNU_MIRROR}/inetutils/inetutils-${PV}.tar.gz \
"
@@ -20,7 +20,7 @@ do_configure_prepend () {
rm -f ${S}/glob/configure*
}
-do_install () {
+fakeroot do_install () {
autotools_do_install
install -d ${D}${base_sbindir} ${D}${base_bindir}
mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${PN}
diff --git a/recipes/inetutils/inetutils_1.8.bb b/recipes/inetutils/inetutils_1.8.bb
index 504bfdd6b1..1396c786c1 100644
--- a/recipes/inetutils/inetutils_1.8.bb
+++ b/recipes/inetutils/inetutils_1.8.bb
@@ -1,12 +1,12 @@
SECTION = "libs"
-DEPENDS = "ncurses"
+DEPENDS = "ncurses fakeroot-native"
LICENSE = "GPL"
DESCRIPTION = "The GNU inetutils are a collection of common \
networking utilities and servers including ftp, ftpd, rcp, \
rexec, rlogin, rlogind, rsh, rshd, syslog, syslogd, talk, \
talkd, telnet, telnetd, tftp, tftpd, and uucpd."
-PR = "r5"
+PR = "r6"
SRC_URI = "${GNU_MIRROR}/inetutils/inetutils-${PV}.tar.gz \
"
@@ -21,7 +21,7 @@ do_configure_prepend () {
rm -f ${S}/glob/configure*
}
-do_install () {
+fakeroot do_install () {
autotools_do_install
install -d ${D}${base_sbindir} ${D}${base_bindir}
mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${PN}