summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-12-29 23:52:31 +0300
committerRoman I Khimov <khimov@altell.ru>2010-12-30 21:00:55 +0300
commit3a75ce4f552d8d9fee1fc243e03ec107c311c646 (patch)
tree07aebefff87b874d9bbcbbee750af45703c439df
parent0d7150c3d30f1fed785d256509d8ebc99723920f (diff)
downloadopenembedded-3a75ce4f552d8d9fee1fc243e03ec107c311c646.tar.gz
perl 5.10.1: fix archlib(exp) and privlib(exp) vars in target configs
These vars can be used to derive build flags for perl modules and thus should point to build-time directories in staged configs. Signed-off-by: Roman I Khimov <khimov@altell.ru> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-rw-r--r--recipes/perl/perl_5.10.1.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index d8c374bb34..4e6bc331f5 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r18"
+PR = "r19"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -224,6 +224,13 @@ do_stage() {
install config.sh ${STAGING_LIBDIR}/perl/
# target configuration, used by native perl when cross-compiling
install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-${TARGET_SYS}.pl
+ sed -r -i \
+ -e "s,^(archlib=).*$,\1'${STAGING_LIBDIR}/perl/${PV}'," \
+ -e "s,^(archlibexp=).*$,\1'${STAGING_LIBDIR}/perl/${PV}'," \
+ -e "s,^(privlib=).*$,\1'${STAGING_DATADIR}/perl/${PV}'," \
+ -e "s,^(privlibexp=).*$,\1'${STAGING_DATADIR}/perl/${PV}'," \
+ ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-${TARGET_SYS}.pl \
+ ${STAGING_LIBDIR}/perl/config.sh
# target configuration
install lib/Config.pm ${STAGING_LIBDIR}/perl/${PV}/
install lib/ExtUtils/typemap ${STAGING_DATADIR}/perl/${PV}/ExtUtils/