summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-12-26 13:31:05 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-12-26 13:31:05 +0100
commit433bba9cbf07772cd548fcfa7e37d477e9fc301a (patch)
tree325e31e19fe27650a4d8e71d3cc3ee3c9c499db4
parent4c8bba5e963ede7f1cfac21af8f0a73b62b9e728 (diff)
parente2d3fd9d5518371366510c9f3115958e0d4d35db (diff)
downloadopenembedded-433bba9cbf07772cd548fcfa7e37d477e9fc301a.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
-rw-r--r--conf/distro/include/slugos.inc6
-rw-r--r--conf/distro/minimal.conf11
-rw-r--r--recipes/qextserialport/qextserialport-e_hg.bb4
-rw-r--r--recipes/qextserialport/qextserialport.inc18
-rw-r--r--recipes/qextserialport/qextserialport_hg.bb4
-rw-r--r--recipes/qmake/qmake2.inc2
-rw-r--r--recipes/qmake/qmake2_2.10a.bb2
-rw-r--r--recipes/sip/sip-native_4.12.bb36
-rw-r--r--recipes/tasks/task-slugos-toolchain-target.bb8
-rw-r--r--recipes/vim/vim_7.2.bb4
-rw-r--r--recipes/xmlrpc-c/xmlrpc-c-1.06.41/lib-path.patch58
-rw-r--r--recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb21
12 files changed, 158 insertions, 16 deletions
diff --git a/conf/distro/include/slugos.inc b/conf/distro/include/slugos.inc
index c2a380dcd2..bbfd907768 100644
--- a/conf/distro/include/slugos.inc
+++ b/conf/distro/include/slugos.inc
@@ -16,7 +16,7 @@
#TARGET_OS "linux" or "linux-uclibc"
# The following may be overridden to make sub-versions
-SLUGOS_VERSION = "5.5"
+SLUGOS_VERSION = "5.6"
DISTRO_REVISION ?= ""
DISTRO_VERSION ?= "${SLUGOS_VERSION}${DISTRO_REVISION}-${DISTRO_TYPE}"
# For release (only):
@@ -30,7 +30,9 @@ THUMB_INTERWORK = "yes"
# arm system and vice versa. It is strongly recommended that DISTROs not
# turn this off - the actual cost is very small.
# We want images supporting the following features (for task-base)
-DISTRO_FEATURES = "nfs smbfs wifi ppp alsa bluetooth ext2 vfat irda pcmcia usbgadget usbhost pci"
+DISTRO_FEATURES = "largefile ipv4 ipv6 nfs smbfs wifi ppp alsa bluetooth ext2 vfat irda pcmcia usbhost pci"
+# We may also wish to enable raid support at some point (space permitting)
+#DISTRO_FEATURES += " raid"
# Add thumb-interwork to feature list if selected machine supports it.
DISTRO_FEATURES += ' ${@["", "thumb-interwork"][bb.data.getVar('THUMB_INTERWORK', d, 1) == "yes"]}'
diff --git a/conf/distro/minimal.conf b/conf/distro/minimal.conf
index 5b92a3652b..c935080295 100644
--- a/conf/distro/minimal.conf
+++ b/conf/distro/minimal.conf
@@ -94,6 +94,17 @@ require conf/distro/include/sane-toolchain.inc
require conf/distro/include/arm-thumb.inc
#############################################################################
+# QA
+#############################################################################
+
+#run QA tests on builds and packages and log them
+INHERIT += "insane"
+QA_LOG = "1"
+
+#run QA tests on recipes
+INHERIT += "recipe_sanity"
+
+#############################################################################
# PREFERRED VERSIONS
#############################################################################
require conf/distro/include/preferred-e-versions.inc
diff --git a/recipes/qextserialport/qextserialport-e_hg.bb b/recipes/qextserialport/qextserialport-e_hg.bb
new file mode 100644
index 0000000000..f106ebd2a8
--- /dev/null
+++ b/recipes/qextserialport/qextserialport-e_hg.bb
@@ -0,0 +1,4 @@
+inherit qt4e
+
+require qextserialport.inc
+
diff --git a/recipes/qextserialport/qextserialport.inc b/recipes/qextserialport/qextserialport.inc
new file mode 100644
index 0000000000..db82de3bf5
--- /dev/null
+++ b/recipes/qextserialport/qextserialport.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Serial Port Library for Qt"
+SECTION = "libs"
+PRIORITY = "optional"
+
+PV = "0.0+${PR}+hg${SRCREV}"
+PR = "r0"
+
+SRCREV = "default"
+SRC_URI = "hg://qextserialport.googlecode.com/hg;rev=${SRCREV};module=qextserialport;proto=https"
+
+S = "${WORKDIR}/qextserialport"
+
+do_install() {
+ install -d ${D}${libdir} \
+ ${D}${includedir}
+ oe_libinstall -so -C src/build libqextserialport ${D}${libdir}
+ cp -pPR src/*.h ${D}${includedir}
+}
diff --git a/recipes/qextserialport/qextserialport_hg.bb b/recipes/qextserialport/qextserialport_hg.bb
new file mode 100644
index 0000000000..3464131a09
--- /dev/null
+++ b/recipes/qextserialport/qextserialport_hg.bb
@@ -0,0 +1,4 @@
+inherit qt4x11
+
+require qextserialport.inc
+
diff --git a/recipes/qmake/qmake2.inc b/recipes/qmake/qmake2.inc
index 2e78a44281..f2631b5f7e 100644
--- a/recipes/qmake/qmake2.inc
+++ b/recipes/qmake/qmake2.inc
@@ -3,7 +3,7 @@ PRIORITY = "optional"
HOMEPAGE = "http://www.trolltech.com"
SECTION = "devel"
LICENSE = "GPL"
-PR = "r11"
+PR = "r12"
# We call 'moc' during the build
DEPENDS = "qt4-tools-native"
diff --git a/recipes/qmake/qmake2_2.10a.bb b/recipes/qmake/qmake2_2.10a.bb
index d07f68baa5..77d909f8eb 100644
--- a/recipes/qmake/qmake2_2.10a.bb
+++ b/recipes/qmake/qmake2_2.10a.bb
@@ -18,6 +18,7 @@ do_install() {
touch $script
echo 'export QT_DIR_NAME=qtopia' >> $script
echo 'export QT_LIBINFIX=E' >> $script
+ echo 'export OE_QMAKE_AR=ar' >> $script
echo 'export OE_QMAKE_CC=gcc' >> $script
echo 'export OE_QMAKE_CXX=g++' >> $script
echo 'export OE_QMAKE_LINK=g++' >> $script
@@ -34,6 +35,7 @@ do_install() {
script="${D}/${datadir}/qt4/environment-setup"
touch $script
+ echo 'export OE_QMAKE_AR=ar' >> $script
echo 'export OE_QMAKE_CC=gcc' >> $script
echo 'export OE_QMAKE_CXX=g++' >> $script
echo 'export OE_QMAKE_LINK=g++' >> $script
diff --git a/recipes/sip/sip-native_4.12.bb b/recipes/sip/sip-native_4.12.bb
new file mode 100644
index 0000000000..47e870864b
--- /dev/null
+++ b/recipes/sip/sip-native_4.12.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "SIP is a C++/Python Wrapper Generator"
+AUTHOR = "Phil Thompson"
+HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.riverbankcomputing.co.uk/static/Downloads/sip4/sip-${PV}.tar.gz"
+SRC_URI[md5sum] = "8a0998fbaf34bdab2c15af3d4fa3bc0e"
+SRC_URI[sha256sum] = "9a0d24aec5328fd038be13f94de5c710b767caeb1dfd869e52c69d98b8656168"
+
+S = "${WORKDIR}/sip-${PV}/sipgen"
+
+inherit qt4x11 native python-dir
+
+EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
+
+export BUILD_SYS
+export HOST_SYS
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+do_configure_prepend() {
+ cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
+}
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 sip ${D}${bindir}/sip
+ cd ${WORKDIR}/sip-${PV} && python configure.py
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}
+ install -m 0755 sip*.py ${D}${PYTHON_SITEPACKAGES_DIR}
+}
+
+DEFAULT_PREFERENCE = "-1"
+NATIVE_INSTALL_WORKS = "1"
diff --git a/recipes/tasks/task-slugos-toolchain-target.bb b/recipes/tasks/task-slugos-toolchain-target.bb
index fb0418fe29..06b3b61e5f 100644
--- a/recipes/tasks/task-slugos-toolchain-target.bb
+++ b/recipes/tasks/task-slugos-toolchain-target.bb
@@ -2,19 +2,17 @@ DESCRIPTION = "Packages for a standalone SDK or external toolchain"
LICENSE = "MIT"
ALLOW_EMPTY = "1"
-PR = "r3"
+PR = "r3.2"
PACKAGES = "${PN}"
-DEPENDS = "task-sdk-bare"
-
# This is a starting point, and nothing more at present -- please fill
# this out with a reasonable set of development tools for a SlugOS image.
# Also feel free to remove stuff that's silly.
RDEPENDS_${PN} = "\
- task-sdk-bare \
- linux-libc-headers-dev \
+ eglibc eglibc-dbg eglibc-utils eglibc-dev eglibc-thread-db libsegfault \
+ libgcc libstdc++ libstdc++-dev \
libssl \
libcrypto \
openssl-dev \
diff --git a/recipes/vim/vim_7.2.bb b/recipes/vim/vim_7.2.bb
index 99a8e31fc1..6e1499197a 100644
--- a/recipes/vim/vim_7.2.bb
+++ b/recipes/vim/vim_7.2.bb
@@ -19,14 +19,12 @@ SRC_URI += "file://configure.in_remove_CC_quotes.patch;apply=no"
SRC_URI += "file://vimrc"
# we need to apply patches in other dir then ${S}
-do_applypatch() {
+do_patch() {
cd ${WORKDIR}/vim${VIMVER}
patch -p1 <${WORKDIR}/001-411.diff
patch -p1 <${WORKDIR}/configure.in_remove_CC_quotes.patch
}
-addtask applypatch after do_unpack before do_patch
-
do_install_append() {
install -m 0644 ${WORKDIR}/vimrc ${D}/${datadir}/vim
}
diff --git a/recipes/xmlrpc-c/xmlrpc-c-1.06.41/lib-path.patch b/recipes/xmlrpc-c/xmlrpc-c-1.06.41/lib-path.patch
new file mode 100644
index 0000000000..1ec148b749
--- /dev/null
+++ b/recipes/xmlrpc-c/xmlrpc-c-1.06.41/lib-path.patch
@@ -0,0 +1,58 @@
+Don't use build directories in the library search path because it apparently
+causes Libtool to hard-code the build directories inside installed .la files,
+triggering "QA issues". Use with newer Libtool.
+--- xmlrpc-c-1.06.41/src/Makefile
++++ xmlrpc-c-1.06.41/src/Makefile
+@@ -7,8 +7,8 @@ VPATH = .:$(SRCDIR)
+
+ include $(BUILDDIR)/Makefile.config
+
+-ABYSS_LIBDIR = $(BUILDDIR)/lib/abyss/src/.libs
+-LIBUTIL_LIBDIR = $(BUILDDIR)/lib/libutil/.libs
++ABYSS_LIB = $(BUILDDIR)/lib/abyss/src/libxmlrpc_abyss.la
++LIBUTIL_LIB = $(BUILDDIR)/lib/libutil/libxmlrpc_util.la
+
+ default: all
+
+@@ -70,17 +70,17 @@ endif
+ # may require the necessary -L options in addition.
+
+ LIBXMLRPC_CLIENT_OBJS = xmlrpc_client.lo xmlrpc_client_global.lo
+-LIBXMLRPC_CLIENT_LIBDEP = -lxmlrpc_util -lxmlrpc
++LIBXMLRPC_CLIENT_LIBDEP = $(LIBUTIL_LIB) libxmlrpc.la
+
+ LIBXMLRPC_SERVER_OBJS = registry.lo system_method.lo
+-LIBXMLRPC_SERVER_LIBDEP = -lxmlrpc_util -lxmlrpc
++LIBXMLRPC_SERVER_LIBDEP = $(LIBUTIL_LIB) libxmlrpc.la
+
+ LIBXMLRPC_SERVER_ABYSS_OBJS = xmlrpc_server_abyss.lo
+ LIBXMLRPC_SERVER_ABYSS_LIBDEP = \
+- -lxmlrpc_util -lxmlrpc_server -L$(ABYSS_LIBDIR) -lxmlrpc_abyss -lxmlrpc
++ $(LIBUTIL_LIB) libxmlrpc_server.la $(ABYSS_LIB) libxmlrpc.la
+
+ LIBXMLRPC_SERVER_CGI_OBJS = xmlrpc_server_cgi.lo
+-LIBXMLRPC_SERVER_CGI_LIBDEP = -lxmlrpc_util -lxmlrpc_server -lxmlrpc
++LIBXMLRPC_SERVER_CGI_LIBDEP = $(LIBUTIL_LIB) libxmlrpc_server.la libxmlrpc.la
+
+ LIBXMLRPC_OBJS = \
+ trace.lo \
+@@ -96,7 +96,7 @@ LIBXMLRPC_OBJS = \
+ xmlrpc_utf8.lo \
+ xmlrpc_authcookie.lo \
+
+-LIBXMLRPC_LIBDEP = -lxmlrpc_util $(LIBXML_LIBS)
++LIBXMLRPC_LIBDEP = $(LIBUTIL_LIB) $(LIBXML_LIBS)
+
+ LIB_OBJS = $(LIBXMLRPC_CLIENT_OBJS) $(LIBXMLRPC_SERVER_OBJS)
+
+@@ -133,9 +133,7 @@ all: $(TARGET_LTLIBRARIES) $(SUBDIRS:%=%
+
+ LDFLAGS = $(LADD)
+
+-LIBPATHS = -L.libs -L$(LIBUTIL_LIBDIR)
+-
+-LIBLDFLAGS = $(LDFLAGS_VERSINFO) -rpath $(LIBINST_DIR) $(LIBPATHS) $(LADD)
++LIBLDFLAGS = $(LDFLAGS_VERSINFO) -rpath $(LIBINST_DIR) $(LADD)
+
+
+ libxmlrpc.la: $(LIBXMLRPC_OBJS)
diff --git a/recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb b/recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb
index e9bbc312e8..3cd817920f 100644
--- a/recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb
+++ b/recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb
@@ -2,24 +2,35 @@ DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to h
write an XML-RPC server or client in C or C++."
LICENSE = "GPLv2+"
DEPENDS = "curl libxml2"
-PR = "r1"
-
+PR = "r2"
+LEAD_SONAME = "libxmlrpc.so.3"
# note: this is version 1.06.47
# there seems to be versions with higher numbers (e.g. 1.11.00)
# but these are actually not newer
EXTRA_OECONF = " --enable-libxml2-backend -disable-libwww-client"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
PARALLEL_MAKE = ""
inherit autotools binconfig
-do_configure () {
- gnu-configize
+do_configure() {
+ # no autoreconf please
+ aclocal
+ autoconf
+ libtoolize --force
+ gnu-configize --force
oe_runconf
}
+do_compile_prepend () {
+ (cd ${S}; ln -s ${HOST_SYS}-libtool libtool)
+}
-SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tgz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tgz \
+ file://lib-path.patch \
+"
SRC_URI[md5sum] = "02c6b89b8ff911341b6b6d4a6c621ea9"
SRC_URI[sha256sum] = "a13f5ef40ed75d89543b9cd086185121dead9fc7de850ca4d2edd9a0cec12205"