summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-12-27 14:33:06 +0100
committerKoen Kooi <koen@openembedded.org>2010-12-27 14:33:06 +0100
commitb54eb35090e34ac39cabc1774a62331e1507d34d (patch)
tree78e413757a8101377e020e035c343779d33971a8
parent767ff1b1f149800ec9d3a64380b06178587d9eb9 (diff)
downloadopenembedded-b54eb35090e34ac39cabc1774a62331e1507d34d.tar.gz
ti-c6accel: fixes and cleanups
* this makes c6accel really regenerate the needed files * doesn't pass -L/lib to the linker anymore Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/ti/ti-c6accel.inc18
1 files changed, 12 insertions, 6 deletions
diff --git a/recipes/ti/ti-c6accel.inc b/recipes/ti/ti-c6accel.inc
index 4d3d1949c7..21eaf33883 100644
--- a/recipes/ti/ti-c6accel.inc
+++ b/recipes/ti/ti-c6accel.inc
@@ -31,11 +31,7 @@ DEPENDS = "ti-codec-engine ti-xdais ti-dsplink ti-dspbios"
DEPENDS += "ti-edma3lld ti-cgt6x ti-xdctools ti-framework-components"
DEPENDS += "ti-biosutils"
-do_compile() {
- unset VERBOSE
- # Build C6Accel package
- cd ${S}
- make \
+TIARGS = ' \
PLATFORM="${PLATFORM}" \
CE_INSTALL_DIR="${CE_INSTALL_DIR}" \
XDAIS_INSTALL_DIR="${XDAIS_INSTALL_DIR}" \
@@ -52,8 +48,18 @@ do_compile() {
C6ACCEL_INSTALL_DIR="${S}" \
CSTOOL_DIR="${TOOLCHAIN_PATH}" \
CSTOOL_PREFIX="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}" \
- all
+ LINUXLIBS_INSTALL_DIR="${STAGING_DIR}/${BASE_PACKAGE_ARCH}${HOST_VENDOR}-${HOST_OS}" \
+'
+do_configure() {
+ unset VERBOSE
+ make ${TIARGS} clean
+ #sed -i -e 's:-L$(LINUXLIBS_INSTALL_DIR)/lib:${LDFLAGS}:' ${S}/soc/app/Makefile
+}
+
+do_compile() {
+ unset VERBOSE
+ make ${TIARGS} all
}
do_install() {