summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-11-23 13:26:55 +0300
committerRoman I Khimov <khimov@altell.ru>2010-12-28 22:50:54 +0300
commitcd0141bdbec23521022447fe87c82e10cb9a500e (patch)
treef882312b746dd59d7394ce7476812e17129b69d6
parent264f7ab1f41cc86d29716619d67506c85223df71 (diff)
downloadopenembedded-cd0141bdbec23521022447fe87c82e10cb9a500e.tar.gz
perl 5.10.1: fix Time::HiRes cross-compilation
We can't do 'run' check, so let's hope compile check is enough. Fixes Time::HiRes::nanosleep(): unimplemented in this platform error. Signed-off-by: Roman I Khimov <khimov@altell.ru> Acked-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/perl/perl-5.10.1/perl-time-hires-fix-cross-compilation.patch29
-rw-r--r--recipes/perl/perl_5.10.1.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/recipes/perl/perl-5.10.1/perl-time-hires-fix-cross-compilation.patch b/recipes/perl/perl-5.10.1/perl-time-hires-fix-cross-compilation.patch
new file mode 100644
index 0000000000..7c8b47e164
--- /dev/null
+++ b/recipes/perl/perl-5.10.1/perl-time-hires-fix-cross-compilation.patch
@@ -0,0 +1,29 @@
+Index: perl-5.10.1/ext/Time-HiRes/Makefile.PL
+===================================================================
+--- perl-5.10.1.orig/ext/Time-HiRes/Makefile.PL 2010-11-23 12:05:59.000000000 +0300
++++ perl-5.10.1/ext/Time-HiRes/Makefile.PL 2010-11-23 12:06:42.000000000 +0300
+@@ -157,24 +157,6 @@
+ my $res = system($cccmd);
+ $ok = defined($res) && $res == 0 && -s $tmp_exe && -x _;
+
+- if ( $ok && exists $args{run} && $args{run}) {
+- my $tmp_exe =
+- File::Spec->catfile(File::Spec->curdir, $tmp_exe);
+- printf "Running $tmp_exe..." if $VERBOSE;
+- if (system($tmp_exe) == 0) {
+- $ok = 1;
+- } else {
+- $ok = 0;
+- my $errno = $? >> 8;
+- local $! = $errno;
+- printf <<EOF;
+-
+-*** The test run of '$tmp_exe' failed: status $?
+-*** (the status means: errno = $errno or '$!')
+-*** DO NOT PANIC: this just means that *some* functionality will be missing.
+-EOF
+- }
+- }
+ unlink("$tmp.c", $tmp_exe);
+ }
+ }
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 387755e4da..0e6a1f933f 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r15"
+PR = "r16"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -62,6 +62,7 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz;name=perl-${PV} \
file://arm-alignment.diff \
file://fcgi-test.diff \
file://hurd-ccflags.diff \
+ file://perl-time-hires-fix-cross-compilation.patch \
\
file://Makefile.patch \
file://Makefile.SH.patch \