summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2011-01-12 09:16:05 -0700
committerChris Larson <chris_larson@mentor.com>2011-01-12 12:39:41 -0700
commit310773c9b0f9917a488bcd5e1a009150056556b7 (patch)
tree83831950bcb6bf351083e2c82b301c3808be32cb
parentd729d14d9bff474f41c0853086d89cf6b50f41ff (diff)
downloadopenembedded-310773c9b0f9917a488bcd5e1a009150056556b7.tar.gz
argp-standalone: build shared library also
This applies a patch from FreeBSD to use libtool to build both shared and static versions of libargp. Signed-off-by: Chris Larson <chris_larson@mentor.com>
-rw-r--r--recipes/argp-standalone/argp-standalone/libtool.patch56
-rw-r--r--recipes/argp-standalone/argp-standalone_1.3.bb6
2 files changed, 60 insertions, 2 deletions
diff --git a/recipes/argp-standalone/argp-standalone/libtool.patch b/recipes/argp-standalone/argp-standalone/libtool.patch
new file mode 100644
index 0000000000..c3498aa749
--- /dev/null
+++ b/recipes/argp-standalone/argp-standalone/libtool.patch
@@ -0,0 +1,56 @@
+---
+ Makefile.am | 10 +++++-----
+ configure.ac | 1 +
+ testsuite/Makefile.am | 2 +-
+ 3 files changed, 7 insertions(+), 6 deletions(-)
+
+--- argp-standalone-1.3.orig/configure.ac
++++ argp-standalone-1.3/configure.ac
+@@ -21,6 +21,7 @@ AC_PROG_CC
+ AC_PROG_MAKE_SET
+ AC_PROG_RANLIB
+ AM_PROG_CC_STDC
++AC_PROG_LIBTOOL
+
+ if test "x$am_cv_prog_cc_stdc" = xno ; then
+ AC_ERROR([the C compiler doesn't handle ANSI-C])
+--- argp-standalone-1.3.orig/Makefile.am
++++ argp-standalone-1.3/Makefile.am
+@@ -21,9 +21,9 @@
+ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = . testsuite
+
+-LIBOBJS = @LIBOBJS@
++LTLIBOBJS = @LTLIBOBJS@
+
+-lib_LIBRARIES = libargp.a
++lib_LTLIBRARIES = libargp.la
+
+ # argp-test needs random(), which is not available on windows.
+ EXTRA_PROGRAMS = argp-test
+@@ -33,11 +33,11 @@ include_HEADERS=argp.h
+ EXTRA_DIST = mempcpy.c strchrnul.c strndup.c strcasecmp.c vsnprintf.c Versions
+
+ # Leaves out argp-fs-xinl.c and argp-xinl.c
+-libargp_a_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
++libargp_la_SOURCES = argp-ba.c argp-eexst.c argp-fmtstream.c \
+ argp-help.c argp-parse.c argp-pv.c \
+ argp-pvh.c
+
+-libargp_a_LIBADD = $(LIBOBJS)
++libargp_la_LIBADD = $(LTLIBOBJS)
+
+-argp_test_LDADD = libargp.a
++argp_test_LDADD = libargp.la
+
+--- argp-standalone-1.3.orig/testsuite/Makefile.am
++++ argp-standalone-1.3/testsuite/Makefile.am
+@@ -7,7 +7,7 @@ TS_SH = ex1-test permute-test
+
+ TS_ALL = $(TS_PROGS) $(TS_SH)
+
+-LDADD = ../libargp.a
++LDADD = $(top_builddir)/libargp.la
+
+ EXTRA_DIST = $(TS_SH) run-tests
+ CLEANFILES = test.out
diff --git a/recipes/argp-standalone/argp-standalone_1.3.bb b/recipes/argp-standalone/argp-standalone_1.3.bb
index 79d219a98b..ba8d35642d 100644
--- a/recipes/argp-standalone/argp-standalone_1.3.bb
+++ b/recipes/argp-standalone/argp-standalone_1.3.bb
@@ -1,7 +1,9 @@
-DESCRIPTION = "Argp is an interface for parsing unix-style argument vectors. This is only needed for uclibc"
+DESCRIPTION = "A standalone version of argp, which is part of the GNU C Library."
PRIORITY = "optional"
+PR = "r1"
-SRC_URI = "http://www.auto.tuwien.ac.at/~mkoegler/eib/argp-standalone-${PV}.tar.gz"
+SRC_URI = "http://www.auto.tuwien.ac.at/~mkoegler/eib/argp-standalone-${PV}.tar.gz \
+ file://libtool.patch"
inherit autotools