aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2011-05-31 22:28:20 +0000
committerutx@penguin.cz <utx@penguin.cz>2011-05-31 22:40:19 +0000
commit7aa5d7991112dd14a0a81b6fe523ad62bb56ae58 (patch)
tree82be74847368f014cfdc9b2b44fff76458f71492
parentdbc1e12e03d23f2f02446aedf0dd9086bb438f41 (diff)
downloadopenembedded-7aa5d7991112dd14a0a81b6fe523ad62bb56ae58.tar.gz
lynx: New recipe, version 2.8.7.
Signed-off-by: Stanislav Brabec <utx@penguin.cz>
-rw-r--r--recipes/lynx/files/locale-charset.patch13
-rw-r--r--recipes/lynx/lynx_2.8.7.bb41
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes/lynx/files/locale-charset.patch b/recipes/lynx/files/locale-charset.patch
new file mode 100644
index 0000000000..7f1ffeeb2f
--- /dev/null
+++ b/recipes/lynx/files/locale-charset.patch
@@ -0,0 +1,13 @@
+Index: lynx2-8-7/lynx.cfg
+===================================================================
+--- lynx2-8-7.orig/lynx.cfg
++++ lynx2-8-7/lynx.cfg
+@@ -453,7 +453,7 @@ DEFAULT_INDEX_FILE:http://lynx.isc.org/
+ # happens to give useful values, but other implementations are not guaranteed
+ # to do this.
+ #LOCALE_CHARSET:FALSE
+-
++LOCALE_CHARSET:TRUE
+
+ .h2 ASSUME_CHARSET
+ # ASSUME_CHARSET changes the handling of documents which do not
diff --git a/recipes/lynx/lynx_2.8.7.bb b/recipes/lynx/lynx_2.8.7.bb
new file mode 100644
index 0000000000..022162c676
--- /dev/null
+++ b/recipes/lynx/lynx_2.8.7.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "text web browser"
+SECTION = "console/network"
+DEPENDS = "ncurses openssl"
+LICENSE = "GPL"
+HOMEPAGE = "http://lynx.isc.org/"
+PR = "r0"
+S = "${WORKDIR}/${PN}${@bb.data.getVar('PV',d,1).replace('.', '-')}"
+
+SRC_URI = "http://lynx.isc.org/${PN}${PV}/${PN}${PV}.tar.bz2 \
+ file://locale-charset.patch"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-ssl=${STAGING_DIR_HOST}${layout_exec_prefix} --with-curses-dir=${STAGING_DIR_HOST}${layout_exec_prefix} --enable-nls --with-screen=ncursesw --enable-locale-charset --enable-ipv6 --enable-persistent-cookies"
+
+do_configure() {
+ # prevent import of ncursesw6-config from host system
+ # only ncurses-config (version 5) is available in the tree
+ sed -i 's/}6/}6-does-not-exist-in-oe/g' aclocal.m4 configure
+ # configure.in cannot be easily rebuilt
+ oe_runconf\
+ ac_cv_path_TELNET=${bindir}/telnet\
+ ac_cv_path_TN3270=no\
+ ac_cv_path_RLOGIN=${bindir}/rlogin\
+ ac_cv_path_MV=/bin/mv\
+ ac_cv_path_GZIP=/bin/gzip\
+ ac_cv_path_UNCOMPRESS=/bin/gunzip\
+ ac_cv_path_UNZIP=${bindir}/unzip\
+ ac_cv_path_BZIP2=${bindir}/bzip2\
+ ac_cv_path_TAR=/bin/tar\
+ ac_cv_path_COMPRESS=no\
+ ac_cv_path_RM=/bin/rm\
+ ac_cv_path_UUDECODE=${bindir}/uudecode\
+ ac_cv_path_UUDECODE=${bindir}/uudecode\
+ ac_cv_path_ZCAT=/bin/zcat\
+ ac_cv_path_ZIP=${bindir}/zip\
+ ac_cv_path_INSTALL=${bindir}/install
+}
+
+SRC_URI[md5sum] = "cb936aef812e4e463ab86cbbe14d4db9"
+SRC_URI[sha256sum] = "301bda96ad3cd5032805e8d5315a42061a11e472e3d3a7baee3a2879517ef627"