aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2011-06-02 14:36:36 +0200
committerPaul Menzel <paulepanter@users.sourceforge.net>2011-06-02 15:13:20 +0200
commitc55a2839e10beee6baf587afebdbf9c490d41ea3 (patch)
tree04963f7559989a6b86948c6ae70178b83fb0bcac
parent5c8f30f1cb0de6f7b07a965e858da3bf625d5ba1 (diff)
downloadopenembedded-c55a2839e10beee6baf587afebdbf9c490d41ea3.tar.gz
lynx: inherit class `gettext` to fix build with `minimal-uclibc`
Task configure failed with the following error message using `minimal-uclibc` for `MACHINE = "beagleboard"`. checking for __argz_stringify... no checking for __argz_next... no checking for iconv... no, consider installing GNU libiconv checking for nl_langinfo and CODESET... yes checking for LC_MESSAGES... yes checking whether NLS is requested... yes checking whether included gettext is requested... no checking for libintl.h and gettext()... no configure: error: no NLS library is packaged with this application Inheriting the class `gettext` fixes this error and the build completes using `minimal-uclibc` for `MACHINE = "beagleboard"`. Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
-rw-r--r--recipes/lynx/lynx_2.8.7.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/lynx/lynx_2.8.7.bb b/recipes/lynx/lynx_2.8.7.bb
index b9b5407b49..f59dc9aa6f 100644
--- a/recipes/lynx/lynx_2.8.7.bb
+++ b/recipes/lynx/lynx_2.8.7.bb
@@ -11,9 +11,9 @@ S = "${WORKDIR}/${PN}${@bb.data.getVar('PV',d,1).replace('.', '-')}"
SRC_URI = "http://lynx.isc.org/current/${PN}${PV}rel.2.tar.bz2 \
file://locale-charset.patch"
-inherit autotools
+inherit autotools gettext
-EXTRA_OECONF = "--with-ssl=${STAGING_DIR_HOST}${layout_exec_prefix} --with-curses-dir=${STAGING_DIR_HOST}${layout_exec_prefix} --enable-nls --with-screen=ncursesw --enable-locale-charset --enable-ipv6 --enable-persistent-cookies"
+EXTRA_OECONF += "--with-ssl=${STAGING_DIR_HOST}${layout_exec_prefix} --with-curses-dir=${STAGING_DIR_HOST}${layout_exec_prefix} --enable-nls --with-screen=ncursesw --enable-locale-charset --enable-ipv6 --enable-persistent-cookies"
do_configure() {
# prevent import of ncursesw6-config from host system