summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-05-18 15:38:19 +0100
committerKoen Kooi <koen@openembedded.org>2010-05-19 11:30:02 +0200
commit05a44074d49142791b9421538ea526fe1329edd2 (patch)
tree4759a9bc77dad98ca7d9a5f33440fa15c6d14f3d
parent98ec975e54191774d896ef4f20e06c56df67f6cc (diff)
downloadopenembedded-05a44074d49142791b9421538ea526fe1329edd2.tar.gz
ti-msp430-chronos: Add initial recipe for msp430 chronos watch support
* This recipe downloads and unpacks installer and installs the tcl scripts for the Control Center tools * Currently installing into MACHINE ARCH, which could be moved later. Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/ti/ti-msp430-chronos_1.05.00.00.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/ti/ti-msp430-chronos_1.05.00.00.bb b/recipes/ti/ti-msp430-chronos_1.05.00.00.bb
new file mode 100644
index 0000000000..38812f067f
--- /dev/null
+++ b/recipes/ti/ti-msp430-chronos_1.05.00.00.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "eZ430 Chronos Tools - MSP430 Development Kit/Watch"
+HOMEPAGE = "http://processors.wiki.ti.com/index.php/EZ430-Chronos"
+SECTION = "multimedia"
+
+PV = "1_05_00_00"
+
+SRC_URI = "http://focus.ti.com/lit/sw/slac388/slac388.zip;name=slac388zip"
+
+SRC_URI[slac388zip.md5sum] = "22d4104a07af584222828fb377793796"
+SRC_URI[slac388zip.sha256sum] = "1c9cd1e36015e8db3b36c98be41907628144b76002b3f76b27fd310f4bd35ad7"
+
+require ti-paths.inc
+require ti-staging.inc
+require ti-eula-unpack.inc
+
+S = "${WORKDIR}/ti/eZ430-Chronos"
+
+BINFILE="Chronos-Setup"
+TI_BIN_UNPK_CMDS="Y:workdir:"
+
+do_unpack_append() {
+ os.system('mv "Texas Instruments" ti')
+}
+
+do_compile() {
+ echo "Do Nothing for Now"
+}
+
+do_install() {
+
+ install -d ${D}/${installdir}/ti-msp430-chronos-apps
+ cp -pPrf "${S}"/"Control Center"/* ${D}/${installdir}/ti-msp430-chronos-apps
+}
+
+PACKAGES += "ti-msp430-chronos-apps"
+FILES_ti-msp430-chronos-apps = "${installdir}/ti-msp430-chronos-apps/*"
+
+RDEPENDS_ti-msp430-chronos-apps += " tcl xdotool"
+