summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-10-23 11:42:39 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-10-23 11:42:39 +0200
commit1ec5d58130c4c76aa885a10f099b9bb32651a292 (patch)
tree4ca566d1d6f775a5002b5bf473c8a504e26bcd10
parent1258abe38ad6240a78c700f03f66a654c9cab2a9 (diff)
downloadopenembedded-1ec5d58130c4c76aa885a10f099b9bb32651a292.tar.gz
gcc-cross_csl-arm-2005q3: put into useable state again
* add some patches needed for libstdc++ compilation * disable fortran and objc build for now * bump PR
-rw-r--r--recipes/gcc/gcc-cross_csl-arm-2005q3.bb5
-rw-r--r--recipes/gcc/gcc-csl-arm-2005q3.inc5
-rw-r--r--recipes/gcc/gcc-csl-arm/demangle.patch22
-rw-r--r--recipes/gcc/gcc-csl-arm/libstdc++_configure.patch14
4 files changed, 44 insertions, 2 deletions
diff --git a/recipes/gcc/gcc-cross_csl-arm-2005q3.bb b/recipes/gcc/gcc-cross_csl-arm-2005q3.bb
index 39abdeb500..112bfe5736 100644
--- a/recipes/gcc/gcc-cross_csl-arm-2005q3.bb
+++ b/recipes/gcc/gcc-cross_csl-arm-2005q3.bb
@@ -1,4 +1,7 @@
-PR = "r7"
+PR = "r8"
+
+OBJC = ""
+FORTRAN = ""
require gcc-csl-arm-2005q3.inc
require gcc-cross.inc
diff --git a/recipes/gcc/gcc-csl-arm-2005q3.inc b/recipes/gcc/gcc-csl-arm-2005q3.inc
index 5d77ecbd07..55bbe4b13a 100644
--- a/recipes/gcc/gcc-csl-arm-2005q3.inc
+++ b/recipes/gcc/gcc-csl-arm-2005q3.inc
@@ -8,7 +8,10 @@ FILESDIR = "${FILE_DIRNAME}/gcc-csl-arm"
SRC_URI = "http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi.src.tar.bz2 \
file://gcc_optab_arm.patch;patch=1 \
- file://gcc-3.4.4-eabi-bigendian.patch;patch=1"
+ file://gcc-3.4.4-eabi-bigendian.patch;patch=1 \
+ file://libstdc++_configure.patch;patch=1 \
+ file://demangle.patch;patch=1 \
+ "
S = "${WORKDIR}/gcc-2005q3"
diff --git a/recipes/gcc/gcc-csl-arm/demangle.patch b/recipes/gcc/gcc-csl-arm/demangle.patch
new file mode 100644
index 0000000000..f6ad721441
--- /dev/null
+++ b/recipes/gcc/gcc-csl-arm/demangle.patch
@@ -0,0 +1,22 @@
+Index: gcc-2005q3/libiberty/cp-demangle.c
+===================================================================
+--- gcc-2005q3.orig/libiberty/cp-demangle.c 2009-10-20 00:40:24.353743504 +0200
++++ gcc-2005q3/libiberty/cp-demangle.c 2009-10-20 00:40:49.418955689 +0200
+@@ -1404,7 +1404,7 @@
+
+ #define NL(s) s, (sizeof s) - 1
+
+-CP_STATIC_IF_GLIBCPP_V3
++/*CP_STATIC_IF_GLIBCPP_V3*/
+ const struct demangle_operator_info cplus_demangle_operators[] =
+ {
+ { "aN", NL ("&="), 2 },
+@@ -1744,7 +1744,7 @@
+ ::= u <source-name>
+ */
+
+-CP_STATIC_IF_GLIBCPP_V3
++/*CP_STATIC_IF_GLIBCPP_V3*/
+ const struct demangle_builtin_type_info
+ cplus_demangle_builtin_types[D_BUILTIN_TYPE_COUNT] =
+ {
diff --git a/recipes/gcc/gcc-csl-arm/libstdc++_configure.patch b/recipes/gcc/gcc-csl-arm/libstdc++_configure.patch
new file mode 100644
index 0000000000..ee7105d3d4
--- /dev/null
+++ b/recipes/gcc/gcc-csl-arm/libstdc++_configure.patch
@@ -0,0 +1,14 @@
+Index: gcc-2005q3/libstdc++-v3/configure
+===================================================================
+--- gcc-2005q3.orig/libstdc++-v3/configure 2009-10-20 00:20:18.975521386 +0200
++++ gcc-2005q3/libstdc++-v3/configure 2009-10-20 00:20:48.563010077 +0200
+@@ -93680,7 +93680,8 @@
+ case "$target" in
+ *arm*-symbianelf)
+ LIBSUPCXX_PRONLY=yes;;
+- *);;
++ *)
++ LIBSUPCXX_PRONLY=no;;
+ esac
+
+